Sumarización de Rutas en EIGRP: Automática y Manual

Se explica cómo configurar la sumarización automática de EIGRP y cómo configurar la sumarización manual de EIGRP. Aquí se describen comandos y ejemplos.

¡Bienvenido a CCNA desde Cero!: Este tema forma parte del Capítulo 8 del curso de Cisco CCNA 2, para un mejor seguimiento del curso puede ir a la sección CCNA 3 para guiarse del índice.

EIGRP es un protocolo de routing versátil que se puede ajustar de muchas formas. Dos de las capacidades de ajuste más importantes son la de resumir rutas y la de implementar el balanceo de carga. Otras capacidades de ajuste son la propagación de una ruta predeterminada, el ajuste de temporizadores y la implementación de la autenticación entre vecinos EIGRP para aumentar la seguridad.

En este capítulo, se tratan estas características adicionales de ajuste y los comandos del modo de configuración para implementarlas para IPv4 e IPv6.

1. Sumarización automática

Antes de ajustar las características de EIGRP, empiece con una implementación básica de EIGRP.

En la Imagen 1, se muestra la topología de la red que se usa en este capítulo.

Métricas Topología EIGRP para IPv4

Imagen 1: Topología EIGRP para IPv4

En las Imágenes 2, 3 y 4, se muestra la configuración de interfaces IPv4 y las implementaciones de EIGRP en el R1, el R2 y el R3, respectivamente.

Es posible que los tipos de interfaces seriales y sus anchos de banda asociados no reflejen necesariamente los tipos de conexiones más frecuentes que se encuentran en las redes en la actualidad. Los anchos de banda de los enlaces seriales que se usan en esta topología ayudan a explicar el cálculo de las métricas de los protocolos de routing y el proceso de selección de la mejor ruta.

Observe que se usaron los comandos bandwidth en las interfaces seriales para modificar el ancho de banda predeterminado de 1544 kb/s.

En este capítulo, el router ISP se usa como gateway del dominio de routing a Internet. Los tres routers ejecutan el IOS de Cisco, versión 15.2.

1.1. Sumarización automática de EIGRP

Uno de los métodos de ajuste más comunes de EIGRP es habilitar y deshabilitar la sumarización automática de rutas.

La sumarización de ruta permite que un router agrupe redes y las anuncie como un gran grupo por medio de una única ruta resumida. La capacidad para resumir rutas es necesaria debido al rápido crecimiento de las redes.

Un router de frontera es un router que se ubica en el límite de una red. Este router debe poder anunciar todas las redes conocidas dentro de su tabla de rutas a un router de red o router ISP conector. Potencialmente, esta convergencia puede dar como resultado tablas de rutas muy grandes.

La sumarización disminuye la cantidad de entradas en las actualizaciones de enrutamiento y reduce la cantidad de entradas en las tablas de enrutamiento locales. Reduce, además, el uso del ancho de banda para las actualizaciones de enrutamiento y acelera las búsquedas en las tablas de enrutamiento.

Para limitar la cantidad de anuncios de routing y el tamaño de las tablas de routing, los protocolos de routing, como EIGRP, utilizan la sumarización automática en los límites con clase. Esto significa que EIGRP reconoce las subredes como una única red de clase A, B o C y crea solo una entrada en la tabla de routing para la ruta resumida. Como resultado, todo el tráfico destinado a las subredes viaja por esa ruta.

Cómo Funciona la Sumarización automática

En la ilustración, se muestra un ejemplo de la manera en que funciona la sumarización automática.

Cómo funciona Sumarización automática

Imagen 5: Sumarización automática en el límite de una red con clase

  • Los routers R1 y R2 están configurados con EIGRP para IPv4, con sumarización automática. El R1 tiene tres subredes en la tabla de routing: 172.16.1.0/24, 172.16.2.0/24 y 172.16.3.0/24.
  • En la arquitectura de direccionamiento de redes con clase, todas estas subredes se consideran parte de una red de clase B más grande: 172.16.0.0/16.
  • Debido a que EIGRP en el router R1 está configurado para sumarización automática, cuando envía la actualización de routing al R2, resume las tres subredes /24 como una única red 172.16.0.0/16. Esto reduce la cantidad de actualizaciones de routing que se envían y la cantidad de entradas en la tabla de routing IPv4 del R2.
  • Todo el tráfico destinado a las tres subredes viaja a través de la única ruta. El R2 no mantiene rutas a subredes individuales y no se descubre información de subredes.

En una red empresarial, es posible que la ruta elegida para alcanzar la ruta sumarizada no sea la mejor elección para el tráfico que está intentando alcanzar la subred individual.

La única forma en que todos los routers pueden encontrar las mejores rutas para cada subred individual es que los vecinos envíen información sobre las subredes. En esta situación, se debe deshabilitar la sumarización automática.

Cuando se deshabilita la sumarización automática, las actualizaciones incluyen información de subredes.

1.2. Configuración de la sumarización automática de EIGRP

Nota: La sumarización automática de EIGRP para IPv4 está deshabilitada de manera predeterminada a partir de las versiones 15.0(1)M y 12.2(33) del IOS de Cisco.

En la Imagen 6, el resultado del comando show ip protocols en el R1 indica que la sumarización automática de EIGRP está deshabilitada.

Verificación si la sumarización automática está deshabilitada

Imagen 6: Verificación de si la sumarización automática está deshabilitada

Este router ejecuta IOS 15.2; por ende, la sumarización automática de EIGRP está deshabilitada de manera predeterminada.

En la Imagen 7, se muestra la tabla de routing actual del R3. Observe que la tabla de routing IPv4 del R3 contiene todas las redes y subredes dentro del dominio de routing EIGRP.

Verificación si rutas no se resumen automáticamente

Imagen 7: Verificación de si las rutas no se resumen automáticamente

Para habilitar la sumarización automática de EIGRP, use el comando auto-summary en el modo de configuración del router, como se muestra en la Imagen 8:

Configuración de la sumarización automática

Imagen 8: Configuración de la sumarización automática

R1(config)# router eigrp as-number
R1(config-router)# auto-summary

La forma no de este comando se usa para deshabilitar la sumarización automática.

2. Verificación de la sumarización automática


2.1. Comando show ip protocols

En la Imagen 1 (más arriba), observe que el dominio de routing EIGRP tiene tres redes con clase:

  • La red de clase B 172.16.0.0/16, que consta de las subredes 172.16.1.0/24, 172.16.2.0/24 y 172.16.3.0/30.
  • La red de clase C 192.168.10.0/24, que consta de las subredes 192.168.10.4/30 y 192.168.10.8/30.
  • La red de clase C 192.168.1.0/24, que no está dividida en subredes.

El resultado del comando show ip protocols en el R1, que aparece en la Imagen 9, muestra que la sumarización automática ahora está habilitada. El resultado también indica cuáles redes están resumidas y en qué interfaces.

Verificación si la sumarización automática está habilitada

Imagen 9: Verificación de si la sumarización automática está habilitada

Observe que el R1 resume dos redes en las actualizaciones de routing EIGRP:

  • 192.168.10.0/24 enviada por las interfaces GigabitEthernet 0/0 y Serial 0/0/0
  • 172.16.0.0/16 enviada por la interfaz Serial 0/0/1

El R1 tiene las subredes 192.168.10.4/30 y 192.168.10.8/30 en la tabla de routing IPv4.

Resumen de Redes

Como se indica en la Imagen 10, el R1 resume las subredes 192.168.10.4/30 y 192.168.10.8/30 y reenvía la dirección resumida 192.168.10.0/24 a los vecinos en las interfaces Serial 0/0/0 y GigabitEthernet 0/0. Debido a que el R1 no tiene vecinos EIGRP en la interfaz GigabitEthernet 0/0, solo el R2 recibe la actualización de routing resumida.

Resumen de 192.168.10.0

Imagen 10: Resumen de 192.168.10.0/24 del R1

Como se indica en la Imagen 11, el R1 también tiene las subredes 172.16.1.0/24, 172.16.2.0/24 y 172.16.3.0/30 en la tabla de routing IPv4.

Resumen de 172.16.0.0

Imagen 11: Resumen de 172.16.0.0/16 del R1

El R3 selecciona al R1 como el sucesor a 172.16.0.0/16, porque tiene una distancia factible menor. La interfaz S0/0/0 del R3 que se conecta al R1 usa un ancho de banda predeterminado de 1544 kb/s. El enlace del R3 al R2 tiene una distancia factible más alta, debido a que la interfaz S0/0/1 del R3 se configuró con un ancho de banda inferior a 1024 kb/s.

Observe que la actualización resumida de 172.16.0.0/16 no se envía por las interfaces GigabitEthernet 0/0 ni Serial 0/0/0 del R1. Esto se debe a que estas dos interfaces son miembros de la misma red de clase B 172.16.0.0/16. El R1 envía la actualización de routing no resumida de 172.16.1.0/24 al R2.

Las actualizaciones resumidas solo se envían por interfaces en diferentes redes principales con clase.

2.2. Tabla de topología

En la Imagen 12, los routers R1 y R2 envían al R3 una actualización de routing EIGRP resumida de 172.16.0.0/16.

Tabla de topología Rutas Resumidas

Imagen 12: Tabla de topología EIGRP para IPv4

Las tablas de routing del R1 y el R2 tienen subredes de la red 172.16.0.0/16, por lo tanto, ambos routers envían al R3 anuncios resumidos a través de una red principal diferente.

A continuación, se muestra el resultado del comando show ip eigrp topology all-links que se usó para ver la tabla completa de topología de EIGRP del R3.

R3# show ip eigrp topology all-links
P 172.16.0.0/16, 1 successors, FD is 2170112, serno 9
 via 192.168.10.5 (2170112/2816), Serial0/0/0
 via 192.168.10.9 (3012096/2816), Serial0/0/1

Esto verifica que el R3 recibió la ruta resumida 172.16.0.0/16 tanto del R1 en 192.168.10.5 como del R2 en 192.168.10.9.

La primera entrada a través de 192.168.10.5 es el sucesor, y la segunda entrada a través de 192.168.10.9 es el sucesor factible. El R1 es el sucesor porque su enlace de 1544 kb/s al R3 le da a este último un mejor costo EIGRP a 172.16.0.0/16 que el del R2, que usa un enlace más lento de 1024 kb/s.

La opción all-links muestra todas las actualizaciones recibidas, independientemente de si la ruta califica como sucesor factible (FS) o no. En este caso, el R2 califica como FS. El R2 se considera un FS debido a que la distancia notificada (RD) de 2816 es menor que la distancia factible (FD) de 2 170 112 a través del R1.

2.3. Tabla de routing

Examine la tabla de routing para verificar que se haya recibido la ruta resumida.

En la Imagen 13, se muestra la tabla de routing del R3 antes de la sumarización automática.

Sumarización automática deshabilitada

Imagen 13: Sumarización automática deshabilitada

En la Imagen 14, se muestra la tabla de routing del R3 con la sumarización automática habilitada mediante el comando auto-summary.

Sumarización automática habilitada

Imagen 14: Sumarización automática habilitada

Observe que con la sumarización automática habilitada, la tabla de routing del R3 ahora solo la dirección de red de clase B 172.16.0.0/16. El sucesor o el router de siguiente salto es el R1, a través de 192.168.10.5.

Nota: la sumarización automática solo es una opción con EIGRP para IPv4. El direccionamiento con clase no existe en IPv6, por lo tanto, la sumarización automática no es necesaria con EIGRP para IPv6.

La interfaz nula

En el momento de habilitar la sumarización automática, también es necesario entender la interfaz nula (Null). En la Imagen 15, se muestra la tabla de routing del R1.

Resumen de rutas Null0 en el R1

Imagen 15: Resumen de rutas Null0 en el R1

Observe que en las dos entradas destacadas se usa una interfaz de salida Null0. EIGRP automáticamente incluyó una ruta resumida a Null0 para dos redes con clase: 192.168.10.0/24 y 172.16.0.0/16.

La interfaz Null0 es una interfaz virtual del IOS que constituye una ruta hacia ninguna parte, comúnmente conocida como “el limbo electrónico”. Los paquetes que vinculan una ruta con una interfaz de salida Null0 se descartan.

EIGRP para IPv4 automáticamente incluye un resumen de rutas Null0 cuando se producen las siguientes condiciones:

  • Por lo menos existe una subred que se aprendió a través de EIGRP.
  • Hay dos o más comandos network del modo de configuración del router EIGRP.
  • La sumarización automática se encuentra habilitada.

El objetivo del resumen de rutas Null0 es evitar bucles de routing hacia destinos que se incluyen en el resumen, pero que no existen realmente en la tabla de routing.

3. Ruta resumida

En la ilustración, se muestra una situación en la que podría producirse un bucle de routing:

Ejemplo de un bucle de routing

Imagen 16: Ejemplo de un bucle de routing

  1. El R1 tiene una ruta predeterminada 0.0.0.0/0 mediante el router ISP.
  2. El R1 envía una actualización de routing al R2 con la ruta predeterminada.
  3. El R2 instala la ruta predeterminada del R1 en su tabla de routing IPv4.
  4. La tabla de routing del R2 contiene las subredes 172.16.1.0/24, 172.16.2.0/24 y 172.16.3.0/24 en su tabla de routing.
  5. El R2 envía una actualización resumida al R1 para la red 172.16.0.0/16.
  6. El R1 instala la ruta resumida para 172.16.0.0/16 mediante el R2.
  7. El R1 recibe un paquete para 172.16.4.10. Debido a que el R1 tiene una ruta para 172.16.0.0/16 mediante el R2, reenvía el paquete al R2.
  8. El R2 recibe el paquete con la dirección de destino 172.16.4.10 del R1. El paquete no coincide con ninguna ruta específica, de manera que, mediante la ruta predeterminada en su tabla de routing, el R2 reenvía el paquete de regreso al R1.
  9. El paquete para 172.16.4.10 va y viene en un bucle entre el R1 y el R2 hasta que el TTL expira y el paquete se descarta.

3.1. Null0 frente a un bucle de routing

EIGRP usa la interfaz Null0 para evitar estos tipos de bucles de routing. En la ilustración, se muestra una situación en la que una ruta Null0 evita que se produzca un bucle de routing como el que se explicó en el ejemplo anterior:

La ruta Null0 evita bucles

Imagen 17: La ruta Null0 se usa para evitar bucles

  1. El R1 tiene una ruta predeterminada 0.0.0.0/0 mediante el router ISP.
  2. El R1 envía una actualización de routing al R2 con la ruta predeterminada.
  3. El R2 instala la ruta predeterminada del R1 en su tabla de routing IPv4.
  4. La tabla de routing del R2 contiene las subredes 172.16.1.0/24, 172.16.2.0/24 y 172.16.3.0/24 en su tabla de routing.
  5. El R2 instala la ruta resumida 172.16.0.0/16 a Null0 en la tabla de routing.
  6. El R2 envía una actualización resumida al R1 para la red 172.16.0.0/16.
  7. El R1 instala la ruta resumida para 172.16.0.0/16 mediante el R2.
  8. El R1 recibe un paquete para 172.16.4.10. Debido a que el R1 tiene una ruta para 172.16.0.0/16 mediante el R2, reenvía el paquete al R2.
  9. El R2 recibe el paquete con la dirección de destino 172.16.4.10 del R1. El paquete no coincide con ninguna subred específica de 172.16.0.0, pero coincide con la ruta resumida 172.16.0.0/16 a Null0. Mediante la ruta Null0, se descarta el paquete.

Una ruta resumida en el R2 para 172.16.0.0/16 a la interfaz Null0 descarta cualquier paquete que empiece con 172.16.x.x y que no tenga una coincidencia más larga con ninguna de las subredes: 172.16.1.0/24, 172.16.2.0/24 o 172.16.3.0/24.

Incluso si el R2 tiene una ruta predeterminada 0.0.0.0/0 en la tabla de routing, la ruta Null0 es una coincidencia más larga.

Nota: el resumen de rutas Null0 se elimina cuando se deshabilita la sumarización automática con el comando no auto-summary del modo de configuración del router.

4. Sumarización manual

EIGRP puede configurarse para que resuma rutas, ya sea que se encuentre habilitado la sumarización automática (auto-summary) o no.

Debido a que EIGRP es un protocolo de enrutamiento sin clase e incluye la máscara de subred en las actualizaciones de enrutamiento, la sumarización manual puede incluir rutas de superredes. Recuerde, una superred es un agregado de múltiples direcciones de redes principales con clase.

En la Imagen 18, se agregan dos redes más al router R3 con las interfaces loopback: 192.168.2.0/24 y 192.168.3.0/24. Aunque las interfaces loopback son interfaces virtuales, en este ejemplo se usan para representar redes físicas.

Topología EIGRP IPv4 Sumarización Manual

Imagen 18: Topología EIGRP IPv4 Sumarización Manual

A continuación, se muestran los comandos para configurar las dos interfaces loopback y la configuración para habilitar ambas interfaces para EIGRP en el R3.

R3(config)# interface loopback 2 
R3(config-if)# ip add 192.168.2.1 255.255.255.0 
R3(config-if)# exit 
R3(config)# interface loopback 3 
R3(config-if)# ip add 192.168.3.1 255.255.255.0 
R3(config-if)# exit 
R3(config)# router eigrp 1 
R3(config-router)# network 192.168.2.0 
R3(config-router)# network 192.168.3.0

Para verificar que el R3 envió los paquetes de actualización EIGRP al R1 y al R2, se examinan las tablas de routing de ambos routers.

A continaución, solo se muestran las rutas pertinentes. En las tablas de routing del R1 y el R2 se muestran estas redes adicionales: 192.168.2.0/24 y 192.168.3.0/24.

R1# show ip route
D 192.168.1.0/24 [90/2170112] via 192.168.10.6, 00:47:39,Serial0/0/1
D 192.168.2.0/24 [90/2297856] via 192.168.10.6, 00:08:09,Serial0/0/1
D 192.168.3.0/24 [90/2297856] via 192.168.10.6, 00:08:04,Serial0/0/1
R1#
R2# show ip route
D 192.168.1.0/24 [90/3012096] via 192.168.10.10, 00:47:58,Serial0/0/1
D 192.168.2.0/24 [90/3139840] via 192.168.10.10, 00:08:28,Serial0/0/1
D 192.168.3.0/24 [90/3139840] via 192.168.10.10, 00:08:23,Serial0/0/1
R2#

En lugar de enviar tres redes por separado, el R3 puede resumir las redes 192.168.1.0/24, 192.168.2.0/24 y 192.168.3.0/24 como una única ruta.

4.1. Configuración de rutas resumidas manuales EIGRP

Determinación de la ruta sumarizada EIGRP

En la figura 1, se muestra las dos rutas resumidas manuales que están configuradas en el R3. Estas rutas resumidas se envían por las interfaces Serial 0/0/0 y Serial 0/0/1 a los vecinos EIGRP del R3.

Configuración de rutas resumidas manuales EIGRP

Imagen 19: Topología EIGRP para IPv4

Para determinar el resumen de estas tres redes, se usa el mismo método que para determinar rutas estáticas resumidas, como se muestra en la Imagen 20:

Cálculo de ruta resumida

Imagen 20: Cálculo de una ruta resumida

  • Paso 1. Escriba las redes que se resumirán en formato binario.
  • Paso 2. Para encontrar la máscara de subred para la sumarización, empiece con el bit del extremo izquierdo.
  • Paso 3. De izquierda a derecha, encuentre todos los bits que coincidan en forma consecutiva.
  • Paso 4. Cuando haya una columna de bits que no coincidan, deténgase. Este es el límite de resumen.
  • Paso 5. Cuente el número de bits coincidentes que se encuentran en el extremo izquierdo. En el ejemplo, es 22. Este número se usa para determinar la máscara de subred de la ruta resumida: /22 o 255.255.252.0.
  • Paso 6. Para encontrar la dirección de red para el resumen, copie los 22 bits que coinciden y agregue a todos los bits 0 al final para obtener 32 bits.

El resultado es la dirección de red resumida y la máscara para 192.168.0.0/22.

Configuración de la sumarización manual de EIGRP

Para establecer la sumarización manual EIGRP en una interfaz EIGRP específica, utilice el siguiente comando del modo de configuración de interfaz:

Router(config-if)# ip summary-address eigrp as-number network-address subnet-mask

A continuación, se muestra la configuración para propagar una ruta resumida manual en la interfaz Serial 0/0/0 del R3. Debido a que el R3 tiene dos vecinos EIGRP, la sumarización manual de EIGRP debe configurarse tanto en Serial 0/0/0 como en Serial 0/0/1.

R3(config)# interface serial 0/0/0
R3(config-if)# ip summary-address eigrp 1 192.168.0.0
255.255.252.0
R3(config-if)#

4.3. Verificación de las rutas resumidas manuales

A continuación se muestra que, después de configurar la ruta resumida, las tablas de routing del R1 y el R2 ya no incluyen las redes individuales 192.168.1.0/24, 192.168.2.0/24 y 192.168.3.0/24.

R1# show ip route
D 192.168.0.0/22 [90/2170112] via 192.168.10.6, 01:53:19, 
Serial0/0/1
R1#
R2# show ip route
D 192.168.0.0/22 [90/3012096] via 192.168.10.10, 01:53:33, 
Serial0/0/1
R2#

En cambio, muestran una única ruta resumida: 192.168.0.0/22. Las rutas resumidas reducen el número total de rutas en las tablas de routing, lo que hace que el proceso de búsqueda en dichas tablas sea más eficaz.

Estas rutas también requieren menor utilización de ancho de banda para las actualizaciones de routing, ya que se puede enviar una única ruta en lugar de varias rutas individuales.

4.4. EIGRP para IPv6: rutas resumidas manuales

Si bien la sumarización automática no está disponible para redes IPv6 EIGRP, es posible habilitar la sumarización manual para estas redes.

En la Imagen 21, se muestra la topología IPv6 EIGRP con cuatro direcciones de loopback configuradas en el R3. Estas direcciones virtuales se utilizan para representar redes físicas en la tabla de routing IPv6 del R3. En EIGRP para IPv6, estas redes pueden resumirse manualmente.

Topología EIGRP para IPv6 Sumarización Manual

Imagen 21: Topología EIGRP para IPv6

Ahora, se muestra la configuración de las direcciones de loopback IPv6 en el R3.

R3(config)# interface loopback 11 
R3(config-if)# ipv6 address 2001:db8:acad:1::1/64
R3(config-if)# ipv6 eigrp 2
R3(config-if)# exit
R3(config)# interface loopback 12 
R3(config-if)# ipv6 address 2001:db8:acad:2::1/64
R3(config-if)# ipv6 eigrp 2
R3(config-if)# exit
R3(config)# interface loopback 13 
R3(config-if)# ipv6 address 2001:db8:acad:3::1/64
R3(config-if)# ipv6 eigrp 2
R3(config-if)# exit
R3(config)# interface loopback 14 
R3(config-if)# ipv6 address 2001:db8:acad:4::1/64
R3(config-if)# ipv6 eigrp 2

Solo se muestran cuatro direcciones de loopback en la topología, que están configuradas en el R3; sin embargo, para este ejemplo, se da por sentado que se puede llegar a todas las subredes de 2001:DB8:ACAD::/48 a través del R3.

Para configurar la sumarización manual de EIGRP para IPv6 en una interfaz EIGRP específica, utilice el siguiente comando del modo de configuración de interfaz:

Router(config-if)# ipv6 summary-address eigrp as-number prefix/prefix-length

En la Imagen 22, se muestra la configuración para propagar una ruta resumida manual EIGRP para IPv6 al R1 y al R2, para el prefijo 2001:DB8:ACAD::/48.

Configuración resumen manual IPv6 en R3

Imagen 22: Configuración de resumen manual IPv6 en el R3

De manera similar a lo que sucede en EIGRP para IPv4, el R3 incluye una ruta resumida a null0 para evitar la formación de bucles.

La recepción de la ruta resumida manual se puede verificar mediante la revisión de la tabla de routing de los otros routers en el dominio de routing.

Por último, se muestra la ruta 2001:DB8:ACAD::/48 en la tabla de routing IPv6 del R1.

R1# show ipv6 route | include 2001:DB8:ACAD::
D 2001:DB8:ACAD::/48 [90/2297856]
R1#
Sin respuestas a “Sumarización de Rutas en EIGRP: Automática y Manual”

Deja un Comentario