Configuración de EIGRP para IPv6

Se explica con un ejemplo cómo configurar EIGRP para IPv6 en una red enrutada pequeña. Además, se compara su implementación con EIGRP para Ipv4 y se detallan todos los comandos básicos para su configuración.

¡Bienvenido a CCNA desde Cero!: Este tema forma parte del Capítulo 7 del curso de Cisco CCNA 2, para un mejor seguimiento del curso puede ir a la sección CCNA 3 para guiarse del índice.

De manera similar a su homólogo para IPv4, EIGRP para IPv6 intercambia información de routing para completar la tabla de routing IPv6 con prefijos remotos. EIGRP para IPv6 está disponible a partir del IOS de Cisco versión 12.4(6)T.

Nota: en IPv6, la dirección de red se denomina “prefijo” y la máscara de subred se denomina “longitud de prefijo”.

EIGRP para IPv6 tiene la misma funcionalidad que EIGRP para IPv4, pero utiliza IPv6 como el protocolo de capa de red, se comunica con peers EIGRP para IPv6 y anuncia rutas IPv6.

EIGRP para IPv6 también usa DUAL como motor de cómputo para garantizar rutas principales y de respaldo sin bucles a través de todo el dominio de routing.

Al igual que con todos los protocolos de routing IPv6, EIGRP para IPv6 tiene procesos separados de los de su homólogo para IPv4. Los procesos y las operaciones son básicamente los mismos que en el protocolo de routing IPv4; no obstante, se ejecutan de manera independiente.

EIGRP para IPv4 y EIGRP para IPv6

Imagen 1: EIGRP para IPv4 y EIGRP para IPv6

EIGRP para IPv4 y EIGRP para IPv6 tienen tablas de vecinos EIGRP, tablas de topología EIGRP y tablas de IP routing separadas, como se muestra en la ilustración. EIGRP para IPv6 es un módulo dependiente de protocolo (PDM) separado.

Los comandos de configuración y verificación de EIGRP para IPv6 son muy similares a los que se utilizan en EIGRP para IPv4. Estos comandos se describen más adelante en esta sección.

1. Comparación entre EIGRP para IPv4 e IPv6

La siguiente es una comparación de las principales características de EIGRP para IPv4 e EIGRP para IPv6:

Comparación entre EIGRP para IPv4 e IPv6

Imagen 2: Comparación entre EIGRP para IPv4 e IPv6

  • Rutas anunciadas: EIGRP para IPv4 anuncia redes IPv4, mientras que EIGRP para IPv6 anuncia prefijos IPv6.
  • Vector distancia: EIGRP para IPv4 y para IPv6 son protocolos de routing vector distancia avanzados. Ambos protocolos usan las mismas distancias administrativas.
  • Tecnología de convergencia: tanto EIGRP para IPv4 como para IPv6 usan el algoritmo DUAL. Ambos protocolos usan las mismas técnicas y procesos de DUAL, incluidos sucesor, FS, FD y RD.
  • Métrica: tanto EIGRP para IPv4 como para IPv6 usan ancho de banda, retraso, confiabilidad y carga para su métrica compuesta.
  • Protocolo de transporte: el protocolo de transporte confiable (RTP) es responsable de la entrega garantizada de paquetes EIGRP a todos los vecinos para ambos protocolos, EIGRP para IPv4 y para IPv6.
  • Mensajes de actualización: tanto EIGRP para IPv4 como para IPv6 envían actualizaciones incrementales cuando el estado de un destino cambia. Los términos “parcial” y “limitada” se usan para hacer referencia a las actualizaciones de ambos protocolos.
  • Mecanismo de descubrimiento de vecinos: tanto EIGRP para IPv4 como EIGRP para IPv6 utilizan un simple mecanismo de saludo para descubrir routers vecinos y formar adyacencias.
  • Direcciones de origen y destino: EIGRP para IPv4 envía mensajes a la dirección de multidifusión 224.0.0.10. EIGRP para IPv6 envía sus mensajes a la dirección de multidifusión FF02::A.
  • Autenticación: EIGRP para IPv4 puede usar autenticación de texto no cifrado o autenticación de síntesis del mensaje 5 (MD5). EIGRP para IPv6 usa MD5.
  • ID del router: EIGRP para IPv4 y EIGRP para IPv6 usan un número de 32 bits para la ID del router EIGRP.

2. Direcciones IPv6 link-local

Los routers que ejecutan un protocolo de routing dinámico, como EIGRP, intercambian mensajes entre vecinos en la misma subred o el mismo enlace.

Los routers solo necesitan enviar y recibir mensajes de protocolo de routing con sus vecinos conectados directamente. Estos mensajes siempre se envían desde la dirección IP de origen del router que realiza el reenvío.

EIGRP para IPv6 y direcciones link-local

Imagen 3: EIGRP para IPv6 y direcciones link-local

Las direcciones IPv6 link-local son ideales para este propósito. Una dirección IPv6 link-local permite que un dispositivo se comunique con otros dispositivos con IPv6 habilitado en el mismo enlace y solo en ese enlace (subred).

Los paquetes con una dirección link-local de origen o de destino no se pueden enrutar más allá del enlace en el cual se originó el paquete.

Los mensajes EIGRP para IPv6 se envían mediante lo siguiente:

  • Dirección IPv6 de origen: esta es la dirección IPv6 link-local de la interfaz de salida.
  • Dirección IPv6 de destino: cuando debe enviarse un paquete a una dirección de multidifusión, se envía a la dirección IPv6 de multidifusión FF02::A, el ámbito de todos los routers EIGRP con link-local. Si el paquete puede enviarse como una dirección de unidifusión, se envía a la dirección link-local del router vecino.

Nota: las direcciones IPv6 link-local están en el rango de FE80::/10. El valor /10 indica que los primeros 10 bits son 1111 1110 10xx xxxx, lo que da como resultado un primer hexteto con el rango de 1111 1110 1000 0000 (FE80) a 1111 1110 1011 1111 (FEBF).

3. Ejemplo: Configurar EIGRP para IPv6

En la Imagen 4, se muestra la topología de la red que se utiliza para configurar EIGRP para IPv6. Si en la red se ejecuta dual-stack y se utilizan IPv4 e IPv6 en todos los dispositivos, se puede configurar tanto EIGRP para IPv4 como para IPv6 en todos los routers. No obstante, esta sección se centra solamente en EIGRP para IPv6.

Topología EIGRP para IPv6

Imagen 4: Topología EIGRP para IPv6

Solo las direcciones IPv6 de unidifusión global se configuraron en cada router.

A continuación, se muestra la configuración de inicio de interfaz en cada router.


R1# show running-config
interface GigabitEthernet0/0
 ipv6 address 2001:DB8:CAFE:1::1/64
!
interface Serial0/0/0
 ipv6 address 2001:DB8:CAFE:A001::1/64
 clock rate 64000
!
interface Serial0/0/1
 ipv6 address 2001:DB8:CAFE:A003::1/64
R2# show running-config
!
interface GigabitEthernet0/0
 ipv6 address 2001:DB8:CAFE:2::1/64
!
interface Serial0/0/0
 ipv6 address 2001:DB8:CAFE:A001::2/64
!
interface Serial0/0/1
 ipv6 address 2001:DB8:CAFE:A002::1/64
 clock rate 64000
!
interface Serial0/1/0
 ipv6 address 2001:DB8:FEED:1::1/64
R3# show running-config
!
interface GigabitEthernet0/0
 ipv6 address 2001:DB8:CAFE:3::1/64
!
interface Serial0/0/0
 ipv6 address 2001:DB8:CAFE:A003::2/64
 clock rate 64000
! 
interface Serial0/0/1
 ipv6 address 2001:DB8:CAFE:A002::2/64

Observe los valores de ancho de banda de interfaz de la configuración EIGRP para IPv4 previa. Debido a que EIGRP utiliza las mismas métricas para IPv4 e IPv6, modificar los parámetros de ancho de banda influye en ambos protocolos de routing.

4. Configuración de direcciones IPv6 link-local

Las direcciones link-local se crean de manera automática cuando se asigna una dirección IPv6 de unidifusión global a la interfaz. No se requieren direcciones de unidifusión global en una interfaz, pero sí se requieren direcciones IPv6 link-local.

A menos que se configuren manualmente, los routers Cisco crean la dirección link-local utilizando el prefijo FE80::/10 y el proceso EUI-64.

EUI-64 implica usar la dirección MAC de Ethernet de 48 bits, insertar FFFE en el medio e invertir el séptimo bit. Para las interfaces seriales, Cisco usa la dirección MAC de una interfaz Ethernet. Un router con varias interfaces seriales puede asignar la misma dirección link-local a cada interfaz IPv6, porque las direcciones link-local solo necesitan ser locales en el enlace.

Las direcciones link-local creadas con el formato EUI-64 o, en algunos casos, con ID de interfaces aleatorias, hacen que resulte difícil reconocer y recordar esas direcciones. Debido a que los protocolos de routing IPv6 utilizan direcciones IPv6 link-local para el direccionamiento de unidifusión y la información de dirección de siguiente salto en la tabla de routing, habitualmente se busca que sea una dirección fácil de reconocer. Configurar la dirección link-local manualmente permite crear una dirección reconocible y más fácil de recordar.

Las direcciones link-local se pueden configurar manualmente mediante el mismo comando del modo de configuración de interfaz que se utiliza para crear direcciones IPv6 de unidifusión global, pero con diferentes parámetros:

Router(config-if)# ipv6 address link-local-address link-local

Una dirección link-local tiene un prefijo dentro del rango FE80 a FEBF. Cuando una dirección comienza con este hexteto (segmento de 16 bits), la palabra clave link-local debe escribirse después de la dirección.

4.1. Ejemplo de Configuración

A continuación, se muestra la configuración de una dirección link-local mediante el comando ipv6 address del modo de configuración de interfaz.

R1(config)# interface s 0/0/0
R1(config-if)# ipv6 address fe80::1 ?
 link-local Use link-local address

R1(config-if)# ipv6 address fe80::1 link-local
R1(config-if)# exit
R1(config)# interface s 0/0/1
R1(config-if)# ipv6 address fe80::1 link-local
R1(config-if)# exit
R1(config)# interface g 0/0
R1(config-if)# ipv6 address fe80::1 link-local
R1(config-if)#

La dirección link-local FE80::1 se utiliza para que sea posible reconocer fácilmente que pertenece al router R1. Se configura la misma dirección IPv6 link-local en todas las interfaces de R1. Se puede configurar FE80::1 en cada enlace, debido a que solamente tiene que ser única en ese enlace.

De manera similar al R1, el router R2 se configura con FE80::2 como la dirección IPv6 link-local en todas sus interfaces.

R2(config)# interface s 0/0/0
R2(config-if)# ipv6 address fe80::2 link-local
R2(config-if)# exit
R2(config)# interface s 0/0/1
R2(config-if)# ipv6 address fe80::2 link-local
R2(config-if)# exit
R2(config)# interface s 0/1/0
R2(config-if)# ipv6 address fe80::2 link-local
R2(config-if)# exit
R2(config)# interface g 0/0
R2(config-if)# ipv6 address fe80::2 link-local
R2(config-if)#

Como se muestra en la Imagen 5, el comando show ipv6 interface brief se usa para verificar las direcciones IPv6 link-local y de unidifusión global en todas las interfaces.

Verificación de direcciones link-local

Imagen 5: Verificación de direcciones link-local en el R1

5. Configuración del proceso de routing EIGRP para IPv6

El comando ipv6 unicast-routing del modo de configuración global habilita el routing IPv6 en el router. Este comando es necesario antes de poder configurar cualquier protocolo de routing IPv6. No se requiere para configurar direcciones IPv6 en las interfaces, pero es necesario para habilitar el router como un router IPv6.

5.1. EIGRP para IPv6

El siguiente comando del modo de configuración global se utiliza para ingresar al modo de configuración del router para EIGRP para IPv6:

Router(config)# ipv6 router eigrp autonomous-system

De manera similar a lo que sucede en EIGRP para IPv4, el valor de autonomous-system debe ser el mismo en todos los routers en el dominio de routing. De acuerdo al siguiente esquema, el proceso de routing EIGRP para IPv6 no se pudo configurar hasta que el routing IPv6 se habilitó con el comando del modo de configuración global ipv6 unicast-routing.

R1(config)# ipv6 router eigrp 2 
% IPv6 routing not enabled
R1(config)# ipv6 unicast-routing 
R1(config)# ipv6 router eigrp 2 
R1(config-rtr)#

5.2. Id. de router

Como se muestra a continuación, el comando eigrp router-id se utiliza para configurar la ID del router.

R1(config)# ipv6 router eigrp 2
R1(config-rtr)# eigrp router-id 1.0.0.0
R1(config-rtr)#

EIGRP para IPv6 utiliza un valor de 32 bits para la ID del router. Para obtener ese valor, EIGRP para IPv6 utiliza el mismo proceso que EIGRP para IPv4. El comando eigrp router-id tiene prioridad sobre cualquier dirección de loopback o dirección IPv4 de interfaz física. Si un router EIGRP para IPv6 no tiene ninguna interfaz activa con una dirección IPv4, se requiere el comando eigrp router-id.

La ID del router debe ser un número único de 32 bits en el dominio de routing EIGRP para IP; de lo contrario, pueden ocurrir incongruencias de routing.

De manera predeterminada, el proceso EIGRP para IPv6 se encuentra en estado desactivado. Se requiere el comando no shutdown para activar el proceso EIGRP para IPv6, como se muestra a continuación:

R1(config)# ipv6 router eigrp 2 
R1(config-rtr)# eigrp router-id 1.0.0.0 
R1(config-rtr)# no shutdown

Este comando no se requiere para EIGRP para IPv4. Aunque EIGRP para IPv6 esté habilitado, no se pueden enviar ni recibir actualizaciones de adyacencias de vecinos ni de routing hasta que EIGRP se active en las interfaces apropiadas.

Se requieren el comando no shutdown y una ID de router para que el router establezca adyacencias de vecinos.

A continuación, se muestra la configuración de EIGRP para IPv6 completa para el router R2.

R2(config)# ipv6 unicast-routing 
R2(config)# ipv6 router eigrp 2 
R2(config-rtr)# eigrp router-id 2.0.0.0 
R2(config-rtr)# no shutdown

6. Comando de interfaz ipv6 eigrp

EIGRP para IPv6 utiliza un método diferente para habilitar una interfaz para EIGRP. En lugar de usar el comando network del modo de configuración del router para especificar las direcciones de interfaz que coinciden, EIGRP para IPv6 se configura directamente en la interfaz.

Utilice el siguiente comando del modo de configuración de interfaz para habilitar EIGRP para IPv6 en una interfaz:

Router(config-if)# ipv6 eigrp autonomous-system

De manera similar al comando network que se utiliza en EIGRP para IPv4, el comando ipv6 eigrp interface lleva a cabo lo siguiente:

  • Habilita la interfaz para que forme adyacencias y envíe o reciba actualizaciones de EIGRP para IPv6.
  • Incluye el prefijo (red) de la interfaz en las actualizaciones de routing EIGRP para IPv6.
Habilitación de EIGRP para IPv6 en una interfaz

Imagen 6: Habilitación de EIGRP para IPv6 en una interfaz

En la Imagen 6, se muestra la configuración para habilitar EIGRP para IPv6 en las interfaces de los routers R1 y R2. Observe el mensaje a continuación de la interfaz serial 0/0/0 en el R2:

%DUAL-5-NBRCHANGE: EIGRP-IPv6 2: Neighbor FE80::1 
(Serial0/0/0) is up: new adjacency

Este mensaje indica que el R2 formó una adyacencia EIGRP-IPv6 con el vecino en la dirección link-local FE80::1. Debido a que se configuraron direcciones link-local estáticas en los tres routers, es fácil determinar que esta adyacencia es con el router R1 (FE80::1).

6.1. Interfaz pasiva con EIGRP para IPv6

El mismo comando passive-interface que se utiliza para IPv4 se usa para configurar una interfaz como pasiva en EIGRP para IPv6. Como se muestra a continuación, se utiliza el comando show ipv6 protocols para verificar la configuración.

Configuración y verificación EIGRP para IPv6 con interfaz pasiva

Imagen 7: Configuración y verificación del EIGRP para IPv6 con una interfaz pasiva

Deja un Comentario

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.