Configuración Inicial del Router

Definimos qué es el router, su función en las redes, sus principales componentes de hardware y software, y el proceso de routing.

¡Bienvenido a CCNA desde Cero!: Este tema forma parte del Capítulo 1 del curso de Cisco CCNA 2, para un mejor seguimiento del curso puede ir a la sección CCNA 2 para guiarse del índice.

Ya hemos visto que los switches Ethernet funcionan en la capa de enlace de datos (la capa 2) y se utilizan para reenviar tramas de Ethernet entre dispositivos dentro de una misma red. Ahora, cuando las direcciones IP de origen y destino están en distintas redes, la trama de Ethernet se debe enviar a un router. Aquí empezamos!

Consideraciones importantes:

  • El router usa su tabla de routing para encontrar la mejor ruta para reenviar un paquete.
  • Cuando un host envía un paquete a un dispositivo en una red IP diferente, el paquete se reenvía al gateway predeterminado.
  • El gateway predeterminado es el destino que enruta el tráfico desde la red local hacia los dispositivos en las redes remotas.


1. ¿Por qué es necesario el routing?

En pocas palabras, un router conecta una red con otra red. La comunicación entre redes no sería posible sin un router que determine la mejor ruta hacia el destino y que reenvíe el tráfico al router siguiente en esa ruta. El router es responsable del routing del tráfico entre redes.

Y cuando hablamos de la mejor ruta nos damos cuenta de la velocidad con la que accedemos a una página web cuando hacemos clic en un enlace en el navegador.

En la siguiente imagen vemos que los routers interconectan las redes en los diferentes sitios. Cuando un paquete llega a una interfaz del router, este utiliza la tabla de routing para determinar cómo llegar a la red de destino.

Conexión del Router

Conexión del Router

Es responsabilidad de los routers entregar esos paquetes de forma eficaz. 

2. Los routers eligen las mejores rutas

Las funciones principales de un router son las siguientes:

  • Determinar la mejor ruta para enviar paquetes.
  • Reenviar paquetes a su destino.

Es sencillo, cuando el router recibe un paquete, analiza la dirección de destino del paquete y usa la tabla de routing para buscar la mejor ruta hacia esa red.

Un router puede recibir un paquete encapsulado en un tipo de trama de enlace de datos y reenviarlo por una interfaz que usa otro tipo de trama de enlace de datos. Precisamente, las distintas tecnologías de enlace de datos a las que se puede conectar un router incluyen Ethernet, PPP, Frame Relay, DSL, tecnología de cable y tecnología inalámbrica (802.11, Bluetooth, etc.).

2.1. Mecanismos de reenvío de paquetes

Los routers admiten tres mecanismos de reenvío de paquetes:

  • Switching de procesos: (antiguo y lento) Cuando un paquete llega a una interfaz, se reenvía al plano de control, donde la CPU hace coincidir la dirección de destino con una entrada de la tabla de routing y, a continuación, determina la interfaz de salida y reenvía el paquete. El router hace esto con cada paquete, incluso si el destino es el mismo para un flujo de paquetes.
Reenvío de paquetes - Switching de procesos

Reenvío de paquetes – Switching de procesos

El switching de procesos resuelve un problema realizando todos los cálculos matemáticos, incluso si los problemas son idénticos.

  • Switching rápido: Utiliza una memoria caché de switching rápido para almacenar la información de siguiente salto. Cuando un paquete llega a una interfaz, se reenvía al plano de control, donde la CPU busca una coincidencia en la caché de switching rápido. Si no encuentra ninguna, se aplica el switching de procesos al paquete, y este se reenvía a la interfaz de salida. Si otro paquete con el mismo destino llega a una interfaz, se vuelve a utilizar la información de siguiente salto de la caché sin intervención de la CPU.
Reenvío de paquetes - Switching rápido

Reenvío de paquetes – Switching rápido

El switching rápido resuelve un problema realizando todos los cálculos matemáticos una vez y recuerda la respuesta para los problemas posteriores idénticos.

  • Cisco Express Forwarding (CEF): Es el mecanismo de reenvío de paquetes más reciente y más utilizado del IOS de Cisco. Al igual que el switching rápido, CEF arma una base de información de reenvío (FIB) y una tabla de adyacencia. La FIB contiene búsquedas inversas calculadas previamente, información de siguiente salto para las rutas, incluida la información de interfaz y de capa 2.
Reenvío de paquetes - Cisco Express Forwarding

Reenvío de paquetes – Cisco Express Forwarding

CEF soluciona todos los problemas posibles antes de tiempo en una hoja de cálculo.

3. Conexión de dispositivos

Generalmente los dispositivos se conectan a una red mediante una conexión Ethernet por cable o una conexión inalámbrica. Ahora, para habilitar el acceso a la red, se deben configurar los dispositivos con la información de dirección IP para identificar los elementos correspondientes, entre ellos:

  • Dirección IP: identifica un host único en una red local.
  • Máscara de subred: identifica con qué subred de la red se puede comunicar el host.
  • Gateway predeterminado: identifica la dirección IP del router al que se debe enviar un paquete cuando el destino no está en la misma subred de la red local.

Cuando un host envía un paquete a un dispositivo en una red IP diferente, el paquete se reenvía al gateway predeterminado

Conexión de dispositivos

En la imagen:  PC1 envía un paquete al Servidor web ubicado en 176.16.1.99. Como este no está en la red local, debe enviar el paquete a la dirección de control de acceso a los medios (MAC) de su gateway predeterminado. La unidad de datos del protocolo (PDU) del paquete identifica las direcciones MAC e IP de origen y destino.

3.1. Asignar IP en un host

La información de la dirección IP a un host se puede asignar de dos formas:

  • Estática: se asigna la dirección IP, la máscara de subred y el gateway predeterminado correctos al host de forma manual. También se puede configurar la dirección IP del servidor DNS.
Asignar IP Estático

En la imagen: Asignación de IP Estático

  • Dinámica: un servidor proporciona la información de dirección IP mediante el protocolo de configuración dinámica de host (DHCP). El servidor de DHCP proporciona una dirección IP, una máscara de subred y un gateway predeterminado válidos para las terminales.

3.2. Registro del direccionamiento de red

Cuando se diseña una nueva red o se hacen asignaciones en una red existente, es necesario documentar la red. Como mínimo, el registro debe identificar lo siguiente:

  • Nombres de los dispositivos
  • Interfaces usadas en el diseño
  • Direcciones IP y máscaras de subred
  • Direcciones de gateway predeterminado

Esta información se captura mediante la creación de los siguientes registros:

  • Diagrama de topología: proporciona una referencia visual que indica la conectividad física y el direccionamiento lógico de capa 3. A menudo se crea mediante software (por ejemplo, Microsoft Visio)
  • Tabla de direccionamiento: es una tabla que captura nombres de dispositivos, interfaces, direcciones IPv4, máscaras de subred y direcciones de gateway predeterminado.
Tabla de direccionamiento

En la imagen: Ejemplo de Tabla de direccionamiento

4. Configuración del Router

Una vez repasado los temas anteriores pasamos a la configuración básica de un router.

Los routers y switches Cisco tienen muchas similitudes. Admiten estructuras de comandos similares, así como muchos de los mismos comandos. Por ello, los pasos de configuración inicial son similares para ambos dispositivos.

  • Asignarun nombre al dispositivo
  • Proteger el acceso de administración
  • Configurar un aviso

Para no quedarnos cortos les mostraré los comandos básicos para el router (que son los mismos vistos en el Switch —ver la lectura anterior)

R1>en
R1#conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)#
R1(config)#enable secret MyPassEnable
R1(config)#line console 0
R1(config-line)#pass MyPassConsole
R1(config-line)#login 
R1(config-line)#exit
R1(config)#line vty 0 4 
R1(config-line)#pass MyPassVty
R1(config-line)#login
R1(config-line)#exit
R1(config)#service password-encryption
R1(config)#banner motd #SOLO ACCESO AUTORIZADO!#
R1(config)#exit
R1#
%SYS-5-CONFIG_I: Configured from console by console
R1#copy running-config startup-config 
Destination filename [startup-config]? 
Building configuration...
[OK]
R1#

4.1. Configuración de una interfaz de router IPv4

Una característica que distingue a los switches de los routers es el tipo de interfaces que admite cada uno. Mientras que los switches de capa 2 admiten redes LAN (tienen varios puertos FastEthernet o Gigabit Ethernet), los routers admiten redes LAN y WAN, y pueden interconectar distintos tipos de redes (admiten muchos tipos de interfaces).

Por ejemplo, los ISR G2 tienen una o dos interfaces Gigabit Ethernet integradas y ranuras para tarjetas de interfaz WAN de alta velocidad (HWIC) para admitir otros tipos de interfaces de red, incluidas las interfaces seriales, DSL y de cable.

Para que una interfaz esté disponible, debe cumplir los siguientes requisitos:

  • Estar configurada con una dirección IP y una máscara de subred: utilice el comando de ip address [ip-address] [subnet-mask] para la configuración de interfaz.
  • Activar la interfaz: las interfaces LAN y WAN no están activadas (shutdown) de manera predeterminada. Para habilitar una interfaz, esta se debe activar mediante el comando no shutdown. (Es como encender la interfaz.) La interfaz también debe estar conectada a otro dispositivo (un hub, un switch u otro router) para que la capa física se active.

Es aconsejable configurar una descripción (breve de hasta 240 caracteres) en cada interfaz con el comando description

Ejemplo: Se mostrará los comandos de configuración para el Router R1

Configuración de una interfaz de router

En la imagen: Configuración de la interfaz del Router R1

Configuración de la interfaz GigabitEthernet 0/0 con la dirección 
IP 192.168.10.1 y la máscara de subred 255.255.255.0. 
Se describe al enlace como "Enlace a LAN 1" (Link to LAN 1) y se activa la interfaz.
R1(config)# interface gigabitethernet 0/0
R1(config-if)# ip address 192.168.10.1 255.255.255.0
R1(config-if)# description Link to LAN 1
R1(config-if)# no shutdown
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
Configuración de la interfaz GigabitEthernet 0/1 con la dirección 
IP 192.168.11.1 y la máscara de subred 255.255.255.0. 
Se describe el enlace como "Enlace a LAN 2" (Link to LAN 2) y se activa la interfaz.
R1(config-if)# interface gigabitethernet 0/1
R1(config-if)# ip address 192.168.11.1 255.255.255.0
R1(config-if)# description Link to LAN 2
R1(config-if)# no shutdown
%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up

Configuración de la interfaz serial 0/0/0 con la dirección 
IP 209.165.200.224 y la máscara de subred 255.255.255.252. 
Se describe el enlace como "Enlace a R1" y se activa la interfaz.
R1(config-if)# interface Serial 0/0/0
R1(config-if)# ip address 209.165.200.224 255.255.255.252
R1(config-if)# description Enlace a R1
R1(config-if)# no shutdown
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

Configuró correctamente las interfaces del router R1.

4.2. Configuración de una interfaz de router IPv6

La configuración de una interfaz IPv6 es similar a la configuración de una interfaz para IPv4. En la mayoría de los casos, la única diferencia en los comandos es el uso de ipv6 en lugar de ip.

Se debe realizar lo siguiente con la interfaz IPv6:

  • Configurar con la dirección IPv6 y la máscara de subred: utilice ip address [dirección-ipv6/longitud-prefijo]
  • Activar la interfaz: la interfaz se debe activar mediante el comando no shutdown.

Una interfaz puede generar su propia dirección link-local de IPv6 sin tener una dirección de unidifusión global mediante el comando de configuración de interfaz ipv6 enable.

Ejemplo: Se mostrará los comandos de configuración para el Router R1

Configuración de una interfaz de router IPv6

Configuración de una interfaz de router IPv6

Configuración de la interfaz GigabitEthernet 0/0 con la dirección 
IPv6 2001:db8:acad:1::1/64. Se describe el enlace como "Link to LAN 1" 
y se activa la interfaz.
R1(config)# interface gigabitethernet 0/0
R1(config-if)# ipv6 address 2001:db8:acad:1::1/64
R1(config-if)# description Link to LAN 1
R1(config-if)# no shutdown
%LINK-5-CHANGED: Interface GigabitEthernet0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
Configuración de la interfaz GigabitEthernet 0/1 con la dirección 
IPv6 2001:db8:acad:2::1/64. Se describe el enlace como "Link to LAN 2" 
y se activa la interfaz.
R1(config-if)# interface gigabitethernet 0/1
R1(config-if)# ipv6 address 2001:db8:acad:2::1/64
R1(config-if)# description Link to LAN 2
R1(config-if)# no shutdown
%LINK-5-CHANGED: Interface GigabitEthernet0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/1, changed state to up
Configuración de la interfaz serial 0/0/0 con la dirección 
IPv6 2001:db8:acad:3::2/64. Se describe el enlace como "Enlace a R1" 
y se activa la interfaz.

R1(config-if)# interface Serial 0/0/0
R1(config-if)# ipv6 address 2001:db8:acad:3::2/64
R1(config-if)# description Enlace a R1
R1(config-if)# no shutdown
%LINK-5-CHANGED: Interface Serial0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

Configuró correctamente las interfaces IPv6 del router R1.

Cuando el router se configura con el comando de configuración global ipv6 unicast-routing, el router comienza a enviar mensajes de anuncio de router ICMPv6 por la interfaz.

5. Verificación de la configuración de interfaz

Existen varios comandos show que se pueden usar para verificar el funcionamiento y la configuración de una interfaz. Los siguientes tres comandos son particularmente útiles para identificar de forma rápida el estado de una interfaz:

  • show ip interface brief: muestra un resumen de todas las interfaces, incluidos la dirección IPv4 de la interfaz y el estado operativo actual.
  • show ip route: muestra el contenido de la tabla de routing IPv4 que se almacena en la RAM. En el IOS de Cisco las interfaces activas deben aparecer con dos entradas relacionadas identificadas con el código “C” (conectada) o “L” (local)
  • show running-config interface interface-id: muestra los comandos configurados en la interfaz especificada.

Los comandos para verificar la configuración de interfaz IPv6 son similares a los comandos que se usan para IPv4, sólo se cambia ip por ipv6

 

Deja un Comentario

CLOSE
CLOSE