Configuración Básica del Router

Configuración Básica Router
5

Resumen

Aprenderás a configurar los ajustes básicos de un router para enrutar entre dos redes conectadas directamente, usando CLI. ¡¡Empieza a aprender CCNA 200-301 gratis!!

¡Bienvenido!: Este tema forma parte del Módulo 1 del curso de Cisco CCNA 2, para un mejor seguimiento del curso puede ir a la sección CCNA 2 para guiarte del índice.

1. Configurar Ajustes Básicos del Router

Hasta ahora, este módulo sólo tiene cubiertos switches. Si quieres que los dispositivos puedan enviar y recibir datos fuera de tu red, tendrás que configurar los routers. Este tema te enseña la configuración básica de los routers y proporciona dos verificadores de sintaxis y una actividad Packet Tracer para que puedas practicar estas habilidades.

Los routers y switches Cisco tienen muchas similitudes. Soportan un sistema operativo modal similar, estructuras de comando similares y muchos de los mismos comandos. Además, ambos dispositivos tienen pasos de configuración inicial similares. Por ejemplo, las siguientes tareas de configuración deberían realizarse siempre. Nombrar el dispositivo para distinguirlo de otros routers y configurar las contraseñas, como se muestra en el ejemplo.

Router# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)# hostname R1
R1(config)# enable secret class
R1(config)# line console 0
R1(config-line)# password cisco
R1(config-line)# login
R1(config-line)# exit
R1(config)# line vty 0 4
R1(config-line)# password cisco
R1(config-line)# login
R1(config-line)# exit
R1(config)# service password-encryption
R1(config)#

Configure un banner para notificar legalmente el acceso no autorizado, como se muestra en el ejemplo.

R1(config)# banner motd $ Authorized Access Only! $
R1(config)#

Guarda los cambios en un router, como se muestra en el ejemplo.

R1# copy running-config startup-config
Destination filename [startup-config]? 
Building configuration...
[OK]

2. Comprobador de sintaxis – Configuración Básica Router

En esta Actividad de Sintaxis, configurarás los ajustes básicos para R2.


Entre en el modo de configuración global y nombre el router R2.

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname R2

Configura class como la contraseña secreta.

R1(config)#enable secret class

Configura cisco como la contraseña de la línea de la consola y requiere que los usuarios se conecten. Luego salga del modo de configuración de la línea.

R1(config)#line console 0
R1(config-line)#password cisco
R1(config-line)#login
R1(config-line)#exit

Configurar cisco como la contraseña vty para las líneas 0 a 4 y requerir que los usuarios se conecten.

R1(config)#line vty 0 4
R1(config-line)#password cisco
R1(config-line)#login

Salga del modo de configuración de línea y encripte todas las contraseñas de texto plano.

R1(config-line)#exit
R1(config)#service password-encryption

Ingresa el banner ¡Solo acceso autorizado! y usa # como carácter delimitador.

R1(config)#banner motd #¡Solo acceso autorizado!#

Salga del modo de configuración global y guarde la configuración.

R1(config)#exit
R1#copy running-config startup-config
Destination filename \[startup-config\]? 
Building configuration... 
\[OK\]

3. Topología Dual Stack

Una característica que distingue a los switches y routers es el tipo de interfaces que soporta cada uno. Por ejemplo, los switches de capa 2 admiten redes LAN; por lo tanto, tienen varios puertos FastEthernet o Gigabit Ethernet. La topología de doble pila (dual stack) de la figura se utiliza para demostrar la configuración de las interfaces IPv4 e IPv6 del router.

Topología Dual Stack

Topología Dual Stack

4. Configurar Interfaces del Router

Los Routers soportan LAN y WAN y pueden interconectar diferentes tipos de redes; por lo tanto, soportan muchos tipos de interfaces. Por ejemplo, los ISR G2 tienen una o dos interfaces Gigabit Ethernet integradas y ranuras para tarjetas de interfaz WAN de alta velocidad (HWIC) para dar cabida a otros tipos de interfaces de red, incluidas las interfaces en serie, DSL y por cable.

Para estar disponible, una interfaz debe estar:

  • Configurada con al menos una dirección IP – Usar los comandos de configuración de interfaz ip address ip-address subnet-mask y ipv6 address ipv6-address/prefix
  • Activada – Por defecto, las interfaces LAN y WAN no están activadas (shutdown). Para habilitar una interfaz, debe activarse mediante el comando no shutdown. (Esto es similar a encender la interfaz.) La interfaz también debe estar conectada a otro dispositivo (un hub, un switch u otro router) para que la capa física esté activa.
  • Descripción – Opcionalmente, la interfaz también puede ser configurada con una breve descripción de hasta 240 caracteres. Es una buena práctica configurar una descripción en cada interfaz. En las redes de producción, las ventajas de las descripciones de las interfaces se materializan rápidamente, ya que son útiles para la resolución de problemas y la identificación de la conexión y la información de contacto de un tercero.

El siguiente ejemplo muestra la configuración de las interfaces en la R1.

R1(config)# interface gigabitethernet 0/0/0
R1(config-if)# ip address 192.168.10.1 255.255.255.0 
R1(config-if)# ipv6 address 2001:db8:acad:1::1/64 
R1(config-if)# description Link to LAN 1
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)# interface gigabitethernet 0/0/1
R1(config-if)# ip address 192.168.11.1 255.255.255.0 
R1(config-if)# ipv6 address 2001:db8:acad:2::1/64 
R1(config-if)# description Link to LAN 2
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)# interface serial 0/0/0
R1(config-if)# ip address 209.165.200.225 255.255.255.252 
R1(config-if)# ipv6 address 2001:db8:acad:3::225/64 
R1(config-if)# description Link to R2
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)#

5. Verificador de Sintaxis – Configurar Interfaces del Router

En esta actividad del Comprobador de Sintaxis, configurarás R2 con sus interfaces IPv4 e IPv6.

Configurar GigabitEthernet 0/0/0.

  • Utilice g0/0/0 para entrar en el modo de configuración de la interfaz.
  • Configure la dirección IPv4 10.1.1.1 y la máscara de subred 255.255.255.0.
  • Configure la dirección IPv6 2001:db8:acad:4::1/64.
  • Describa el enlace como Link to LAN 3.
  • Activar la interfaz.
Router(config)#interface g0/0/0
Router(config-if)#ip address 10.1.1.1 255.255.255.0
Router(config-if)#ipv6 address 2001:db8:acad:4::1/64
Router(config-if)#Description Link to LAN 3
Router(config-if)#no shutdown
%LINK-3-UPDOWN: Interface GigabitEthernet0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0/0, changed state to up

Configurar GigabitEthernet 0/0/1.

  • Utilice g0/0/1 para entrar en el modo de configuración de la interfaz.
  • Configure la dirección IPv4 10.1.2.1 y la máscara de subred 255.255.255.0.
  • Configure la dirección IPv6 2001:db8:acad:5::1/64.
  • Describa el enlace como Link to LAN 4.
  • Activar la interfaz.
Router(config-if)#interface g0/0/1
Router(config-if)#ip address 10.1.2.1 255.255.255.0
Router(config-if)#ipv6 address 2001:db8:acad:5::1/64
Router(config-if)#description Link to LAN 4
Router(config-if)#no shutdown
%LINK-3-UPDOWN: Interface GigabitEthernet0/0/1, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0/1, changed state to up

Configurar la Serial 0/0/0.

  • Utilice s0/0/0 para entrar en el modo de configuración de la interfaz.
  • Configure la dirección IPv4 209.165.200.226 y la máscara de subred 255.255.255.252.
  • Configure la dirección IPv6 2001:db8:acad:3::226/64.
  • Describa el enlace como Link to R1.
  • Activar la interfaz.
Router(config-if)#interface s0/0/0
Router(config-if)#ip address 209.165.200.226 255.255.255.0
Router(config-if)#ipv6 address 2001:db8:acad:3::226/64
Router(config-if)#description Link to R1
Router(config-if)#no shutdown
%LINK-3-UPDOWN: Interface Serial0/0/0, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0/0, changed state to up

6. Interfaces Loopback IPv4

Otra configuración común de los routers de Cisco IOS es la de habilitar una interfaz de loopback.

La interfaz de loopback es una interfaz lógica que es interna al router. No está asignada a un puerto físico y no puede ser conectada a ningún otro dispositivo. Se considera una interfaz de software que se coloca automáticamente en estado “up”, siempre que el router esté funcionando.

La interfaz de loopback es útil para probar y gestionar un dispositivo IOS de Cisco porque garantiza que al menos una interfaz estará siempre disponible. Por ejemplo, puede utilizarse para fines de prueba, como la comprobación de los procesos de enrutamiento interno, emulando las redes que se encuentran detrás del router.

Las interfaces de loopback (o bucle de retorno) también se utilizan comúnmente en los entornos de laboratorio para crear interfaces adicionales. Por ejemplo, se pueden crear múltiples interfaces de loopback en un router para simular más redes con fines de práctica de configuración y pruebas. En este plan de estudios, a menudo utilizamos una interfaz de loopback para simular un enlace a Internet.

Habilitar y asignar una dirección de loopback es sencillo:

Router(config)# interface loopback number
Router(config-if)# ip address ip-address subnet-mask

Se pueden habilitar múltiples interfaces de loopback en un router. La dirección IPv4 de cada interfaz loopback debe ser única y no debe ser utilizada por ninguna otra interfaz, como se muestra en el ejemplo de configuración de la interfaz loopback 0 en R1.

R1(config)# interface loopback 0
R1(config-if)# ip address 10.0.0.1 255.255.255.0
R1(config-if)# exit
R1(config)#
%LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback0, changed state to up

7. Packet Tracer – Configurar las Interfaces del Router

En esta actividad de Packet Tracer, configurarás los routers con direcciones IPv4 e IPv6.

Glosario: Si tienes dudas con algún término especial, puedes consultar este diccionario de redes informáticas.

¡Listo! Sigue visitando nuestro blog de curso de redes, dale Me Gusta a nuestra fanpage; y encontrarás más herramientas y conceptos que te convertirán en todo un profesional de redes.

Deja un Comentario

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.

¿Quieres aprobar la certificación Cisco CCNA?Sí, quiero!
+ +