Configuración de un cliente y un servidor DHCPv4

Configuración DHCPv4
  • 10/10
    Configuración de un servidor DHCPv4 básico - 10/10
  • 10/10
    Configuración de un cliente DHCPv4 - 10/10
10/10

Resumen

Te enseñamos a cómo configurar un servidor DHCP (DHCPv4) tanto un servidor como en un cliente. Se muestran muchos ejemplos con todos los comandos a seguir paso a paso.

En esta sección, se explora la configuración de DHCPv4. Paso a paso y todos los comandos que debes conocer y aprender.

¡Bienvenido a CCNA desde Cero!: Este tema forma parte del Capítulo 8 del curso de Cisco CCNA 2, para un mejor seguimiento del curso puede ir a la sección CCNA 2 para guiarse del índice.

Un router Cisco que ejecuta el software IOS de Cisco puede configurarse para que funcione como servidor de DHCPv4. El servidor de DHCPv4 que utiliza IOS de Cisco asigna y administra direcciones IPv4 de conjuntos de direcciones especificados dentro del router para los clientes DHCPv4. La topología que se muestra en la Imagen 1 se utiliza para ilustrar esta funcionalidad.

Router R1 como servidor de DHCPv4

Imagen 1: Ejemplo para el Router R1 como servidor de DHCPv4

1. Cómo Configurar un servidor DHCP en Router Cisco

  • Paso 1: Excluir direcciones IPv4

El router que funciona como servidor de DHCPv4 asigna todas las direcciones IPv4 en un conjunto de direcciones DHCPv4, a menos que esté configurado para excluir direcciones específicas. Generalmente, algunas direcciones IPv4 de un conjunto se asignan a dispositivos de red que requieren asignaciones de direcciones estáticas. Por lo tanto, estas direcciones IPv4 no deben asignarse a otros dispositivos. Para excluir direcciones específicas, utilice el comando ip dhcp excluded-address, como se muestra a continuación:

R1(config)# ip dhcp excluded-address low-address [high-address]

Se puede excluir una única dirección o un rango de direcciones especificando la dirección más baja y la dirección más alta del rango. Las direcciones excluidas deben incluir las direcciones asignadas a los routers, a los servidores, a las impresoras y a los demás dispositivos que se configuraron o se configurarán manualmente.

R1(config)# ip dhcp excluded-address 192.168.10.1 192.168.10.9
R1(config)# ip dhcp excluded-address 192.168.10.254
  • Paso 2: Configurar un pool de DHCPv4

La configuración de un servidor de DHCPv4 implica definir un conjunto de direcciones que se deben asignar. Como se muestra a continuación, el comando ip dhcp pool nombre-del-conjunto crea un conjunto con el nombre especificado y coloca al router en el modo de configuración de DHCPv4, que se identifica con el indicador Router(dhcp-config)#.

R1(config)# ip dhcp pool pool-name
R1(dhcp-config)#
R1(config)# ip dhcp pool LAN-POOL-1
R1(dhcp-config)#
  • Paso 3: Configurar tareas específicas

Por último, se indican las tareas para finalizar la configuración del pool de DHCPv4. Algunas de ellas son optativas, mientras que otras deben configurarse.

1.1. Tareas requeridas y opcionales para DHCP

Tareas Requeridas

Tabla de configuración de tareas específicas.
Tareas requeridasComando
Definir el conjunto de direcciones.network número de red [máscara | longitud-prefijo]
Definir el router o gateway predeterminado.default-router dirección [dirección2…dirección8]

Tareas Opcionales

Tabla de configuración de tareas específicas.
Tareas OpcionalesComando
Definir un servidor DNS.dns-server dirección [dirección2…dirección8]
Definir el nombre de dominio.domain-name dominio
Definir la duración de la concesión DHCP.lease {días [horas] [minutos] | infinito}
Definir el servidor WINS con NetBIOS.netbios-name-server dirección [dirección2…dirección8]

El conjunto de direcciones y el router de gateway predeterminado deben estar configurados. Utilice la instrucción network para definir el rango de direcciones disponibles.

Utilice el comando default-router para definir el router de gateway predeterminado. Normalmente, el gateway es la interfaz LAN del router más cercano a los dispositivos clientes. Se requiere un gateway, pero se pueden indicar hasta ocho direcciones si hay varios gateways.

Otros comandos del pool de DHCPv4 son optativos. Por ejemplo, la dirección IPv4 del servidor DNS que está disponible para un cliente DHCPv4 se configura mediante el comando dns-server. El comando domain-name dominio se utiliza para definir el nombre de dominio. La duración del arrendamiento de DHCPv4 puede modificarse mediante el comando lease. El valor de arrendamiento predeterminado es un día. El comando netbios-name-server se utiliza para definir el servidor WINS con NetBIOS.

1.2. Ejemplo de configuración DHCPv4

Un ejemplo de configuración con parámetros básicos de DHCPv4 configurados en el router R1 se muestra a continuación. R1 está configurado como servidor DHCPv4 para la LAN 192.168.10.0/24 mediante la topología de ejemplo de la Imagen 1.

R1(config)# ip dhcp excluded-address 192.168.10.1 192.168.10.9
R1(config)# ip dhcp excluded-address 192.168.10.254 
R1(config)# ip dhcp pool LAN-POOL-1
R1(dhcp-config)# network 192.168.10.0 255.255.255.0
R1(dhcp-config)# default-router 192.168.10.1
R1(dhcp-config)# dns-server 192.168.11.5
R1(dhcp-config)# domain-name example.com
R1(dhcp-config)# end
R1#

El servicio DHCPv4 está habilitado de manera predeterminada. Para deshabilitar el servicio, utilice el comando del modo de configuración global no service dhcp. Utilice el comando del modo de configuración global service dhcp para volver a habilitar el proceso del servidor de DHCPv4. Si los parámetros no se configuran, habilitar el servicio no tiene ningún efecto.

1.3. Verificación de DHCPv4

En el resultado de ejemplo, se utiliza la topología que se muestra en la Imagen 1. En este ejemplo, se configuró el R1 para que proporcione servicios DHCPv4. Dado que la PC1 no se encendió, no tiene una dirección IP.

1.3.1. Comando show running-config

Como se muestra a continuación, en el resultado del comando show running-config | section dhcp, se muestran los comandos de DHCPv4 configurados en el R1. El parámetro | section muestra solamente los comandos asociados a la configuración de DHCPv4.

R1# show running-config | section dhcp
ip dhcp excluded-address 192.168.10.1 192.168.10.9
ip dhcp excluded-address 192.168.10.254
ip dhcp excluded-address 192.168.11.1 192.168.11.9
ip dhcp excluded-address 192.168.11.254
ip dhcp pool LAN-POOL-1
 network 192.168.10.0 255.255.255.0
 default-router 192.168.10.1 
 dns-server 192.168.11.5 
 domain-name example.com
ip dhcp pool LAN-POOL-2
 network 192.168.11.0 255.255.255.0
 default-router 192.168.11.1 
 dns-server 192.168.11.5 
 domain-name example.com
R1#

1.3.2. Comando show ip dhcp binding

Como se muestra en el siguiente resultado, se puede verificar el funcionamiento de DHCPv4 mediante el comando show ip dhcp binding. Este comando muestra una lista de todas las vinculaciones de la dirección IPv4 con la dirección MAC que fueron proporcionadas por el servicio DHCPv4.

R1# show ip dhcp binding
Bindings from all pools not associated with VRF:
IP address Client-ID/          Lease expiration  Type
           Hardware address/
           User name

El siguiente comando, show ip dhcp server statistics, se utiliza para verificar si el router recibe o envía los mensajes. Este comando muestra información de conteo con respecto a la cantidad de mensajes DHCPv4 que se enviaron y recibieron.

R1# show ip dhcp server statistics
Memory usage 23543
Address pools 1
Database agents 0
Automatic bindings 0
Manual bindings 0
Expired bindings 0
Malformed messages 0
Secure arp entries 0

Message Received
BOOTREQUEST 0
DHCPDISCOVER 0
DHCPREQUEST 0
DHCPDECLINE 0
DHCPRELEASE 0
DHCPINFORM 0

Message Sent
BOOTREPLY 0
DHCPOFFER 0
DHCPACK 0
DHCPNAK 0
R1#

Como se observa en el resultado de estos comandos, actualmente no hay vinculaciones, y las estadísticas indican que no hay mensajes enviados o recibidos. En este momento, ningún dispositivo solicitó servicios DHCPv4 del router R1.

1.3.3. Comando show ip dhcp

En el siguiente resultado, los comandos se emiten después de que la PC1 y la PC2 se encendieron y finalizaron el proceso de arranque.

R1# show ip dhcp binding
Bindings from all pools not associated with VRF:
IP address Client-ID/         Lease expiration  Type
           Hardware address/
           User name
192.168.10.10 0100.e018.5bdd.35 May 28 2013 01:06 PM Automatic
192.168.11.10 0100.b0d0.d817.e6 May 28 2013 01:10 PM Automatic
R1# show ip dhcp server statistics
Memory usage 25307
Address pools 2
Database agents 0
Automatic bindings 2
Manual bindings 0
Expired bindings 0
Malformed messages 0
Secure arp entries 0

Message Received
BOOTREQUEST 0
DHCPDISCOVER 8
DHCPREQUEST 3
DHCPDECLINE 0
DHCPRELEASE 0
DHCPINFORM 0

Message Sent
BOOTREPLY 0
DHCPOFFER 3
DHCPACK 3
DHCPNAK 0
R1#

Observe que en la información acerca de las vinculaciones ahora se muestra que las direcciones IPv4 192.168.10.10 a 192.168.11.10 se unieron a las direcciones MAC. Las estadísticas también muestran actividad DHCPDISCOVER, DHCPREQUEST, DHCPOFFER y DHCPACK.

1.3.4. Comando ipconfig /all

Como se muestra en la Imagen 2, el comando ipconfig /all, cuando se emite en la PC1, muestra los parámetros TCP/IP. Dado que la PC1 se conectó al segmento de red 192.168.10.0/24, recibió automáticamente un sufijo DNS, una dirección IPv4, una máscara de subred, un gateway predeterminado y una dirección del servidor DNS de ese pool. No se requiere ninguna configuración de interfaz del router específica de DHCP. Si una computadora está conectada a un segmento de red que tiene un pool de DHCPv4 disponible, la computadora puede obtener una dirección IPv4 del pool adecuado de manera automática.

DHCP Comando ipconfig all

Imagen 2: Comando ipconfig all

1.4. Retransmisión de DHCPv4

En una red jerárquica compleja, los servidores empresariales suelen estar ubicados en una granja de servidores. Estos servidores pueden proporcionar servicios DHCP, DNS, TFTP y FTP para la red. Generalmente, los clientes de red no se encuentran en la misma subred que esos servidores. Para ubicar los servidores y recibir servicios, los clientes con frecuencia utilizan mensajes de difusión.

DHCP Problemas de DHCPv4

Imagen 3: Problemas de DHCPv4

En la Imagen 3, la PC1 intenta adquirir una dirección IPv4 de un servidor de DHCP mediante un mensaje de difusión. En esta situación, el router R1 no está configurado como servidor de DHCPv4 y no reenvía el mensaje de difusión. Dado que el servidor de DHCPv4 está ubicado en una red diferente, la PC1 no puede recibir una dirección IP mediante DHCP.


1.4.1. Comandos ipconfig /release e  ipconfig /renew

En la Imagen 4, la PC1 intenta renovar su dirección IPv4. Para hacerlo, se emite el comando ipconfig /release. Observe que se libera la dirección IPv4, y se muestra que la dirección es 0.0.0.0. A continuación, se emite el comando ipconfig /renew. Este comando hace que la PC1 transmita por difusión un mensaje DHCPDISCOVER. En el resultado se muestra que la PC1 no puede ubicar el servidor de DHCPv4. Dado que los routers no reenvían mensajes de difusión, la solicitud no es correcta.

PC1 sin dirección IPv4

Imagen 4: PC1 sin dirección IPv4

Como solución a este problema, un administrador puede agregar servidores de DHCPv4 en todas las subredes. Sin embargo, ejecutar estos servicios en varias computadoras genera un costo adicional y sobrecarga administrativa.

Una mejor solución consiste en configurar una dirección de ayuda de IOS de Cisco. Esta solución permite que el router reenvíe difusiones de DHCPv4 al servidor de DHCPv4. Cuando un router reenvía solicitudes de asignación/parámetros de direcciones, actúa como agente de retransmisión DHCPv4. En la topología de ejemplo, la PC1 transmitiría por difusión una solicitud para ubicar un servidor de DHCPv4. Si el R1 estuviera configurado como agente de retransmisión DHCPv4, reenviaría la solicitud al servidor de DHCPv4 ubicado en la subred 192.168.11.0.

1.4.2. Comando ip helper-address

Como se muestra a continuación, la interfaz en el R1 que recibe la difusión se configura con el comando del modo de configuración de interfaz ip helper-address. La dirección del servidor de DHCPv4 se configura como el único parámetro.

R1(config)# interface g0/0
R1(config-if)# ip helper-address 192.168.11.6
R1(config-if)# end
R1# show ip interface g0/0
GigabitEthernet0/0 is up, line protocol is up 
 Internet address is 192.168.10.1/24
 Broadcast address is 255.255.255.255
 Address determined by setup command
 MTU is 1500 bytes
 Helper address is 192.168.11.6

Cuando se configura el R1 como agente de retransmisión DHCPv4, acepta solicitudes de difusión para el servicio DHCPv4 y, a continuación, reenvía dichas solicitudes en forma de unidifusión a la dirección IPv4 192.168.11.6. El comando show ip interface se utiliza para verificar la configuración.

Como se muestra en la Imagen 5, la PC1 ahora puede adquirir una dirección IPv4 del servidor de DHCPv4.

PC1 renovación de la dirección IPv4

Imagen 5: PC1 – renovación de la dirección IPv4

DHCPv4 no es el único servicio que puede configurarse para que retransmita el router. De manera predeterminada, el comando ip helper-address reenvía los siguientes ocho siguientes servicios UDP:

  • Puerto 37: Tiempo
  • Puerto 49: TACACS
  • Puerto 53: DNS
  • Puerto 67: cliente DHCP/BOOTP
  • Puerto 68: servidor de DHCP/BOOTP
  • Puerto 69: TFTP
  • Puerto 137: servicio de nombres NetBIOS
  • Puerto 138: servicio de datagrama NetBIOS

2. Configuración de un router como cliente DHCPv4

En ocasiones, los routers Cisco en oficinas pequeñas y oficinas domésticas (SOHO) y en los sitios de sucursales deben configurarse como clientes DHCPv4 de manera similar a los equipos cliente. El método específico utilizado depende del ISP. Sin embargo, en su configuración más simple, se utiliza la interfaz Ethernet para conectarse a un cable módem o a un módem DSL. Para configurar una interfaz Ethernet como cliente DHCP, utilice el comando del modo de configuración de interfaz ip address dhcp.

Configuración de un router como cliente de DHCP

Imagen 6: Configuración de un router como cliente de DHCP

En la Imagen 6, suponga que un ISP se configuró para proporcionar direcciones IP del rango de red 209.165.201.0/27 a clientes selectos. Después de que se configura la interfaz G0/1 con el comando ip address dhcp, el comando show ip interface g0/1 confirma que la interfaz está activada y que la dirección fue asignada por un servidor de DHCPv4.

SOHO(config)# interface g0/1 
SOHO(config-if)# ip address dhcp 
SOHO(config-if)# no shutdown 
SOHO(config-if)# 
*Jan 31 17:31:11.507: %DHCP-6-ADDRESS_ASSIGN: Interface 
GigabitEthernet0/1 assigned DHCP address 209.165.201.12, mask 
255.255.255.224, hostname SOHO
SOHO(config-if)# end 
SOHO# show ip interface g0/1 
GigabitEthernet0/1 is up, line protocol is up
 Internet address is 209.165.201.12/27
 Broadcast address is 255.255.255.255
 Address determined by DHCP

2.1. Configuración de un router inalámbrico como cliente DHCPv4

Normalmente, los routers inalámbricos para uso en el hogar o una oficina pequeña se conectan a un ISP mediante un cable módem o DSL. En la mayoría de los casos, los routers inalámbricos se configuran para recibir información de direccionamiento IPv4 automáticamente desde el ISP.

Configuración de un router inalámbrico como cliente DHCPv4

Imagen 7: Configuración de un router inalámbrico como cliente DHCPv4

Por ejemplo, en la ilustración se muestra la página de configuración de WAN predeterminada para un router inalámbrico de Packet Tracer. Observe que el tipo de conexión a Internet está establecido como Automatic Configuration – DHCP (Configuración automática, DHCP). Se utiliza esta selección cuando el router se conecta a un cable módem o DSL y actúa como cliente DHCPv4 y solicita una dirección IPv4 del ISP.

Deja un Comentario

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.