Configurar EtherChannel

Configurar EtherChannel
5

Resumen

Aprenderás a configurar EtherChannel. ¡¡Empieza a aprender CCNA 200-301 gratis ahora mismo!!

¡Bienvenido!: Este tema forma parte del Módulo 6 del curso de Cisco CCNA 2, para un mejor seguimiento del curso puede ir a la sección CCNA 2 para guiarte del índice.

1. Instrucciones de Configuración

Ahora que ya sabes qué es EtherChannel, en este tema se explica cómo configurarlo. Las siguientes pautas y restricciones son útiles para configurar EtherChannel:

  • Soporte de EtherChannel – Todas las interfaces Ethernet deben admitir EtherChannel, sin necesidad de que las interfaces sean físicamente contiguas.
  • Velocidad y dúplex – Configura todas las interfaces en un EtherChannel para que funcionen a la misma velocidad y en el mismo modo dúplex.
  • Coincidencia VLAN – Todas las interfaces en el grupo EtherChannel se deben asignar a la misma VLAN o se deben configurar como enlace troncal (mostrado en la figura).
  • Rango de VLAN – Un EtherChannel soporta el mismo rango permitido de VLANs en todas las interfaces de un EtherChannel troncal. Si el rango permitido de VLANs no es el mismo, las interfaces no forman un EtherChannel, incluso cuando están configuradas en modo desirable o auto.

La figura muestra una configuración que permitiría que se forme un EtherChannel entre el S1 y el S2.

Instrucciones de Configuración EtherChannel

Instrucciones de Configuración EtherChannel

Un EtherChannel se forma cuando los ajustes de configuración coinciden en ambos switches.

En la siguiente figura, los puertos de S1 están configurados en modo semidúplex. Por lo tanto, no se formará un EtherChannel entre el S1 y el S2.

Error de configuración EtherChannel

Error de configuración EtherChannel

Un EtherChannel no se forma cuando los ajustes de configuración son diferentes en cada switch.

Si es necesario cambiar estos ajustes, configúralos en el modo de configuración de la interfaz del canal de puerto. Cualquier configuración que se aplique a la interfaz de canal de puerto también afecta a las interfaces individuales. Sin embargo, las configuraciones que se aplican a las interfaces individuales no afectan a la interfaz de canal de puerto. Por lo tanto, realizar cambios de configuración en una interfaz que forma parte de un enlace EtherChannel puede causar problemas de compatibilidad de la interfaz.


El canal de puertos se puede configurar en modo de acceso/access mode, modo de enlace troncal/trunk mode (más frecuente) o en un puerto enrutado/routed port.

2. Ejemplo de Configuración de LACP

EtherChannel está deshabilitado de forma predeterminada y debe configurarse. La topología de la figura se utilizará para demostrar un ejemplo de configuración de EtherChannel utilizando LACP.

Ejemplo de Configuración de LACP

Ejemplo de Configuración de LACP

La configuración de EtherChannel con LACP requiere tres pasos:

Paso 1. Especifica las interfaces que conforman el grupo EtherChannel mediante el comando de modo de configuración global interface range interface global. La palabra clave range te permite seleccionar varias interfaces y configurarlas a la vez.

Paso 2. Crea la interfaz port channel con el comando en el modo de configuración de rango de interfaz (interface range) channel-group identifier mode active. El identificador especifica el número del grupo del canal/channel group. Las palabras clave mode active identifican a esta configuración como EtherChannel LACP.

Paso 3. Para cambiar la configuración de capa 2 en la interfaz de canal de puertos, ingresa al modo de configuración de interfaz de canal de puertos mediante el comando interface port-channel, seguido del identificador de la interfaz. En el ejemplo, S1 está configurado con un EtherChannel LACP. El canal de puertos está configurado como interfaz de enlace troncal con VLAN permitidas específicas.

S1(config)# interface range FastEthernet 0/1 - 2
S1(config-if-range)# channel-group 1 mode active
Creating a port-channel interface Port-channel 1
S1(config-if-range)# exit
S1(config-if)# interface port-channel 1
S1(config-if)# switchport mode trunk
S1(config-if)# switchport trunk allowed vlan 1,2,20

3. Verificador de sintaxis – Configuración EtherChannel

Configurar EtherChannel para S2 en función de los requisitos especificados

Ejemplo Configuración EtherChannel

Ejemplo Configuración EtherChannel

  • Ingresa al modo interface range para FastEthernet0/1 y FastEthernet0/2. Usa fa 0/1 – 2 como designación de interfaz.
S1(config)#interface range fa 0/1 - 2
  • Utilice la ayuda contextual (?) para mostrar las opciones del comando channel-group.
S1(config-if-range)#channel-group ?
<1-6> Channel group number
  • Selecciona channel-group 1 y muestra la siguiente opción.
S1(config-if-range)#channel-group 1 ?
mode Etherchannel Mode of the interface
  • Introduce la palabra clave mode y muestra el siguiente conjunto de opciones.
S1(config-if-range)#channel-group 1 mode ?
active Enable LACP unconditionally 
auto Enable PAgP only if a PAgP device is detected 
desirable Enable PAgP unconditionally 
on Enable Etherchannel only 
passive Enable LACP only if a LACP device is detected
  • Configura el channel-group para usar el LACP incondicionalmente.
S1(config-if-range)#channel-group 1 mode active
\*Mar 21 00:02:28.184: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state 
to down 
\*Mar 21 00:02:28.193: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state 
to down 
\*Mar 21 00:02:36.179: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state 
to up 
\*Mar 21 00:02:36.674: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state 
to up 
S1(config-if-range)# 
\*Mar 21 00:04:31.170: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state 
to down 
\*Mar 21 00:04:31.186: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state 
to down 
\*Mar 21 00:04:33.116: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state 
to up 
\*Mar 21 00:04:34.114: %LINK-3-UPDOWN: Interface Port-channel1, changed state to up 
\*Mar 21 00:04:35.037: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/2, changed state 
to up 
\*Mar 21 00:04:35.121: %LINEPROTO-5-UPDOWN: Line protocol on Interface Port-channel1, changed state to 
up

Configura los valores de los switchport para el canal del puerto que se creó:

  • Entrar en el modo de configuración de la interfaz para el port-channel 1
  • Configurar el port-channel 1 como troncal
  • Permitir que los VLANS 1,2,20 crucen el enlace troncal. Introducir las VLANs como se muestra sin espacios.
S1(config-if-range)#interface port-channel 1
S1(config-if)#switchport mode trunk
S1(config-if)#switchport trunk allowed vlan 1,2,20

4. Packet Tracer – Configuración de EtherChannel

Acaban de instalarse tres switches. Hay enlaces up redundantes entre los switches. Con esta configuración, solo uno de estos enlaces puede utilizarse; de lo contrario, podría producirse un bucle de bridging/puenteo. Sin embargo, con el uso de un solo enlace, se emplea solo la mitad del ancho de banda disponible. EtherChannel permite que hasta ocho enlaces redundantes se agrupen en un enlace lógico. En esta práctica de laboratorio, configurarás el protocolo PAgP (Port Aggregation Protocol, protocolo de agregación de enlaces), un protocolo Cisco EtherChannel y el protocolo LACP (Link Aggregation Control Protocol, protocolo de control de agregación de enlaces), una versión estándar abierta de EtherChannel según la norma IEEE 802.3ad.

Glosario: Si tienes dudas con algún término especial, puedes consultar este diccionario de redes informáticas.

¡Listo! Sigue visitando nuestro blog de curso de redes, dale Me Gusta a nuestra fanpage; y encontrarás más herramientas y conceptos que te convertirán en todo un profesional de redes.

Deja un Comentario

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.

¿Quieres aprobar la certificación Cisco CCNA?Sí, quiero!
+ +