Verificar y Solucionar Problemas EtherChannel

Verificar y Solucionar Problemas EtherChannel
5

Resumen

Aprenderás a Solucionar Problemas de EtherChannel. ¡¡Empieza a aprender CCNA 200-301 gratis ahora mismo!!

¡Bienvenido!: Este tema forma parte del Módulo 6 del curso de Cisco CCNA 2, para un mejor seguimiento del curso puede ir a la sección CCNA 2 para guiarte del índice.

1. Verificar EtherChannel

Como siempre, al configurar dispositivos en tu red, debes verificar tu configuración. Si hay problemas, también deberás poder solucionarlos y solucionarlos. En este tema se proporcionan los comandos que se deben verificar, así como algunos problemas comunes de red EtherChannel y sus soluciones.

Los ejemplos de comandos de verificación utilizarán la topología mostrada en la figura.

Verificar Problemas EtherChannel

Verificar Problemas EtherChannel

Existe una variedad de comandos para verificar una configuración EtherChannel. Haz clic en cada botón para obtener una explicación y un resultado de comando.


El comando show interfaces port-channel muestra el estado general de la interfaz de canal de puertos. En la figura, la interfaz de canal de puertos/Port Channel 1 está activa.

S1# show interfaces port-channel 1
Port-channel1 is up, line protocol is up (connected)
  Hardware is EtherChannel, address is c07b.bcc4.a981 (bia c07b.bcc4.a981)
  MTU 1500 bytes, BW 200000 Kbit/sec, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
(output omitted)

Cuando se configuren varias interfaces de canal de puertos en el mismo dispositivo, puedes usar el comando show etherchannel summary para mostrar una única línea de información por canal de puertos. En el resultado, el switch tiene un EtherChannel configurado; el grupo 1 utiliza el LACP.

El grupo de interfaces consta de las interfaces FastEthernet0/1 y FastEthernet0/2. El grupo es un EtherChannel de capa 2 y está en uso, según lo indican las letras SU junto al número de canal de puertos.

S1# show etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      N - not in use, no aggregation
        f - failed to allocate aggregator
        M - not in use, minimum links not met
        m - not in use, port not aggregated due to minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port
        A - formed by Auto LAG
Number of channel-groups in use: 1
Number of aggregators:           1
Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         LACP      Fa0/1(P)    Fa0/2(P)

Usa el comando show etherchannel port-channel para mostrar información sobre la interfaz del canal de puertos específica, como se muestra en el resultado. En el ejemplo, la interfaz de canal de puertos 1 consta de dos interfaces físicas, FastEthernet0/1 y FastEthernet0/2. Esta usa LACP en modo activo. Está correctamente conectada a otro switch con una configuración compatible, razón por la cual se dice que el canal de puertos está en uso.

S1# show etherchannel port-channel
                Channel-group listing:
                ----------------------
Group: 1
----------
                Port-channels in the group:
                ---------------------------
Port-channel: Po1    (Primary Aggregator)
------------
Age of the Port-channel   = 0d:01h:02m:10s
Logical slot/port   = 2/1          Number of ports = 2
HotStandBy port = null
Port state          = Port-channel Ag-Inuse
Protocol            =   LACP
Port security       = Disabled
Load share deferral = Disabled
Ports in the Port-channel:
Index   Load   Port     EC state        No of bits
------+------+------+------------------+-----------
  0     00     Fa0/1    Active             0
  0     00     Fa0/2    Active             0
Time since last port bundled:    0d:00h:09m:30s    Fa0/2

En cualquier miembro de una interfaz física de un grupo EtherChannel, el comando show interfaces etherchannel puede proporcionar información sobre el rol de la interfaz en el EtherChannel, como se muestra en el resultado. La interfaz FastEthernet0/1 forma parte del grupo EtherChannel 1. El protocolo para este EtherChannel es LACP.

S1# show interfaces f0/1 etherchannel
Port state    = Up Mstr Assoc In-Bndl
Channel group = 1           Mode = Active          Gcchange = -
Port-channel  = Po1         GC   =   -             Pseudo port-channel = Po1
Port index    = 0           Load = 0x00            Protocol =   LACP
Flags:  S - Device is sending Slow LACPDUs   F - Device is sending fast LACPDUs.
        A - Device is in active mode.        P - Device is in passive mode.
Local information:
                            LACP port     Admin     Oper    Port       
Port      Flags   State     Priority      Key       Number  State
Fa0/1     SA      bndl      32768         0x1       0x1     0x102       0x3D
Partner's information:
                  LACP port                        Admin  Oper   Port    Port
Port      Flags   Priority  Dev ID          Age    key    Key    Number  State
Fa0/1     SA      32768     c025.5cd7.ef00  12s    0x0    0x1    0x102   0x3Dof the port in the current state: 0d:00h:11m:51sllowed vlan 1,2,20

2. Problemas Comunes con Configuraciones de EtherChannel

Todas las interfaces dentro de un EtherChannel deben tener la misma configuración de velocidad y modo dúplex, de VLAN nativas y permitidas en los enlaces troncales, y de VLAN de acceso en los puertos de acceso. Garantizar estas configuraciones reducirá significativamente los problemas de red relacionados con EtherChannel. Entre los problemas comunes de EtherChannel se incluyen los siguientes:

  • Los puertos asignados en el EtherChannel no son parte de la misma VLAN ni son configurados como enlace troncal. Los puertos con VLAN nativas diferentes no pueden formar un EtherChannel.
  • El enlace troncal se configuró en algunos de los puertos que componen el EtherChannel, pero no en todos. No se recomienda configurar el modo trunking en los puertos individuales que componen el EtherChannel. Al configurar un troncal en un EtherChannel, verifica el modo de trunking en el EtherChannel.
  • Si el rango permitido de VLAN no es el mismo, los puertos no forman un EtherChannel incluso cuando el PAgP está configurado en el modo auto o desirable.
  • Las opciones de negociación dinámica para PAgP y LACP no se encuentran configuradas de manera compatible en ambos extremos del EtherChannel.

Nota: Es fácil confundir PAgP o LACP con DTP, ya que ambos son protocolos que se usan para automatizar el comportamiento en los enlaces troncales. PAgP y LACP se usan para la agregación de enlaces (EtherChannel). DTP se usa para automatizar la creación de enlaces troncales. Cuando se configura un enlace troncal de EtherChannel, normalmente se configura primero EtherChannel (PAgP o LACP) y después DTP.

3. Ejemplo de Solución de Problemas EtherChannel

En la figura, las interfaces F0/1 y F0/2 en los switches S1 y S2 se conectan con un EtherChannel. Sin embargo, el EtherChannel no está operativo.

Verificar Problemas EtherChannel

Verificar Problemas EtherChannel

Haz clic en cada botón para ver los pasos para solucionar problemas del EtherChannel.

La salida del comando show etherchannel summary indica que el EtherChannel está caído/down.

S1# show etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      N - not in use, no aggregation
        f - failed to allocate aggregator
        M - not in use, minimum links not met
        m - not in use, port not aggregated due to minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port
        A - formed by Auto LAG
Number of channel-groups in use: 1
Number of aggregators:           1
Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SD)         -      Fa0/1(D)    Fa0/2(D)

En la salida de show run | begin interface port-channel, una salida más detallada indica que existen modos PAgP incompatibles configurados en los switches S1 y S2.

S1# show run | begin interface port-channel
interface Port-channel1
 switchport trunk allowed vlan 1,2,20
 switchport mode trunk
!
interface FastEthernet0/1
 switchport trunk allowed vlan 1,2,20
 switchport mode trunk
 channel-group 1 mode on
!
interface FastEthernet0/2
 switchport trunk allowed vlan 1,2,20
 switchport mode trunk
 channel-group 1 mode on
!======================================
S2# show run | begin interface port-channel
interface Port-channel1
 switchport trunk allowed vlan 1,2,20
 switchport mode trunk
!
interface FastEthernet0/1
 switchport trunk allowed vlan 1,2,20
 switchport mode trunk
 channel-group 1 mode desirable
!
interface FastEthernet0/2
 switchport trunk allowed vlan 1,2,20
 switchport mode trunk
 channel-group 1 mode desirable

Para corregir el problema, el modo PAgP en el EtherChannel se cambia a desirable.

Nota: EtherChannel y STP deben interoperar. Por esta razón, el orden en el que se introducen los comandos relacionados con EtherChannel es importante, por lo que se ve la interfaz Port-Channel 1 eliminada y luego se vuelve a añadir con el comando channel-group, en lugar de cambiarlo directamente. Si se intenta cambiar la configuración directamente, los errores STP hacen que los puertos asociados pasen a un estado de bloqueo o de errdisabled.

S1(config)# no interface port-channel 1
S1(config)# interface range fa0/1 - 2
S1(config-if-range)# channel-group 1 mode desirable
Creating a port-channel interface Port-channel 1
S1(config-if-range)# no shutdown
S1(config-if-range)# exit
S1(config)# interface range fa0/1 - 2
S1(config-if-range)# channel-group 1 mode desirable
S1(config-if-range)# no shutdown
S1(config-if-range)# interface port-channel 1
S1(config-if)# switchport mode trunk
S1(config-if)# end
S1#

El EtherChannel ahora está activo según lo verificado por la salida del comando show etherchannel summary.

S1# show etherchannel summary
Flags:  D - down        P - bundled in port-channel
        I - stand-alone s - suspended
        H - Hot-standby (LACP only)
        R - Layer3      S - Layer2
        U - in use      N - not in use, no aggregation
        f - failed to allocate aggregator
        M - not in use, minimum links not met
        m - not in use, port not aggregated due to minimum links not met
        u - unsuitable for bundling
        w - waiting to be aggregated
        d - default port
        A - formed by Auto LAG
Number of channel-groups in use: 1
Number of aggregators:           1
Group  Port-channel  Protocol    Ports
------+-------------+-----------+-----------------------------------------------
1      Po1(SU)         PAgP      Fa0/1(P)    Fa0/2(P)

4. Packet Tracer – Solución de Problemas de EtherChannel

Un técnico júnior configuró recientemente cuatro switches. Los usuarios se quejan de que la red funciona con lentitud y te piden que investigues.

Glosario: Si tienes dudas con algún término especial, puedes consultar este diccionario de redes informáticas.

¡Listo! Sigue visitando nuestro blog de curso de redes, dale Me Gusta a nuestra fanpage; y encontrarás más herramientas y conceptos que te convertirán en todo un profesional de redes.

Deja un Comentario

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.

50% OFF POR BLACK FRIDAYCUPÓN: BLACKFRIDAY