Configuración de OSPF Multiárea

Se detallan los pasos para implementar OSPF multiárea. También se muestran ejemplos de configuración de OSPFv2 y OSPFv3 multiárea, así como el resumen de rutas OSPF.

¡Bienvenido a CCNA desde Cero!: Este tema forma parte del Capítulo 6 del curso de Cisco CCNA 2, para un mejor seguimiento del curso puede ir a la sección CCNA 3 para guiarse del índice.

1. Implementación de OSPF multiárea

La implementación de OSPF puede ser de área única o multiárea. El tipo de implementación de OSPF que se elige depende de los requisitos específicos y de la topología existente.

Para implementar OSPF multiárea, se deben seguir cuatro pasos.

Los pasos 1 y 2 forman parte del proceso de planificación.

  • Paso 1. Recopilar los parámetros y los requisitos de la red: esto incluye determinar la cantidad de dispositivos host y de red, el esquema de direccionamiento IP (si ya se implementó), el tamaño del dominio y de las tablas de routing, el riesgo de los cambios en la topología y otras características de la red.
  • Paso 2. Definir los parámetros de OSPF: sobre la base de la información que recopiló en el paso 1, el administrador de red debe determinar si la implementación preferida es OSPF de área única o multiárea. Si se selecciona OSPF multiárea, el administrador de red debe tener en cuenta lo siguiente:
  •  Plan de direccionamiento IP: este rige la manera en que se puede implementar OSPF y qué tan bien se podría escalar la implementación de OSPF.
  •  Áreas OSPF: la división de una red OSPF en áreas disminuye el tamaño de la LSDB y limita la propagación de las actualizaciones de estado de enlace cuando se modifica la topología. Se deben identificar los routers que van a cumplir la función de ABR y ASBR, así como los que van a realizar la sumarización o la redistribución.
  •  Topología de la red: esta consta de enlaces que conectan los equipos de red y que pertenecen a áreas OSPF diferentes en un diseño de OSPF multiárea. La topología de la red es importante para determinar los enlaces principales y de respaldo.
  • Paso 3. Configurar la implementación de OSPF multiárea según los parámetros.
  • Paso 4. Verificar la implementación de OSPF multiárea según los parámetros.

2. Configuración de OSPF de diversas áreas

Topología OSPFv2 multiárea

Imagen 1: Topología OSPFv2 multiárea

En la figura 1, se muestra la topología OSPF multiárea de referencia. En este ejemplo:

  • El R1 es un ABR porque tiene interfaces en el área 1 y una interfaz en el área 0.
  • R2 es un router de respaldo interno porque todas sus interfaces están en el área 0.
  • R3 es un ABR porque tiene interfaces en el área 2 y una interfaz en el área 0.

No se requieren comandos especiales para implementar esta red de OSPF de diversas áreas. Un router simplemente se convierte en ABR cuando tiene dos instrucciones network en diferentes áreas.

2.1. Ejemplo de Configuración OSPFv2 multiárea

Como se muestra a continuación, se asignó la ID de router 1.1.1.1 al R1. Este ejemplo activa OSPF en las dos interfaces LAN del área 1.

La interfaz serial se configura como parte de OSPF de área 0. Dado que el R2 tiene interfaces conectadas a dos áreas diferentes, es un ABR.

R1(config)# router ospf 10
R1(config-router)# router-id 1.1.1.1
R1(config-router)# network 10.1.1.1 0.0.0.0 area 1
R1(config-router)# network 10.1.2.1 0.0.0.0 area 1
R1(config-router)# network 192.168.10.1 0.0.0.0 area 0
R1(config-router)# end
R1#

Se configura OSPF multiárea en el R2 y se usa la máscara wildcard de la dirección de red de la interfaz:

R2(config)# router ospf 10
R2(config-router)# router-id 2.2.2.2
R2(config-router)# network 192.168.10.0 0.0.0.3 area 0
R2(config-router)# network 192.168.10.4 0.0.0.3 area 0
R2(config-router)# network 10.2.1.0 0.0.0.255 area 0
R2(config-router)# end
R2#
*Apr 19 18:11:04.029: %OSPF-5-ADJCHG: Process 10, Nbr 1.1.1.1 on 
Serial0/0/0 from LOADING to FULL, Loading Done
R2#

Luego se configura OSPF multiárea en el R3. Aquí se usa la máscara wildcard 0.0.0.0 para todas las redes.

R3(config)# router ospf 10
R3(config-router)# router-id 3.3.3.3
R3(config-router)# network 192.168.10.6 0.0.0.0 area 0
R3(config-router)# network 192.168.1.1 0.0.0.0 area 2
R3(config-router)# network 192.168.2.1 0.0.0.0 area 2
R3(config-router)# end
Apr 19 18:12:55.881: %OSPF-5-ADJCHG: Process 10, Nbr 2.2.2.2 on 
Serial0/0/1 from LOADING to FULL, Loading Done

Nota: las máscaras wildcard inversas utilizadas para configurar el R2 y el R3 difieren a propósito, con el fin de mostrar las dos alternativas para introducir las instrucciones network. El método utilizado para el R3 es más simple, ya que la máscara wildcard siempre es 0.0.0.0 y no es necesario calcularla.

3. Configuración de OSPFv3 de diversas áreas

Al igual que en OSPFv2, la implementación de la topología OSPFv3 multiárea de la Imagen 2 es sencilla.

Topología OSPFv3 multiárea

Imagen 2: Topología OSPFv3 multiárea

No se requieren comandos especiales. Un router se convierte en ABR cuando tiene dos interfaces en dos áreas diferentes.


3.1. Ejemplo de Configuración OSPFv3 multiárea

Por ejemplo, en el esquema de abajo, se asignó la ID de router 1.1.1.1 al R1. El ejemplo también habilita OSPF en las dos interfaces LAN en el área 1 y en la interfaz serial en el área 0. Dado que R1 tiene interfaces conectadas a dos áreas diferentes, es un ABR.

R1(config)# ipv6 router ospf 10
R1(config-rtr)# router-id 1.1.1.1
R1(config-rtr)# exit
R1(config)# 
R1(config)# interface GigabitEthernet 0/0
R1(config-if)# ipv6 ospf 10 area 1
R1(config-if)# 
R1(config-if)# interface Serial0/0/0
R1(config-if)# ipv6 ospf 10 area 0
R1(config-if)# end
R1#

Para R2, ingresamos al modo de configuración del router OSPFv3 con la ID de proceso 10 y configuramos la ID de router 2.2.2.2.

R2(config)# ipv6 router ospf 10
*Apr 24 14:18:10.463: %OSPFv3-4-NORTRID: Process OSPFv3-10-IPv6 
could not pick a router-id, please configure manually
R2(config-rtr)# router-id 2.2.2.2
R2(config-rtr)# exit

Ahora, se configura OSPFv3 para la ID de proceso 10 en cada una de las interfaces:

R2(config)# interfaz g0/0
R2(config-if)# ipv6 ospf 10 area 0
R2(config-if)# interfaz S0/0/0
R2(config-if)# ipv6 ospf 10 area 0
R2(config-if)# interfaz S0/0/1
R2(config-if)# ipv6 ospf 10 area 0
R2(config-if)# end
*Apr 24 14:18:35.135: %OSPFv3-5-ADJCHG: Process 10, Nbr 1.1.1.1 on 
Serial0/0/0 from LOADING to FULL, Loading Done

Para R3, ingresamos al modo de configuración del router OSPFv3 con la ID de proceso 10 y configuramos la ID de router 3.3.3.3.

R3(config)# ipv6 router ospf 10
*Apr 24 14:20:42.463: %OSPFv3-4-NORTRID: Process OSPFv3-10-IPv6 
could not pick a router-id, please configure manually
R3(config-rtr)# router-id 3.3.3.3
R3(config-rtr)# exit

Y por último, se configura OSPFv3 para la ID de proceso 10 en cada una de las interfaces:

R3(config)# interfaz g0/0
R3(config-if)# ipv6 ospf 10 area 2
R3(config-if)# interfaz S0/0/1
R3(config-if)# ipv6 ospf 10 area 0
R3(config-if)# end
*Apr 24 14:21:01.439: %OSPFv3-5-ADJCHG: Process 10, Nbr 2.2.2.2 on 
Serial0/0/1 from LOADING to FULL, Loading Done
R3#

4. Resumen de rutas OSPF

El resumen colabora para que las tablas de routing sean más breves. Implica consolidar varias rutas en un único anuncio, que luego se propaga hacia el área de red troncal.

Por lo general, los LSA de tipo 1 y tipo 2 se generan dentro de cada área, se traducen a LSA de tipo 3 y se envían a otras áreas. Si el área 1 tuviera treinta redes para anunciar, se reenviarían treinta LSA de tipo 3 hacia la red troncal. Con la sumarización de ruta, el ABR consolida las 30 redes en uno de dos anuncios.

En la Imagen 3 el R1 consolida todos los anuncios de red en una LSA de resumen.

Propagación de rutas resumidas

Imagen 3: Propagación de rutas resumidas

En lugar de reenviar LSA de manera individual para cada ruta del área 1, R1 reenvía un LSA de resumen al core router C1. C1, a su vez, reenvía el LSA de resumen hacia R2 y R3. R2 y R3 luego lo reenvían a sus respectivos routers internos.

El resumen también contribuye a aumentar la estabilidad de la red, porque reduce la inundación innecesaria de LSA.

Esta situación afecta directamente la cantidad de recursos de memoria, CPU y ancho de banda utilizados por el proceso de routing de OSPF. Sin un resumen de rutas, todo LSA de enlace específico se propaga en la red troncal OSPF y más allá, lo que genera tráfico de red y recarga del router innecesarios.

En la Imagen 4, un enlace de red en el R1 falla. El R1a envía una LSA al R1. Sin embargo, el R1 no propaga la actualización, ya que tiene configurada una ruta resumida. No se produce la saturación de enlaces específicos fuera del área con LSA.

Supresión de actualizaciones con la sumarización

Imagen 4: Supresión de actualizaciones con la sumarización

5. Sumarización de rutas externas e interárea

En OSPF, la sumarización se puede configurar solo en los ABR o los ASBR. En lugar de anunciar muchas redes específicas, los routers ABR y ASBR anuncian una ruta resumida. Los routers ABR resumen LSA de tipo 3 y los routers ASBR resumen LSA de tipo 5.

De manera predeterminada, las LSA de resumen (LSA de tipo 3) y las LSA externas (tipo 5) no contienen rutas resumidas (agregadas); es decir que, de manera predeterminada, las LSA de resumen no se resumen.

Como se muestra en las Imágenes 5 y 6, la sumarización de ruta se puede configurar de la siguiente manera:

  • Sumarización de rutas interárea: la sumarización de rutas interárea se produce en los ABR y se aplica a las rutas dentro de cada área. No se aplica a las rutas externas introducidas en OSPF mediante la redistribución.

Para realizar una sumarización de rutas interárea eficaz, las direcciones de red se deben asignar de manera contigua, para que dichas direcciones se puedan resumir en una cantidad mínima de direcciones de resumen.

  • Sumarización de rutas externas: la sumarización de rutas externas es específica de las rutas externas que se introducen en OSPF mediante la redistribución de rutas. Una vez más, es importante asegurar la contigüidad de los rangos de direcciones externas que se resumen.

Por lo general, solo los ASBR resumen rutas externas. Como se muestra en la Imagen 6, el ASBR R2 resume las rutas externas EIGRP en una única LSA y las envía al R1 y al R3.

Nota: en los ASBR, la sumarización de rutas externas se configura mediante el comando summary-address address mask del modo de configuración del router.

6. Sumarización de rutas interárea

OSPF no realiza la sumarización automática. La sumarización interárea se debe configurar manualmente en los ABR.

Solo los ABR pueden realizar la sumarización de rutas internas. Cuando se habilita la sumarización en un ABR, se introduce en el backbone una única LSA de tipo 3 que describe la ruta resumida. Esta única LSA resume varias rutas dentro del área.

Una ruta resumida se genera si por lo menos una subred dentro del área se encuentra dentro del rango de direcciones de resumen. La métrica de ruta resumida equivale al costo más bajo de todas las subredes dentro del rango de direcciones de resumen.

Nota: los ABR solo pueden resumir rutas que se encuentran dentro de las áreas conectadas a ellos.

En la Imagen 7, se muestra una topología OSPF multiárea. Las tablas de routing del R1 y el R3 se analizan para ver el efecto de la sumarización.

Sumarización de rutas interárea en los ABR

Imagen 7: Sumarización de rutas interárea en los ABR

En la Imagen 8, se muestra la tabla de routing del R1 antes de que se configure la sumarización, mientras que en la Imagen 9, se muestra la tabla de routing del R3.

Observe que, actualmente, el R3 tiene dos entradas de rutas interárea a las redes del área 1 del R1.

7. Cálculo de la ruta sumarizada

Cálculo de la ruta sumarizada

Imagen 10: Cálculo de la ruta sumarizada

La figura muestra que el resumen de redes en una única dirección y máscara se puede realizar en tres pasos:

  • Paso 1. Enumerar las redes en formato binario. En el ejemplo, las dos redes del área 1 (10.1.1.0/24 y 10.1.2.0/24) se indican en formato binario.
  • Paso 2. Contar el número de bits que coinciden en el extremo izquierdo para determinar la máscara de ruta sumarizada. Según lo resaltado, los primeros 22 dígitos del extremo izquierdo coinciden. Esto produce el prefijo /22 o la máscara de subred 255.255.252.0.
  • Paso 3. Copie los bits coincidentes y luego agregue los cero bits para determinar la dirección de red resumida. En este ejemplo, los bits coincidentes con ceros al final nos muestran como resultado la dirección de red 10.1.0.0/22. Esta dirección de resumen reúne cuatro redes: 10.1.0.0/24, 10.1.1.0/24, 10.1.2.0/24 y 10.1.3.0/24.

En el ejemplo, la dirección de resumen coincide con cuatro redes aunque solo existen dos redes.

8. Configuración de resumen de rutas interárea

En la Imagen 10, para demostrar el efecto de la sumarización de ruta, el R1 está configurado para resumir las rutas internas del área 1.

Para configurar manualmente la sumarización de rutas interárea en un ABR, utilice el comando area area-id range address mask del modo de configuración de router. Esto le ordena al ABR que resuma las rutas para un área específica antes de introducirlas en otra área en forma de LSA de tipo 3 de resumen a través del backbone.

Nota: en OSPFv3, el comando es idéntico, excepto por la dirección de red IPv6. La sintaxis del comando para OSPFv3 es area area id range prefix/prefix-length.

A continuación, se resumen las dos rutas internas del área 1 en una ruta resumida interárea OSPF en el R1. La ruta resumida 10.1.0.0/22 resume cuatro direcciones de red: de la 10.1.0.0/24 a la 10.1.3.0/24.

R1(config)# router ospf 10
R1(config-router)# area 1 range 10.1.0.0 255.255.252.0
R1(config-router)#

8.1. Tabla de routing después de la sumarización

En la Imagen 11, se muestra la tabla de routing IPv4 del R1. Observe que apareció una nueva entrada con una interfaz de salida Null0. Cuando se configura la sumarización manual para evitar los bucles de routing, el IOS de Cisco crea de manera automática una ruta resumida falsa a la interfaz Null0. Todo paquete enviado a una interfaz nula se descarta.

Tabla de routing después de la sumarización

Imagen 11: Verificación de la tabla de routing del R1 después de la sumarización

Por ejemplo, supongan que R1 recibió un paquete destinado a 10.1.0.10. Aunque coincidiría con la ruta sumarizada de R1, R1 no posee una ruta válida en el área 1.

Por lo tanto, el R1 consultaría la tabla de routing para buscar la siguiente coincidencia más extensa, que sería la entrada de Null0. El paquete se reenviaría a la interfaz Null0 y se descartaría. Este proceso evita que el router reenvíe el paquete a una ruta predeterminada y posiblemente cree un bucle.

Tabla de routing R3 después de la sumarización

Imagen 12: Verificación de la tabla de routing del R3 después de la sumarización

En la Imagen 12, se muestra la tabla de routing actualizada del R3. Noten cómo ahora solo existe una entrada de interárea que se dirige a la ruta sumarizada 10.1.0.0/22. Si bien este ejemplo solo redujo la tabla de routing en una entrada, la sumarización se puede implementar para resumir muchas redes. Esto reduciría el tamaño de las tablas de routing.

Sin respuestas a “Configuración de OSPF Multiárea”

Deja un Comentario

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.