Redes Punto a Punto OSPF

Redes Punto a Punto OSPF
5

Resumen

Aprende a configurar OSPFv2 de área única en una red punto a punto. ¡¡Empieza a aprender CCNA 200-301 gratis ahora mismo!!

¡Bienvenido!: Este tema forma parte del Módulo 2 del curso de Cisco CCNA 3, para un mejor seguimiento del curso puede ir a la sección CCNA 3 para guiarte del índice.

1. Sintaxis del Comando network

Un tipo de red que utiliza OSPF es la red punto a punto. Puedes especificar las interfaces que pertenecen a una red punto a punto configurando el comando network. También puedes configurar OSPF directamente en la interfaz con el comando ip ospf, como veremos más adelante.

Ambos comandos se utilizan para determinar qué interfaces participan en el proceso de enrutamiento para un área OSPFv2. La sintaxis básica para el comando network es la siguiente:

Router(config-router)# network network-address wildcard-mask area area-id
  • La sintaxis network-address wildcard-mask syntax se utiliza para habilitar el OSPF en las interfaces. Cualquier interfaz en un router que coincida con la dirección de red en el comando network se habilita para enviar y recibir paquetes OSPF.
  • La sintaxis area area-id se refiere al área OSPF. Al configurar OSPFv2 de área única, el comando network debe configurarse con el mismo valor de area-id en todos los routers. Aunque se puede utilizar cualquier ID de área, es una buena práctica utilizar un ID de área de 0 con OSPFv2 de área única. Esta convención facilita si la red se altera posteriormente para soportar OSPFv2 multiárea.

2. La Máscara Wildcard

La máscara de comodín (wildcard) es típicamente el inverso de la máscara de subred configurada en esa interfaz. En una máscara de subred, el 1 binario es igual a una coincidencia y el 0 binario no es una coincidencia. En una máscara de comodín, lo contrario es cierto, como se muestra aquí:

  • Máscara Wildcard bit 0 – Coincide con el valor de bits correspondiente en la dirección.
  • Máscara Wildcard bit 1 – Ignora el valor de bits correspondiente en la dirección.

El método más sencillo para calcular una máscara de comodín es restar la máscara de subred de la red de 255.255.255.255, como se muestra para las máscaras de subred /24 y /26 en la figura.

Ejemplo Máscara Wildcard

Ejemplo Máscara Wildcard

3. Comprueba tu Comprensión – Máscara Wildcard

[anuncio_b30 id=1]
[anuncio_b30 id=2]

Calcular la máscara de subred y la máscara de comodín necesarias para anunciar la dirección de red especificada en la OSPF. Escribe tus respuestas en los campos provistos.

Red / Subred / Host172.17.2.128/25
Máscara Subred Decimal
Máscara Wildcard

4. Configurar OSPF utilizando el Comando network

Dentro del modo de configuración de enrutamiento, hay dos formas de identificar las interfaces que participarán en el proceso de enrutamiento OSPFv2. En la ilustración, se muestra la topología de referencia.

Topología OSPF de referencia

Topología OSPF de referencia

En el primer ejemplo, la máscara wildcard identifica la interfaz en función de las direcciones de red. Cualquier interfaz activa configurada con una dirección IPv4 perteneciente a esa red, participará en el proceso de enrutamiento OSPFv2.

R1(config)# router ospf 10
R1(config-router)# network 10.10.1.0 0.0.0.255 area 0
R1(config-router)# network 10.1.1.4 0.0.0.3 area 0
R1(config-router)# network 10.1.1.12 0.0.0.3 area 0
R1(config-router)#

Note: Algunas versiones de IOS permiten introducir la máscara de subred en lugar de la máscara wildcard. Luego, IOS convierte la máscara de subred al formato de la máscara wildcard.

Como alternativa, el segundo ejemplo muestra cómo OSPFv2 se puede habilitar especificando la dirección IPv4 exacta de la interfaz usando una máscara wildcard de cuádruple cero. Ingresando network 10.1.1.5 0.0.0.0 area 0 en R1 le dice al router que habilite la interfaz Gigabit Ethernet 0/0/0 para el proceso de enrutamiento. Como resultado, el proceso OSPFv2 anuncia la red que se encuentra en esta interfaz (10.1.1.4/30).

R1(config)# router ospf 10
R1(config-router)# network 10.10.1.1 0.0.0.0 area 0
R1(config-router)# network 10.1.1.5 0.0.0.0 area 0
R1(config-router)# network 10.1.1.14 0.0.0.0 area 0
R1(config-router)#

La ventaja de especificar la interfaz es que no se necesita calcular la máscara wildcard. Observa que en todos los casos, el argumento area especifica el área 0.

5. Comprobador de Sintaxis – Configurar R2 y R3 usando el Comando network

Utiliza el Comprobador de Sintaxis para anunciar las redes conectadas a R2 y R3.

Nota: Mientras completa el Comprobador de Sintaxis, observa los mensajes informativos que describen la adyacencia entre R1 (1.1.1.1) y R2 (2.2.2.2). El esquema de direccionamiento IPv4 utilizado para el router ID facilita la identificación del vecino.

Actualmente estás conectado a R2:

  • Ingresa al modo de configuración de router OSPF con la ID de proceso 10.
  • Configura R2 con el router ID of 2.2.2.2
R2(config)#router ospf 10
R2(config-router)#router-id 2.2.2.2
R2(config-router)#

Anuncie las redes conectadas al R2 con la máscara wildcard adecuado utilizando el área 0. Configure las redes en el siguiente orden:

  1. 10.10.2.0/24
  2. 10.1.1.4/30
  3. 10.1.1.8/30
R2(config-router)#network 10.10.2.0 0.0.0.255 area 0
R2(config-router)#network 10.1.1.4 0.0.0.3 area 0
R2(config-router)#network 10.1.1.8 0.0.0.3 area 0
R2(config-router)#
\*Mar 25 21:19:21.938: %OSPF-5-ADJCHG: Process 10, Nbr 1.1.1.1 on GigabitEthernet0/0/0 from 
LOADING to FULL, Loading Done

Ahora configura el R3:

  • Ingresa al modo de configuración de router OSPF con la ID de proceso 10.
  • Configura el router ID en R3.
  • Utiliza la instrucción network para habilitar OSPF en función de la dirección de interfaz y la máscara wildcard de cuádruple cero para el área 0.
  • Vuelve al modo EXEC privilegiado cuando termines.
R3(config)#router ospf 10
R3(config-router)#router-id 3.3.3.3
R3(config-router)#

Utiliza la instrucción network para habilitar OSPF en función de la dirección de interfaz y la máscara wildcard de cuádruple cero para el área 0. Configura las interfaces en el siguiente orden:

  1. 10.10.3.1
  2. 10.1.1.10
  3. 10.1.1.13
R3(config-router)#network 10.10.3.1 0.0.0.0 area 0
R3(config-router)#network 10.1.1.10 0.0.0.0 area 0
R3(config-router)#network 10.1.1.13 0.0.0.0 area 0
R3(config-router)#
\*Mar 26 14:00:55.183: %OSPF-5-ADJCHG: Process 10, Nbr 1.1.1.1 on GigabitEthernet0/0/0 from 
LOADING to FULL, Loading Done
\*Mar 26 14:00:55.243: %OSPF-5-ADJCHG: Process 10, Nbr 2.2.2.2 on GigabitEthernet0/0/1 from 
LOADING to FULL, Loading Done
R3#

Anunciaste con éxito las redes OSPF en R2 y R3.

6. Configurar OSPF Utilizando el Comando ip ospf

También puedes configurar OSPF directamente en la interfaz en lugar de utilizar el comando network. Para configurar OSPF directamente en la interfaz, utiliza el comando en modo de configuración de interfaz: ip ospf. La sintaxis es la siguiente:

Router(config-if)# ip ospf process-id area area-id

Para R1, elimine los comandos network mediante el uso de la forma no de los comandos network. Y luego dirígete a cada interfaz y configura el comando ip ospf, como se muestra en la ventana de comandos.

R1(config)# router ospf 10
R1(config-router)# no network 10.10.1.1 0.0.0.0 area 0
R1(config-router)# no network 10.1.1.5 0.0.0.0 area 0
R1(config-router)# no network 10.1.1.14 0.0.0.0 area 0
R1(config-router)# interface GigabitEthernet 0/0/0
R1(config-if)# ip ospf 10 area 0
R1(config-if)# interface GigabitEthernet 0/0/1 
R1(config-if)# ip ospf 10 area 0
R1(config-if)# interface Loopback 0
R1(config-if)# ip ospf 10 area 0
R1(config-if)#

7. Comprobador de Sintaxis – Configurar R2 y R3 usando el Comando ip ospf

Utiliza el Comprobador de Sintaxis para anunciar las redes configurando las interfaces para OSPF en R2 y R3.

Actualmente estás conectado a R2. Los comandos network ya han sido eliminados. Configura el enrutamiento OSPF usando el proceso ID 10, en el área 0, en cada interfaz, en ese orden. Utiliza los siguientes nombres de interfaz abreviados:

  • lo0
  • g0/0/0
  • g0/0/1
R2(config)#interface lo0
R2(config-if)#ip ospf 10 area 0
R2(config-if)#interface g0/0/0
R2(config-if)#ip ospf 10 area 0
R2(config-if)#interface g0/0/1
R2(config-if)#ip ospf 10 area 0
\*Mar 25 21:19:21.938: %OSPF-5-ADJCHG: Process 10, Nbr 1.1.1.1 on GigabitEthernet0/0/0 from 
LOADING to FULL, Loading Done

Ahora estás conectado a R3. Los comandos network ya han sido eliminados. Configura el enrutamiento OSPF usando el proceso ID 10, en el área 0, en cada interfaz, en ese orden. Utiliza los siguientes nombres de interfaz abreviados:

  • lo0
  • g0/0/0
  • g0/0/1
R3(config)#interface lo0
R2(config-if)#ip ospf 10 area 0
R2(config-if)#interface g0/0/0
R2(config-if)#ip ospf 10 area 0
R2(config-if)#interface g0/0/1
R2(config-if)#ip ospf 10 area 0
\*Mar 26 14:00:55.183: %OSPF-5-ADJCHG: Process 10, Nbr 1.1.1.1 on GigabitEthernet0/0/0 from
LOADING to FULL, Loading Done
\*Mar 26 14:00:55.243: %OSPF-5-ADJCHG: Process 10, Nbr 2.2.2.2 on GigabitEthernet0/0/1 from
LOADING to FULL, Loading Done
R3(config-router)#

Has configurado con éxito las interfaces para anunciar las redes de OSPF.

8. Interfaz Pasiva

Por defecto, los mensajes OSPF se envían a todas las interfaces habilitadas para OSPF. Sin embargo, estos mensajes sólo necesitan ser enviados a interfaces que se conecten a otros routers habilitados para OSPF.

Topología OSPF de referencia

Topología OSPF de referencia

Consulta la topología de la figura. Los mensajes OSPFv2 se envían a través de las tres interfaces de loopback aunque no exista un vecino OSPFv2 en estas LANs simuladas. En una red de producción, estos “loopbacks” serían interfaces físicas para redes con usuarios y tráfico. El envío de mensajes innecesarios en una LAN afecta a la red de tres maneras, como se indica a continuación:

  • Uso ineficiente del ancho de banda – El ancho de banda disponible se consume transportando mensajes innecesarios.
  • Uso ineficiente de los recursos – Todos los dispositivos en la LAN deben procesar y eventualmente descartar el mensaje.
  • Mayor riesgo de seguridad – Sin configuraciones de seguridad adicionales de OSPF, los mensajes de OSPF pueden ser interceptados con un software de olfateo de paquetes. Las actualizaciones de enrutamiento pueden ser modificadas y enviadas de vuelta al router, corrompiendo la tabla de enrutamiento con métricas falsas que desvían el tráfico.

[anuncio_b30 id=3]

9. Configurar Interfaces Pasivas

Usa el comando passive-interface del modo de configuración del router para evitar la transmisión de mensajes de enrutamiento a través de una interfaz del router, pero aún así permitir que esa red se anuncie a otros routers. El ejemplo de configuración identifica la interfaz R1 Loopback 0/0/0 como pasiva.

Nota: La interfaz de loopback en este ejemplo representa una red Ethernet. En las redes de producción, las interfaces de loopback no requieren ser pasivas.

El comando show ip protocols c se utiliza para comprobar que la interfaz Loopback 0 aparece como pasiva. La interfaz todavía se enumera bajo el encabezado, “Routing on Interfaces Configured Explicitly (Area 0)“, lo que significa que esta red todavía se incluye como una entrada de ruta en las actualizaciones de OSPFv2 que se envían a R2 y R3.

R1(config)# router ospf 10
R1(config-router)# passive-interface loopback 0
R1(config-router)# end
R1#
*May 23 20:24:39.309: %SYS-5-CONFIG_I: Configured from console by console
R1# show ip protocols
*** IP Routing is NSF aware ***
(output omitted)
Routing Protocol is "ospf 10"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 1.1.1.1
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
  Routing on Interfaces Configured Explicitly (Area 0):
    Loopback0
    GigabitEthernet0/0/1
    GigabitEthernet0/0/0
  Passive Interface(s):
    Loopback0
  Routing Information Sources:
    Gateway         Distance      Last Update
    3.3.3.3              110      01:01:48
    2.2.2.2              110      01:01:38
  Distance: (default is 110)
R1#

10. Comprobador de Sintaxis – Configurar Interfaces Pasivas en R2 y R3

Usa el Comprobador de Sintaxis para configurar las interfaces de Loopback en R2 como pasivas. Como alternativa, todas las interfaces pueden hacerse pasivas usando el comando passive-interface default. Las interfaces que no deben ser pasivas pueden ser reactivadas usando el comando no passive-interface. Configura el R3 con el comando passive-interface default y luego vuelve a habilitar las interfaces Gigabit Ethernet.

Actualmente estás conectado a R2.

  • Introduce el modo de configuración del router de OSPF utilizando la ID de proceso 10.
  • Configura la interfaz Loopback como pasiva usando el nombre abreviado de interfaz Lo0.
  • Vuelve al modo EXEC privilegiado.
  • Verifica la configuración del OSPF con el comando show ip protocols.
R2(config)#router ospf 10
R2(config-router)#passive-interface lo0
R2(config-router)#end
\*May 23 20:27:20.718: %SYS-5-CONFIG\_I: Configured from console by console
R2#show ip protocols
\*\*\* IP Routing is NSF aware \*\*\*
(output omitted)
Routing Protocol is "ospf 10"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 2.2.2.2
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
  Routing on Interfaces Configured Explicitly (Area 0):
    Loopback0
    GigabitEthernet0/0/1
    GigabitEthernet0/0/0
  Passive Interface(s):
    Loopback0
  Routing Information Sources:
    Gateway         Distance      Last Update
    3.3.3.3              110      02:07:48
    1.1.1.1              110      02:34:53
  Distance: (default is 110)
R2#
R3(config)#router ospf 10
R3(config-router)#passive-interface default
\*Jun  5 23:06:46.668: %OSPF-5-ADJCHG: Process 10, Nbr 1.1.1.1 on GigabitEthernet0/0/0 from FULL
to DOWN, Neighbor Down: Interface down or detached
\*Jun  5 23:06:46.669: %OSPF-5-ADJCHG: Process 10, Nbr 2.2.2.2 on GigabitEthernet0/0/1 from FULL
to DOWN, Neighbor Down: Interface down or detached
R3(config-router)#no passive-interface g0/0/0
\*Jun  5 23:07:07.746: %OSPF-5-ADJCHG: Process 10, Nbr 1.1.1.1 on GigabitEthernet0/0/0 from
LOADING to FULL, Loading Done
R3(config-router)#no passive-interface g0/0/1
\*Jun  5 23:07:17.841: %OSPF-5-ADJCHG: Process 10, Nbr 2.2.2.2 on GigabitEthernet0/0/1 from
LOADING to FULL, Loading Done
R3(config-router)#end
\* Jun  5 23:07:35.732: %SYS-5-CONFIG\_I: Configured from console by console
R3#>show ip protocols
\*\*\* IP Routing is NSF aware \*\*\*
(output omitted)
Routing Protocol is "ospf 10"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Router ID 3.3.3.3
  Number of areas in this router is 1. 1 normal 0 stub 0 nssa
  Maximum path: 4
  Routing for Networks:
  Routing on Interfaces Configured Explicitly (Area 0):
    Loopback0
    GigabitEthernet0/0/1
    GigabitEthernet0/0/0
  Passive Interface(s):
    Serial0/1/0
    Serial0/1/1
    Loopback0
  Routing Information Sources:
    Gateway         Distance      Last Update
    1.1.1.1              110      00:00:59
    2.2.2.2              110      00:00:48
  Distance: (default is 110)
R3#

Has configurado correctamente las interfaces pasivas para R2 y R3.

11. Redes Punto a Punto OSPF

De forma predeterminada, los routers Cisco eligen DR y BDR en las interfaces Ethernet, incluso si solo hay otro dispositivo en el enlace. Puedes verificar esto con el comando show ip ospf interface command, como se muestra en el ejemplo de G0/0/0 de R1.

R1# show ip ospf interface GigabitEthernet 0/0/0
GigabitEthernet0/0/0 is up, line protocol is up 
  Internet Address 10.1.1.5/30, Area 0, Attached via Interface Enable
  Process ID 10, Router ID 1.1.1.1, Network Type BROADCAST, Cost: 1
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           1         no          no            Base
  Enabled by interface config, including secondary ip addresses
  Transmit Delay is 1 sec, State BDR, Priority 1
  Designated Router (ID) 2.2.2.2, Interface address 10.1.1.6
  Backup Designated router (ID) 1.1.1.1, Interface address 10.1.1.5
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:08
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/2/2, flood queue length 0
  Next 0x0(0)/0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 1
  Last flood scan time is 0 msec, maximum is 0 msec
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 2.2.2.2  (Designated Router)
  Suppress hello for 0 neighbor(s)
R1#

R1 es el BDR y R2 es el DR. El proceso de elección de DR/ BDR es innecesario ya que solo puede haber dos routers en la red punto a punto entre R1 y R2. Observa que en el resultado del router ha designado el tipo de red como Broadcast. Para cambiar esto a una red punto a punto, utiliza el comando de configuración de interfaza, ip ospf network point-to-point en todas las interfaces en las que desees deshabilitar el proceso de elección DR/BDR. El siguiente ejemplo muestra esta configuración para R1. El estado de adyacencia del vecino OSPF disminuirá durante unos milisegundos.

R1(config)# interface GigabitEthernet 0/0/0
R1(config-if)# ip ospf network point-to-point
*Jun  6 00:44:05.208: %OSPF-5-ADJCHG: Process 10, Nbr 2.2.2.2 on GigabitEthernet0/0/0 from FULL to DOWN, Neighbor Down: Interface down or detached
*Jun  6 00:44:05.211: %OSPF-5-ADJCHG: Process 10, Nbr 2.2.2.2 on GigabitEthernet0/0/0 from LOADING to FULL, Loading Done
R1(config-if)# interface GigabitEthernet 0/0/1
R1(config-if)# ip ospf network point-to-point
*Jun  6 00:44:45.532: %OSPF-5-ADJCHG: Process 10, Nbr 3.3.3.3 on GigabitEthernet0/0/1 from FULL to DOWN, Neighbor Down: Interface down or detached
*Jun  6 00:44:45.535: %OSPF-5-ADJCHG: Process 10, Nbr 3.3.3.3 on GigabitEthernet0/0/1 from LOADING to FULL, Loading Done
R1(config-if)# end
R1# show ip ospf interface GigabitEthernet 0/0/0
GigabitEthernet0/0/0 is up, line protocol is up 
  Internet Address 10.1.1.5/30, Area 0, Attached via Interface Enable
  Process ID 10, Router ID 1.1.1.1, Network Type POINT_TO_POINT, Cost: 1
  Topology-MTID    Cost    Disabled    Shutdown      Topology Name
        0           1         no          no            Base
  Enabled by interface config, including secondary ip addresses
  Transmit Delay is 1 sec, State POINT_TO_POINT
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    Hello due in 00:00:04
  Supports Link-local Signaling (LLS)
  Cisco NSF helper support enabled
  IETF NSF helper support enabled
  Index 1/2/2, flood queue length 0
  Next 0x0(0)/0x0(0)/0x0(0)
  Last flood scan length is 1, maximum is 2
  Last flood scan time is 0 msec, maximum is 1 msec
  Neighbor Count is 1, Adjacent neighbor count is 1 
    Adjacent with neighbor 2.2.2.2
  Suppress hello for 0 neighbor(s)
R1#

Observa que la interfaz Gigabit Ethernet 0/0/0 ahora muestra el tipo de red como POINT\ _TO\ _POINT y que no hay DR o BDR en el enlace.

12. Loopbacks y Redes Punto a Punto

Utilizamos loopbacks para proporcionar interfaces adicionales para una variedad de propósitos. En este caso, estamos utilizando loopbacks para simular más redes de las que el equipo puede soportar. De forma predeterminada, las interfaces loopback se anuncian como rutas de host/32. Por ejemplo, R1 anunciaría la red 10.10.1.0/24 como 10.10.1.1/32 a R2 y R3.

R2# show ip route | include 10.10.1
O        10.10.1.1/32 [110/2] via 10.1.1.5, 00:03:05, GigabitEthernet0/0/0

Para simular una LAN real, la interfaz Loopback 0 se configura como una red punto a punto para que R1 anuncie la red 10.10.1.0/24 completa a R2 y R3.

R1(config-if)# interface Loopback 0
R1(config-if)# ip ospf network point-to-point

Ahora R2 recibe la más precisa y simulada dirección de red LAN de 10.10.1.0/24.

R2# show ip route | include 10.10.1
O        10.10.1.0/24 [110/2] via 10.1.1.5, 00:00:30, GigabitEthernet0/0/0

Nota: En el momento de escribir esto, Packet Tracer no admite el comando ip ospf network point-to-point en interfaces Gigabit Ethernet. Sin embargo, es compatible con interfaces Loopback.

13. Packet Tracer – Configuración OSPFv2 de Área Única Punto a Punto

En esta actividad Packet Tracer, configurarás OSPFv2 de área única con lo siguiente:

  • Configurar explícitamente los router IDs.
  • Configurar el comando network en R1 utilizando la máscara wildcard basada en la máscara de subred.
  • Configurar el comando network en R2 utilizando la máscara wildcard de cuádruple cero.
  • Configurar el comando ip ospf interface en R3.
  • Configurar las interfaces pasivas
  • comandos* Verify OSPF operation using the show ip protocols and show ip route

In this Packet Tracer activity, you will configure the single-area OSPFv2 with the following:

  • Explicitly configure router IDs.
  • Configure the network command on R1 using wildcard mask based on the subnet mask.
  • Configure the network command on R2 using a quad-zero wildcard mask.
  • Configure the ip ospf interface command on R3.
  • Configure passive interfaces.
  • Verifique el funcionamiento del OSPF usando los comandos show ip protocols y show ip route.

Glosario: Si tienes dudas con algún término especial, puedes consultar este diccionario de redes informáticas.

¡Listo! Sigue visitando nuestro blog de curso de redes, dale Me Gusta a nuestra fanpage; y encontrarás más herramientas y conceptos que te convertirán en todo un profesional de redes.

Deja un Comentario

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.

¿Quieres aprobar la certificación Cisco CCNA?Sí, quiero!
+ +