Cómo Configurar un Router Cisco

  • 10/10
    Configuración de parámetros iniciales - 10/10
  • 10/10
    Configuración de interfaces - 10/10
  • 10/10
    Configuración del gateway predeterminado - 10/10

Aprende a configurar un router Cisco paso a paso: los parámetros iniciales, las interfaces activas y el gateway predeterminado.

¡Bienvenido!: Este tema forma parte del Capítulo 10 del curso de Cisco CCNA 1, para un mejor seguimiento del curso puede ir a la sección CCNA 1 para guiarte del índice.

1. Pasos básicos en la configuración de un router Cisco


  • Configurar el nombre del dispositivo
Router> enable
Router# configure terminal
Introduzca los comandos de configuración, uno por línea. Finalice con CNTL/Z.
Router(config)# hostname R1
  • Proteger el modo E X E C  (línea de consola)
R1(config)# line console 0
R1(config-line)# password ccnadesdecero
R1(config-line)# login
  • Acceso remoto seguro a Telnet / SSH.
R1(config-line)# line vty 0 4
R1(config-line)# password ccnadesdecero
R1(config-line)# login
R1(config-line)# transport input {ssh | telnet}
  • Proteger el modo EXEC con privilegios
R1(config)# enable secret ccnadesdecero
  • Proteger todas las contraseñas (cifrar las contraseñas)
R1(config)# service password-encryption
  • Proporcionar la notificación legal
R1(config)# banner motd #¡Acceso autorizado únicamente!#
  • Guardar la configuración
R1# copy running-config startup-config

1.1. Ejemplo de configuración básica del Router

En este ejemplo, el Router R1 en el diagrama de topología se configurará con la configuración inicial.

Ejemplo configuración básica Router

Ejemplo configuración básica Router

Para configurar el nombre del dispositivo para R1, usa los siguientes comandos.

Router> enable 
Router# configure terminal 
Enter configuration commands, one per line.
End with CNTL/Z.
Router(config)# hostname R1 
R1(config)#

Nota: Observe cómo el indicador del Router ahora muestra el hostname del Router.

Todo el acceso al Router debe estar asegurado. El modo EXEC privilegiado proporciona al usuario acceso completo al dispositivo y su configuración. Por lo tanto, es el modo más importante para asegurar.

Los siguientes comandos aseguran el modo EXEC privilegiado y el modo EXEC del usuario, habilitan el acceso remoto Telnet y SSH, y cifran todas las contraseñas de texto sin formato (es decir, las líneas EXEC y VTY del usuario).

R1(config)# enable secret class 
R1(config)#
R1(config)# line console 0 
R1(config-line)# password cisco 
R1(config-line)# login 
R1(config-line)# exit 
R1(config)#
R1(config)# line vty 0 4 
R1(config-line)# password cisco 
R1(config-line)# login 
R1(config-line)# transport input ssh telnet 
R1(config-line)# exit 
R1(config)#
R1(config)# service password-encryption 
R1(config)#

La notificación legal advierte a los usuarios que solo usuarios autorizados deben acceder al dispositivo. La notificación legal se configura de la siguiente manera.

R1(config)# banner motd #
Enter TEXT message. End with a new line and the #
*********************************************** 
ADVERTENCIA: ¡El acceso no autorizado está prohibido!
***********************************************
#
R1(config)#

Si se configuraron los comandos anteriores y el Router accidentalmente perdió energía, todos los comandos configurados se perderían. Por esta razón, es importante guardar la configuración cuando se implementan cambios. El siguiente comando guarda la configuración en NVRAM.

R1# copy running-config startup-config
Destination filename [startup-config]? 
Building configuration...
[OK]
R1#

2. Packet Tracer: configurar ajustes iniciales del Router

En esta actividad, realizará configuraciones básicas de Router. Asegurará el acceso a la CLI y al puerto de la consola utilizando contraseñas cifradas y de texto sin formato. También configurará mensajes para los usuarios que inicien sesión en el Router. Estas pancartas también advierten a los usuarios no autorizados que el acceso está prohibido. Finalmente, verificará y guardará su configuración en ejecución.

3. Configurar interfaces de routers

En este punto, los routers tienen sus configuraciones básicas. El siguiente paso es configurar sus interfaces. Esto se debe a que los dispositivos finales no pueden acceder a los routers hasta que se configuran las interfaces. Hay muchos tipos diferentes de interfaces disponibles en los routers Cisco. Por ejemplo, el Router Cisco ISR 4321 está equipado con dos interfaces Gigabit Ethernet:

  • GigabitEthernet 0/0/0 (G0/0/0)
  • GigabitEthernet 0/0/1 (G0/0/1)

La tarea de configurar una interfaz de Router es muy similar a un SVI de administración en un Switch. Específicamente, incluye la emisión de los siguientes comandos:

Router(config)# interface tipo-y-numero
Router(config-if)# description texto-descripcion
Router(config-if)# ip address ipv4-address mascara-subred
Router(config-if)# ipv6 address ipv6-address/prefijo-longitud
Router(config-if)# no shutdown

Nota: Cuando se habilita una interfaz de Router, se deben mostrar mensajes de información que confirman el enlace habilitado.

Aunque el comando de descripción no es necesario para habilitar una interfaz, es una buena práctica usarlo. Puede ser útil para solucionar problemas en redes de producción al proporcionar información sobre el tipo de red conectada. Por ejemplo, si la interfaz se conecta a un ISP o proveedor de servicios, el comando de descripción sería útil para ingresar la conexión de terceros y la información de contacto.

Nota: El texto descriptivo está limitado a 240 caracteres.

El uso del comando no shutdown activa la interfaz y es similar a encender la interfaz. La interfaz también debe estar conectada a otro dispositivo, como un Switch o un Router, para que la capa física esté activa.

Nota: En las conexiones entre routers donde no hay un Switch Ethernet, ambas interfaces de interconexión deben estar configuradas y habilitadas.

3.1. Ejemplo de configurar interfaces de Router

En este ejemplo, se habilitarán las interfaces conectadas directamente de R1 en el diagrama de topología.

Ejemplo configuración básica Router

Ejemplo configuración básica Router

Para configurar las interfaces en R1, usa los siguientes comandos.

R1> enable
R1# configure terminal
Enter configuration commands, one per line.
End with CNTL/Z.
R1(config)# interface gigabitEthernet 0/0/0
R1(config-if)# description Enlace a LAN
R1(config-if)# ip address 192.168.10.1 255.255.255.0
R1(config-if)# ipv6 address 2001:db8:acad:10::1/64
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)#
*Aug 1 01:43:53.435: %LINK-3-UPDOWN: Interface GigabitEthernet0/0/0, changed state to down
*Aug 1 01:43:56.447: %LINK-3-UPDOWN: Interface GigabitEthernet0/0/0, changed state to up
*Aug 1 01:43:57.447: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0/0, changed state to up
R1(config)#
R1(config)#
R1(config)# interface gigabitEthernet 0/0/1
R1(config-if)# description Enlace a R2
R1(config-if)# ip address 209.165.200.225 255.255.255.252
R1(config-if)# ipv6 address 2001:db8:feed:224::1/64
R1(config-if)# no shutdown
R1(config-if)# exit
R1(config)#
*Aug 1 01:46:29.170: %LINK-3-UPDOWN: Interface GigabitEthernet0/0/1, changed state to down
*Aug 1 01:46:32.171: %LINK-3-UPDOWN: Interface GigabitEthernet0/0/1, changed state to up
*Aug 1 01:46:33.171: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0/1, changed state to up
R1(config)#

Nota: Observa los mensajes informativos que nos informan que G0/0/0 y G0/0/1 están habilitados.

3.2. Verificar la configuración de la interfaz

Hay varios comandos que pueden usarse para verificar la configuración de la interfaz. El más útil de estos es el comando show ip interface brief y show ipv6 interface brief, como se muestra en el ejemplo.

R1# show ip interface brief
Interface                           IP-Address            OK?   Method  Status Protocol
GigabitEthernet0/0/0   192.168.10.1         YES   manual    up      up
GigabitEthernet0/0/1   209.165.200.225 YES   manual   up     up
Vlan1 unassigned                                           YES unset administratively     down   down
R1# show ipv6 interface brief
GigabitEthernet0/0/0     [up/up]
FE80::201:C9FF:FE89:4501
2001:DB8:ACAD:10::1
GigabitEthernet0/0/1    [up/up]
FE80::201:C9FF:FE89:4502
2001:DB8:FEED:224::1
Vlan1                                  [administratively down/down]
unassigned
R1#

4. Comandos de verificación de configuración

La tabla resume los comandos show más populares utilizados para verificar la configuración de la interfaz.

ComandosDescripción
show ip interface brief
show ipv6 interface brief
La salida muestra todas las interfaces, sus direcciones IP y su estado actual. Las interfaces configuradas y conectadas deben mostrar un estado de “up” y un protocolo de “up”. Cualquier otra cosa indicaría un problema con la configuración o el cableado.
show ip route
show ipv6 route
Muestra el contenido de las tablas de enrutamiento IP almacenadas en la RAM.
show interfaces
Muestra estadísticas para todas las interfaces en el dispositivo. Sin embargo, este comando solo mostrará la información de direccionamiento IPv4.
show ip interfaces
Muestra las estadísticas de IPv4 para todas las interfaces en un Router.
show ipv6 interface
Muestra las estadísticas de IPv6 para todas las interfaces en un Router.

Glosario: Si tienes dudas con algún término especial, puedes consultar este diccionario de redes informáticas.

¡Listo! Sigue visitando nuestro blog de curso de redes, dale Me Gusta a nuestra fanpage; y encontrarás más herramientas y conceptos que te convertirán en todo un profesional de redes.

9 Respuestas a “Cómo Configurar un Router Cisco”
  1. julio abril 10, 2018
  2. alexander agosto 9, 2018
  3. Andres julio 13, 2019
  4. Emmanuel mis noviembre 17, 2019
  5. Carlos Arias marzo 30, 2020

Deja un Comentario

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.

¿Quieres aprobar la certificación Cisco CCNA?Sí, quiero!
+ +