Configuración del Protocolo RIP

Aprenda a habilitar y configurar el protocolo RIP y RIP versión 2; a anunciar redes, verificar el routing del RIPv2 y configurar interfaces pasivas.

¡Bienvenido a CCNA desde Cero!: Este tema forma parte del Capítulo 3 del curso de Cisco CCNA 2, para un mejor seguimiento del curso puede ir a la sección CCNA 2 para guiarse del índice.

Si bien el protocolo RIP se utiliza con muy poca frecuencia en las redes modernas, es útil como base para comprender el routing de red básico. Esta sección se proporciona una breve descripción general de la forma en que se configuran los valores básicos de RIP y la manera en que se verifica RIPv2.

1. Modo de Configuración de RIP

Consulte la topología de referencia en la Imagen 1 y la tabla de direccionamiento en la Imagen 2:

Topología de Referencia para RIP

Imagen 1: Topología de Referencia para RIP

Tabla de direccionamiento RIP

Imagen 2: Tabla de direccionamiento

En esta situación, todos los routers se configuraron con funciones de administración básicas, y todas las interfaces identificadas en la topología de referencia están configuradas y habilitadas. No hay rutas estáticas configuradas ni protocolos de routing habilitados, por lo que el acceso remoto de red es imposible en ese momento. RIPv1 se utiliza como protocolo de routing dinámico. Para habilitar RIP, utilice el comando router rip, como se muestra a continuación:

R1# conf t
Enter configuration commands, one per line. End with CNTL/Z.
R1(config)# router rip
R1(config-router)#

Este comando no inicia en forma directa el proceso del RIP. En cambio, proporciona acceso al modo de configuración del router, donde se configuran los parámetros de routing RIP. Al habilitar RIP, la versión predeterminada es RIPv1.

Para deshabilitar y eliminar RIP, utilice el comando de configuración global no router rip. Este comando detiene el proceso RIP y elimina todas las configuraciones RIP existentes.

A continuación, se muestran los diversos comandos RIP que se pueden configurar. En esta sección, se abordan las palabras clave resaltadas.

R1(config-router)# ?
Router configuration commands:
 address-family          Enter Address Family command mode
 auto-summary            Enable automatic network
                         number summarization 
 default                 Set a command to its defaults
 default-information     Control distribution of 
                         default information 
 default-metric          Set metric of redistributed
                         routes
 distance                Define an administrative
                         distance
 distribute-list         Filter networks in routing
                         updates
 exit                    Exit from routing protocol
                         configuration mode
 flash-update-threshold  Specify flash update 
                         threshold in second
 help                    Description of the 
                         interactive help system
 input-queue             Specify input queue depth
 maximum-paths           Forward packets over multiple
                         paths
 neighbor                Specify a neighbor router
 network                 Enable routing on an IP network 
 no                      Negate a command or set its 
                         defaults
 offset-list             Add or subtract offset from
                         RIP metrics
 output-delay            Interpacket delay for RIP
                         updates
 passive-interface       Suppress routing updates on an 
                         interface 
 redistribute            Redistribute information from 
                         another routing protocol
 timers                  Adjust routing timers
 traffic-share           How to compute traffic share 
                         over alternate paths
 validate-update-source  Perform sanity checks against 
                         source address ofrouting
                         updates
 version                 Set routing protocol version
R1(config-router)#

2. Anuncio de redes

Al ingresar en el modo de configuración de router RIP, el router recibe instrucciones para que ejecute RIPv1. Pero el router aún necesita conocer las interfaces locales que deberá utilizar para comunicarse con otros routers, así como las redes conectadas en forma local que deberá publicar a dichos routers.

Para habilitar el routing RIP para una red, utilice network dirección de red (comando del modo de configuración del router) Introduzca la dirección de red con clase para cada red conectada directamente.

Topología de Referencia para RIP

Topología de Referencia para RIP

Teniendo en cuenta el ejemplo anterior, vamos a anunciar las redes conectadas directamente al R1, R2 y R3.

R1(config)# router rip
R1(config-router)# network 192.168.1.0
R1(config-router)# network 192.168.2.0
R1(config-router)#
R2(config)# router rip
R2(config-router)# red 192.168.2.0
R2(config-router)# network 192.168.3.0
R2(config-router)# network 192.168.4.0
R3(config)# router rip
R3(config-router)# network 192.168.4.0
R3(config-router)# network 192.168.5.0

Este comando realiza lo siguiente:

  • Habilita el RIP en todas las interfaces que pertenecen a una red específica. Hace que las interfaces asociadas ahora envíen y reciban actualizaciones RIP.
  • Publica la red especificada en las actualizaciones de enrutamiento RIP enviadas a otros routers cada 30 segundos.


Nota: RIPv1 es un protocolo de routing con clase para IPv4. Por lo tanto, si se introduce una dirección de subred, el IOS la convierte automáticamente a la dirección de red con clase. Por ejemplo, si se introduce el comando network 192.168.1.32, se convertiría automáticamente a network 192.168.1.0 en el archivo de configuración en ejecución. El IOS no proporciona un mensaje de error, sino que corrige la entrada e introduce la dirección de red con clase.

 

3. Verificar el routing del RIP

El comando show ip protocols muestra los parámetros del protocolo de routing IPv4 configurados actualmente en el router. Este resultado se muestra a continuación y confirma la mayoría de los parámetros de RIP, incluido lo siguiente:

  1. El routing RIP está configurado y en ejecución en el router R1.
  2. Los valores de diversos temporizadores; por ejemplo, el R1 envía la siguiente actualización de routing en 16 segundos.
  3. La versión de RIP configurada actualmente es RIPv1.
  4. El R1 realiza la sumarización en el límite de la red con clase.
  5. El R1 anuncia las redes con clase. Estas son las redes que el R1 incluye en sus actualizaciones RIP.
  6. Los vecinos RIP se indican mediante la inclusión de la dirección IP del siguiente salto, la AD asociada que el R2 utiliza para las actualizaciones enviadas por ese vecino y el momento en que dicho vecino recibió la última actualización.
<pre>R1# show ip protocols 
*** IP Routing is NSF aware ***

Routing Protocol is "rip"
 Outgoing update filter list for all interfaces is not set
 Incoming update filter list for all interfaces is not set
 Sending updates every 30 seconds, next due in 16 seconds
 Invalid after 180 seconds, hold down 180, flushed after 240
 Redistributing: rip

Default version control: send version 1, receive any version
 Interface Send Recv Triggered RIP Key-chain
 GigabitEthernet0/0 1 1 2 
 Serial0/0/0 1 1 2
 
 Automatic network summarization is in effect
 Maximum path: 4
 Routing for Networks:
 192.168.1.0
 192.168.2.0

Routing Information Sources:
 Gateway Distance Last Update
 192.168.2.2 120 00:00:15
 Distance: (default is 120)

R1#

Nota: este comando también resulta muy útil para verificar las operaciones de otros protocolos de routing (es decir, EIGRP y OSPF).

El comando show ip route muestra las rutas RIP instaladas en la tabla de routing. Comprobamos que R1 ahora tiene información acerca de las redes resaltadas.

R1# show ip route | begin Gateway
Gateway of last resort is not set

192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.1.0/24 is directly connected, GigabitEthernet0/0
L 192.168.1.1/32 is directly connected, GigabitEthernet0/0
 192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.2.0/24 is directly connected, Serial0/0/0
L 192.168.2.1/32 is directly connected, Serial0/0/0
R 192.168.3.0/24 [120/1] via 192.168.2.2, 00:00:24, Serial0/0/0
R 192.168.4.0/24 [120/1] via 192.168.2.2, 00:00:24, Serial0/0/0
R 192.168.5.0/24 [120/2] via 192.168.2.2, 00:00:24, Serial0/0/0
R1#

4. Habilitación y verificación de RIPv2

De manera predeterminada, cuando hay un proceso de RIP configurado en un router Cisco, este ejecuta RIPv1. Sin embargo, a pesar de que el router sólo envía mensajes de RIPv1, puede interpretar los mensajes de RIPv1 y RIPv2. Los routers RIPv1 simplemente ignoran los campos de RIPv2 en la entrada de ruta.

Utilice el comando del modo de configuración del router version 2 para habilitar RIPv2:

R1(config)# router rip
R1(config-router)# version 2
R1(config-router)# ^Z
R1#
R1# show ip protocols | section Default
 Default version control: send version 2, receive version 2
 Interface Send Recv Triggered RIP Key-chain
 GigabitEthernet0/0 2 2
 Serial0/0/0 2 2
R1#

Observe la forma en que el comando show ip protocols verifica que el R2 ahora está configurado para enviar y recibir solamente mensajes de versión 2. El proceso de RIP ahora incluye la máscara de subred en todas las actualizaciones, lo que hace que RIPv2 sea un protocolo de routing sin clase.

Nota: Configurar version 1 habilita RIPv1 solamente, mientras que configurar no version revierte el router a la configuración predeterminada, mediante la cual se envían actualizaciones de la versión 1 pero se está a la escucha de actualizaciones de la versión 1 y la versión 2.

A continuación, se verifica que ya no haya rutas RIP en la tabla de routing. Esto se debe a que el R1 ahora está a la escucha de actualizaciones RIPv2 únicamente. El R2 y el R3 todavía envían actualizaciones RIPv1. Por lo tanto, se debe configurar el comando version 2 en todos los routers en el dominio de routing.

R1# show ip route | begin Gateway
Gateway of last resort is not set

192.168.1.0/24 is variably subnetted, 2 subnets,<br>2 masks
C 192.168.1.0/24 is directly connected, 
GigabitEthernet0/0
L 192.168.1.1/32 is directly connected, 
GigabitEthernet0/0
 192.168.2.0/24 is variably subnetted, 2 subnets,
2 masks
C 192.168.2.0/24 is directly connected, Serial0/0/0
L 192.168.2.1/32 is directly connected, Serial0/0/0
R1#

5. Deshabilitar el resumen automático

Como se muestra en el siguiente resultado, RIPv2 resume automáticamente las redes en los límites de red principales de manera predeterminada, al igual que RIPv1.

R1# show ip protocols
*** IP Routing is NSF aware ***

Routing Protocol is "rip"
 Outgoing update filter list for all interfaces is not set
 Incoming update filter list for all interfaces is not set
 Sending updates every 30 seconds, next due in 16 seconds
 Invalid after 180 seconds, hold down 180, flushed after
 240
 Redistributing: rip
 Default version control: send version 2, receive version 2
 Interface Send Recv Triggered RIP Key-chain
 GigabitEthernet0/0 1 1 2
 Serial0/0/0 1 1 2
Automatic network summarization is in effect
 Maximum path: 4
 Routing for Networks:
 192.168.1.0
 192.168.2.0
 Routing Information Sources:
 Gateway Distance Last Update
 192.168.2.2 120 00:00:15
 Distance: (default is 120)
R1#

Para modificar el comportamiento predeterminado de RIPv2 de sumarización automática, utilice el comando del modo de configuración del router no auto-summary, como se muestra:

R1(config)# router rip 
R1(config-router)# no auto-summary 
R1(config-router)# end
R1#
*Mar 10 14:11:49.659: %SYS-5-CONFIG_I: Configured from
console by console
R1# show ip protocols | section Automatic
 Automatic network summarization is not in effect
R1#

Este comando no tiene ningún efecto cuando se utiliza RIPv1. Cuando se deshabilita la sumarización automática, RIPv2 ya no resume las redes a su dirección con clase en routers fronterizos. RIPv2 ahora incluye todas las subredes y sus máscaras correspondientes en sus actualizaciones de routing. El comando show ip protocols ahora indica lo siguiente: automatic network summarization is not in effect (el resumen de red automático no está en vigencia).

Nota: se debe habilitar RIPv2 antes de deshabilitar la sumarización automática.

6. Configuración de interfaces pasivas

De manera predeterminada, las actualizaciones de RIP se reenvían por todas las interfaces con RIP habilitado. Sin embargo, las actualizaciones de RIP solo se deben enviar por interfaces conectadas a otros routers con RIP habilitado.

Topología de Referencia para RIP

Topología de Referencia para RIP

Por ejemplo, consulte la topología en la figura de ejemplo. RIP envía actualizaciones por su interfaz G0/0, aunque no existe ningún dispositivo RIP en esa LAN. No hay manera de que el R1 tenga información acerca de esto y, como resultado, envía una actualización cada 30 segundos. El envío de actualizaciones innecesarias a una LAN impacta en la red de tres maneras:

  1. Desperdicio de ancho de banda: se utiliza ancho de banda para transportar actualizaciones innecesarias. Dado que las actualizaciones de RIP se transmiten por difusión o multidifusión, los switches también reenvían las actualizaciones por todos los puertos.
  2. Desperdicio de recursos: todos los dispositivos en la LAN deben procesar la actualización hasta las capas de transporte, punto en el cual los dispositivos descartan la actualización.
  3. Riesgo de seguridad: el anuncio de actualizaciones en una red de difusión constituye un riesgo de seguridad. Las actualizaciones RIP pueden interceptarse con software analizador de protocolos. Las actualizaciones de enrutamiento se pueden modificar y enviar de regreso al router, y dañar la tabla de enrutamiento con métricas falsas que desorientan el tráfico.

Utilice el comando de configuración del router passive-interface para evitar que las actualizaciones de routing se transmitan a través de una interfaz del router y permitir que esa red se siga anunciando a otros routers. El comando detiene las actualizaciones de routing a través de la interfaz especificada. Sin embargo, la red a la que pertenece la interfaz especificada aún se anuncia en las actualizaciones de routing enviadas a otras interfaces.

No es necesario que el R1, el R2, y el R3 reenvíen actualizaciones RIP por sus interfaces LAN. En la configuración de siguiente, se identifica la interfaz G0/0 del R1 como pasiva. El comando show ip protocols se utiliza para verificar que la interfaz Gigabit Ethernet es pasiva. Observe que ya no se indica que la interfaz G0/0 envía o recibe actualizaciones de versión 2, sino que se encuentra en la sección Passive Interface(s) (Interfaces pasivas). Asimismo, observe que la red 192.168.1.0 aún se encuentra bajo Routing for Networks (Routing para redes), lo cual significa que esta red aún está incluida como una entrada de ruta en las actualizaciones RIP que se envían al R2.

R1(config)# router rip 
R1(config-router)# passive-interface g0/0 
R1(config-router)# end 
R1#
R1# show ip protocols | begin Default 
Default version control: send version 2, receive version 2
 Interface Send Recv Triggered RIP Key-chain 
 Serial0/0/0 2 2
Automatic network summarization is not in effect
Maximum path: 4
Routing for Networks: 
 192.168.1.0
 192.168.2.0
Passive Interface(s):
 GigabitEthernet0/0
Routing Information Sources:
 Gateway Distance Last Update 
 192.168.2.2 120 00:00:06 
Distance: (default is 120)
R1#

Nota: todos los protocolos de routing admiten el comando passive-interface.

Como alternativa, todas las interfaces se pueden convertir en pasivas con el comando passive-interface default. Las interfaces que no deben ser pasivas se pueden volver a habilitar con el comando no passive-interface.

7. Propagar una ruta predeterminada

Consulte la Imagen 3. En esta situación, el R1 es el router perimetral con una conexión simple a un proveedor de servicios. Por lo tanto, para que el R1 llegue a Internet, solo se requiere una ruta estática predeterminada desde la interfaz Serial 0/0/1.

Propagación de una ruta predeterminada

Imagen 3: Propagación de una ruta predeterminada

Se podrían configurar rutas estáticas predeterminadas similares en el R2 y en el R3, pero es mucho más escalable introducirla una vez en el router perimetral R1 y, a continuación, hacer que el R1 la propague al resto de los routers mediante RIP. Para proporcionarle conectividad a Internet a todas las demás redes del dominio de enrutamiento RIP, la ruta estática predeterminada debe publicarse a todos los demás routers que usan el protocolo de enrutamiento dinámico.

Para propagar una ruta predeterminada en RIP, el router perimetral debe estar configurado con lo siguiente:

  • Una ruta estática predeterminada, mediante el comando ip route 0.0.0.0 0.0.0.0.
  • El comando de configuración del router default-information originate. Esto le ordena al R1 que produzca información predeterminada mediante la propagación de la ruta estática predeterminada en actualizaciones RIP.

Por último, vayamos a configurar una ruta estática predeterminada completamente especificada al proveedor de servicios y, a continuación, se propaga la ruta mediante RIP. Observe que ahora el R1 tiene un gateway de último recurso y una ruta predeterminada instalados en su tabla de routing.

R1(config)# ip route 0.0.0.0 0.0.0.0 S0/0/1 209.165.200.226
R1(config)# router rip
R1(config-router)# default-information originate 
R1(config-router)# ^Z
R1#
*Mar 10 23:33:51.801: %SYS-5-CONFIG_I: Configured from 
console by console
R1# show ip route | begin Gateway
Gateway of last resort is 209.165.200.226 to network 0.0.0.0

S* 0.0.0.0/0 [1/0] via 209.165.200.226, Serial0/0/1
 192.168.1.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.1.0/24 is directly connected, GigabitEthernet0/0
L 192.168.1.1/32 is directly connected, GigabitEthernet0/0
 192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.2.0/24 is directly connected, Serial0/0/0
L 192.168.2.1/32 is directly connected, Serial0/0/0
R 192.168.3.0/24 [120/1] via 192.168.2.2, 00:00:08, 
Serial0/0/0
R 192.168.4.0/24 [120/1] via 192.168.2.2, 00:00:08, 
Serial0/0/0
R 192.168.5.0/24 [120/2] via 192.168.2.2, 00:00:08, 
Serial0/0/0
 209.165.200.0/24 is variably subnetted, 2 subnets, 2 masks
C 209.165.200.0/24 is directly connected, Serial0/0/1
L 209.165.200.225/27 is directly connected, Serial0/0/1
R1#

Deja un Comentario

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.