Solución de Problemas de Enrutamiento Entre VLAN

Solución de Problemas Enrutamiento de entre VLAN
5

Resumen

Aprenderás a solucionar los problemas comunes de configuración de inter-VLAN. ¡¡Empieza a aprender CCNA 200-301 gratis ahora mismo!!

¡Bienvenido!: Este tema forma parte del Módulo 4 del curso de Cisco CCNA 2, para un mejor seguimiento del curso puede ir a la sección CCNA 2 para guiarte del índice.

1. Problemas Comunes de Enrutamiento Entre VLAN

Ya sabes que cuando configures y verifiques, también debes ser capaz de solucionar problemas. En este tema se describen algunos problemas comunes de red asociados con el Enrutamiento Entre VLAN (routing Inter-VLAN).

Hay varias razones por las que una configuración entre VLANs puede no funcionar. Todos están relacionados con problemas de conectividad. En primer lugar, comprueba la capa física para resolver cualquier problema en el que un cable pueda estar conectado al puerto incorrecto. Si las conexiones son correctas, utiliza la lista de la tabla para otras razones comunes por las que puede fallar la conectividad entre VLAN.

Tipo de problemaCómo arreglarCómo verificar
VLAN faltantes
  • Crea (o vuelve a crear) la VLAN si no existe.
  • Asegúrese de que el puerto host está asignado a la VLAN correcta.
show vlan [brief]
show interfaces switchport
ping
Problemas con el puerto troncal del switch
  • Asegúrate de que los enlaces troncales estén configurados correctamente.
  • Asegúrate de que el puerto es un puerto troncal y está habilitado.
show interfaces trunk
show running-config
Problemas en los puertos de acceso de switch
  • Asigna el puerto a la VLAN correcta.
  • Asegúrate de que el puerto es un puerto de acceso y está habilitado.
  • El host está configurado incorrectamente en la subred incorrecta.
show interfaces switchport
show running-config interface
ipconfig
Problemas de configuración del router
  • La dirección IPv4 de la subinterfaz del router está configurada incorrectamente.
  • La subinterfaz del router se asigna al ID de VLAN.
show ip interface brief
show interfaces

2. Escenario de resolución de problemas de Enrutamiento Entre VLAN

Los ejemplos de algunos de estos problemas de Routing Inter-VLAN ahora se tratarán con más detalle.

Esta topología se utilizará para todos estos problemas.

Ejemplo solución problemas Enrutamiento Entre VLAN

Ejemplo solución problemas Enrutamiento Entre VLAN

La información de direccionamiento VLAN e IPv4 para R1 se muestra en la tabla.

Subinterfaces del router R1

SubinterfaceVLANDirección IP
G0/0/0.1010192.168.10.1/24
G0/0/0.2020192.168.20.1/24
G0/0/0.3099192.168.99.1/24

3. VLANs faltantes

Un problema de conectividad entre VLAN podría deberse a la falta de una VLAN. La VLAN podría faltar si no se creó, se eliminó accidentalmente o no se permite en el enlace troncal.


Por ejemplo, PC1 está conectado actualmente a la VLAN 10, como se muestra en el ejemplo del comando show vlan brief.

S1# show vlan brief
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/2, Fa0/3, Fa0/4, Fa0/7
                                                Fa0/8, Fa0/9, Fa0/10, Fa0/11
                                                Fa0/12, Fa0/13, Fa0/14, Fa0/15
                                                Fa0/16, Fa0/17, Fa0/18, Fa0/19
                                                Fa0/20, Fa0/21, Fa0/22, Fa0/23
                                                Fa0/24, Gi0/1, Gi0/2
10   LAN10                            active    Fa0/6
20   LAN20                            active
99   Management                       active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
S1#

Ahora asume que la VLAN 10 se elimina accidentalmente, como se muestra en el siguiente resultado

S1(config)# no vlan 10
S1(config)# do show vlan brief
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/2, Fa0/3, Fa0/4, Fa0/7
                                                Fa0/8, Fa0/9, Fa0/10, Fa0/11
                                                Fa0/12, Fa0/13, Fa0/14, Fa0/15
                                                Fa0/16, Fa0/17, Fa0/18, Fa0/19
                                                Fa0/20, Fa0/21, Fa0/22, Fa0/23
                                                Fa0/24, Gi0/1, Gi0/2
20   LAN20                            active
99   Management                       active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
S1(config)#

Observa que ahora falta VLAN 10 en el resultado. Observa también que el puerto Fa0/6 no se ha reasignado a la VLAN predeterminada. Cuando eliminas una VLAN, cualquier puerto asignado a esa VLAN queda inactivo. Permanecen asociados con la VLAN (y, por lo tanto, inactivos) hasta que los asigne a una nueva VLAN o vuelvas a crear la VLAN que falta.

Utiliza el comando show interface interface-id switchport para verificar la pertenencia a VLAN.

S1(config)# do show interface fa0/6 switchport
Name: Fa0/6
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: native
Negotiation of Trunking: Off
Access Mode VLAN: 10 (Inactive)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
(Output omitted)

Si se vuelve a crear la VLAN que falta, se reasignarán automáticamente los hosts a ella, como se muestra en el siguiente resultado.

S1(config)# vlan 10
S1(config-vlan)# do show vlan brief
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/2, Fa0/3, Fa0/4, Fa0/7
                                                Fa0/8, Fa0/9, Fa0/10, Fa0/11
                                                Fa0/12, Fa0/13, Fa0/14, Fa0/15
                                                Fa0/16, Fa0/17, Fa0/18, Fa0/19
                                                Fa0/20, Fa0/21, Fa0/22, Fa0/23
                                                Fa0/24, Gi0/1, Gi0/2
20   LAN20                            active
99   Management                       active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
S1(config-vlan)#

Observa que la VLAN no se ha creado como se esperaba. La razón se debe a que debes salir del modo de subconfiguración de VLAN para crear la VLAN, como se muestra en el siguiente resultado.

S1(config-vlan)# exit
S1(config)# do show vlan brief
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/2, Fa0/3, Fa0/4, Fa0/7
                                                Fa0/8, Fa0/9, Fa0/10, Fa0/11
                                                Fa0/12, Fa0/13, Fa0/14, Fa0/15
                                                Fa0/16, Fa0/17, Fa0/18, Fa0/19
                                                Fa0/20, Fa0/21, Fa0/22, Fa0/23
                                                Fa0/24, Gi0/1, Gi0/2
10   VLAN0010                         active    Fa0/6
20   LAN20                            active
99   Management                       active
1002 fddi-default                     act/unsup
1003 token-ring-default               act/unsup
1004 fddinet-default                  act/unsup
1005 trnet-default                    act/unsup
S1(config)#

Ahora observa que la VLAN está incluida en la lista y que el host conectado a Fa0/6 está en la VLAN 10.

4. Problemas con el Puerto Troncal del Switch

Otro problema para el enrutamiento de la inter VLAN incluye puertos de switch mal configurados. En una solución de inter-VLAN heredada, esto podría ser causado cuando el puerto del router de conexión no está asignado a la VLAN correcta.

Sin embargo, con una solución router-on-a-stick, la causa más común es un puerto troncal mal configurado.

Por ejemplo, supón que PC1 pudo conectarse a hosts de otras VLAN hasta hace poco. Un vistazo rápido a los registros/logs de mantenimiento reveló que recientemente se accedió al switch S1 Capa 2 para el mantenimiento rutinario. Por lo tanto, sospechsa que el problema puede estar relacionado con ese switch.

Ejemplo solución problemas Enrutamiento Entre VLAN

Ejemplo solución problemas Enrutamiento Entre VLAN

En S1, verifica que el puerto que se conecta a R1 (es decir, F0/5) esté configurado correctamente como enlace troncal utilizando el comando show interfaces trunk, como se muestra.

S1# show interfaces trunk
Port        Mode             Encapsulation  Status        Native vlan
Fa0/1       on               802.1q         trunking      1
Port        Vlans allowed on trunk
Fa0/1       1-4094
Port        Vlans allowed and active in management domain
Fa0/1       1,10,20,99
Port        Vlans in spanning tree forwarding state and not pruned
Fa0/1       1,10,20,99
S1#

El puerto Fa0/5 que conecta a R1 falta misteriosamente en el resultado. Verifica la configuración de la interfaz mediante el comando show running-config interface fa0/5, como se muestra.

S1# show running-config interface fa0/5
Building configuration...
Current configuration : 96 bytes
!
interface FastEthernet0/5
 description Trunk link to R1
 switchport mode trunk
 shutdown
end
S1#

Como puedes ver, el puerto fue apagado/down accidentalmente. Para corregir el problema, vuelve a habilitar el puerto y verifica el estado de enlace troncal, como se muestra en el ejemplo.

S1(config)# interface fa0/5
S1(config-if)# no shut
S1(config-if)#
*Mar  1 04:46:44.153: %LINK-3-UPDOWN: Interface FastEthernet0/5, changed state to up
S1(config-if)#
*Mar  1 04:46:47.962: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/5, changed state to up
S1(config-if)# do show interface trunk
Port        Mode             Encapsulation  Status        Native vlan
Fa0/1       on               802.1q         trunking      1
Fa0/5       on               802.1q         trunking      1
Port        Vlans allowed on trunk
Fa0/1       1-4094
Fa0/5       1-4094
Port        Vlans allowed and active in management domain
Fa0/1       1,10,20,99
Fa0/5       1,10,20,99
Port        Vlans in spanning tree forwarding state and not pruned
Fa0/1       1,10,20,99
Fa0/1       1,10,20,99
S1(config-if)#

Para reducir el riesgo de que un enlace entre switches que falla interrumpa el enrutamiento entre VLAN, los enlaces redundantes y las rutas alternativas deben formar parte del diseño de la red.

5. Problemas en Puertos de Acceso de Switch

Cuando sospeches que hay un problema con una configuración del switch, utiliza los distintos comandos de verificación para examinar la configuración e identificar el problema.

Supongamos que PC1 tiene la dirección IPv4 y la puerta de enlace predeterminada correcta, pero no es capaz de hacer ping a su propia puerta de enlace por defecto. Se supone que el PC1 está conectado a un puerto VLAN 10.

Ejemplo solución problemas Enrutamiento Entre VLAN

Ejemplo solución problemas Enrutamiento Entre VLAN

Verifica la configuración del puerto en S1 mediante el comando show interfaces interface-id switchport.

S1# show interface fa0/6 switchport
Name: Fa0/6
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: native
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none

El puerto Fa0/6 se ha configurado como un puerto de acceso como se indica en «static access». Sin embargo, parece que no se ha configurado para estar en VLAN 10. Verifica la configuración de la interfaz.

S1# show running-config interface fa0/6
Building configuration...
Current configuration : 87 bytes
!
interface FastEthernet0/6
 description PC-A access port
 switchport mode access
end
S1#

Asigna el puerto Fa0/6 a la VLAN 10 y verifica la asignación del puerto.

S1# configure terminal
S1(config)# interface fa0/6
S1(config-if)# switchport access vlan 10
S1(config-if)# 
S1(config-if)# do show interface fa0/6 switchport
Name: Fa0/6
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: native
Negotiation of Trunking: Off
Access Mode VLAN: 10 (VLAN0010)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
(Output omitted)

PC1 ahora puede comunicarse con hosts de otras VLAN.

6. Problemas de Configuración del Router

Los problemas de configuración del router-on-a-stick suelen estar relacionados con configuraciones incorrectas de la subinterfaz. Por ejemplo, se configuró una dirección IP incorrecta o se asignó un ID de VLAN incorrecto a la subinterfaz.

Por ejemplo, R1 debería proporcionar routing inter-VLAN para los usuarios de VLAN 10, 20 y 99. Sin embargo, los usuarios de VLAN 10 no pueden llegar a ninguna otra VLAN.

Ejemplo solución problemas Enrutamiento Entre VLAN

Ejemplo solución problemas Enrutamiento Entre VLAN

Verificaste el enlace troncal del switch y todo parece estar en orden. Verifica el estatus de las interfaces usando el comando show ip interface brief.

R1# show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
GigabitEthernet0/0/0   unassigned      YES unset  administratively down down
GigabitEthernet0/0/1   unassigned      YES unset  up                    up
Gi0/0/1.10             192.168.10.1    YES manual up                    up
Gi0/0/1.20             192.168.20.1    YES manual up                    up
Gi0/0/1.99             192.168.99.1    YES manual up                    up
Serial0/1/0            unassigned      YES unset  administratively down down
Serial0/1/1            unassigned      YES unset  administratively down down
R1#

A las subinterfaces se les han asignado las direcciones IPv4 correctas y están operativas.

Verifique en qué VLAN está cada una de las subinterfaces. Para ello, el comando show interfaces es útil, pero genera una gran cantidad de resultados adicionales no requeridos. El resultado del comando se puede reducir utilizando filtros de comando IOS como se muestra en el ejemplo.

R1# show interfaces | include Gig|802.1Q
GigabitEthernet0/0/0 is administratively down, line protocol is down
GigabitEthernet0/0/1 is up, line protocol is up
  Encapsulation 802.1Q Virtual LAN, Vlan ID  1., loopback not set
GigabitEthernet0/0/1.10 is up, line protocol is up
  Encapsulation 802.1Q Virtual LAN, Vlan ID  100.
GigabitEthernet0/0/1.20 is up, line protocol is up
  Encapsulation 802.1Q Virtual LAN, Vlan ID  20.
GigabitEthernet0/0/1.99 is up, line protocol is up
  Encapsulation 802.1Q Virtual LAN, Vlan ID  99.
R1#

El símbolo de pipe (|) junto con algunas palabras clave de selección es un método útil para ayudar a filtrar el resultado del comando. En este ejemplo, la palabra clave include se utilizó para identificar que sólo se mostrarán las líneas que contienen las letras «Gig» o «802.1Q». Debido a la forma en que la salida de show interface está naturalmente listada, el uso de estos filtros produce una lista condensada de interfaces y sus VLANs asignadas.

Observa que la interfaz G0/0/1.10 se ha asignado incorrectamente a la VLAN 100 en lugar de a la VLAN 10. Esto se confirma mirando la configuración de la subinterfaz GigabitEthernet 0/0/1.10 de R1, como se muestra.

R1# show running-config interface g0/0/1.10
Building configuration...
Current configuration : 146 bytes
!
interface GigabitEthernet0/0/1.10
 description Default Gateway for VLAN 10
 encapsulation dot1Q 100
 ip address 192.168.10.1 255.255.255.0
end
R1#

Para corregir este problema, configura la subinterfaz G0/0/1.10 para que esté en la VLAN correcta mediante el comando encapsulation dot1q 10 en el modo de configuración de subinterfaz.

R1# conf t
Enter configuration commands, one per line.  End with CNTL/Z.
R1(config)# interface gigabitEthernet 0/0/1.10
R1(config-subif)# encapsulation dot1Q 10
R1(config-subif)# end
R1#
R1# show interfaces | include Gig|802.1Q
GigabitEthernet0/0/0 is administratively down, line protocol is down
GigabitEthernet0/0/1 is up, line protocol is up
  Encapsulation 802.1Q Virtual LAN, Vlan ID  1., loopback not set
GigabitEthernet0/0/1.10 is up, line protocol is up
  Encapsulation 802.1Q Virtual LAN, Vlan ID  10.
GigabitEthernet0/0/1.20 is up, line protocol is up
  Encapsulation 802.1Q Virtual LAN, Vlan ID  20.
GigabitEthernet0/0/1.99 is up, line protocol is up
R1#

Una vez asignada la subinterfaz a la VLAN correcta, los dispositivos en esa VLAN pueden acceder a ella, y el router puede realizar routing inter-VLAN.

Con la correcta verificación, los problemas de configuración del router se resuelven rápidamente, lo que permite que el routing inter-VLAN funcione de forma adecuada.

7. Packet Tracer – Resolución de Problemas de Routing Inter-VLAN

En esta actividad de Packet Tracer, completarás los siguientes objetivos:

  • Part 1: Encontrar los problemas de red
  • Part 2: Implementación de la solución
  • Part 3: Verificar la conectividad de la red

8. Lab – Troubleshoot Inter-VLAN Routing

In this lab, you will complete the following objectives:

  • Part 1: Build the Network and Load Device Configurations
  • Part 2: Troubleshoot the Inter-VLAN Routing Configuration
  • Part 3: Verify VLAN Configuration, Port Assignment and Trunking
  • Part 4: Test Layer 3 Connectivity

Glosario: Si tienes dudas con algún término especial, puedes consultar este diccionario de redes informáticas.

¡Listo! Sigue visitando nuestro blog de curso de redes, dale Me Gusta a nuestra fanpage; y encontrarás más herramientas y conceptos que te convertirán en todo un profesional de redes.

Deja un Comentario

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.

¿Quieres aprobar la certificación Cisco CCNA?Sí, quiero!
+ +