Enrutamiento entre VLAN con Router-on-a-Stick

Router-on-a-Stick

Resumen

En este artículo aprenderás a configurar routing inter-VLAN con router-on-a-stick. ¡¡Empieza a aprender CCNA 200-301 gratis ahora mismo!!

¡Bienvenido!: Este tema forma parte del Módulo 4 del curso de Cisco CCNA 2, para un mejor seguimiento del curso puede ir a la sección CCNA 2 para guiarte del índice.

1. Escenario Router-on-a-Stick

En el tema anterior, se enumeraron tres formas diferentes de crear enrutamiento entre VLAN y se detalló el routing  inter-VLAN heredado. Este tema detalla cómo configurar router-on-a-stick. Puedes ver en la figura que el router no está en el centro de la topología, sino que parece estar en un palo/stick cerca del borde, de ahí el nombre.

En la figura, la interfaz R1 GigabitEthernet 0/0/1 está conectada al puerto S1 FastEthernet 0/5. El puerto S1 FastEthernet 0/1 está conectado al puerto S2 FastEthernet 0/1. Estos son enlaces troncales necesarios para reenviar tráfico dentro de las VLAN y entre ellas.

Escenario Router-on-a-Stick

Escenario Router-on-a-Stick

Para enrutar entre VLANs, la interfaz R1 GigabitEthernet 0/0/1 se divide lógicamente en tres subinterfaces, como se muestra en la tabla. La tabla también muestra las tres VLAN que se configurarán en los switches.

Subinterfaces de Router R1

SubinterfazVLANDirección IP
G0/0/1.1010192.168.10.1/24
G0/0/1.2020192.168.20.1/24
G0/0/1.3099192.168.99.1/24

Supón que R1, S1 y S2 tienen configuraciones básicas iniciales. Actualmente, PC1 y PC2 no pueden hacer ping entre sí porque están en redes separadas. Sólo S1 y S2 pueden ping uno al otro, pero son inalcanzables por PC1 o PC2 porque también están en diferentes redes.

Para permitir que los dispositivos se hagan ping entre sí, los switches deben configurarse con VLAN y enlace troncal, y el router debe configurarse para el enrutamiento inter-VLAN.

2. VLAN S1 y Configuración de Enlace Troncal

Completa los siguientes pasos para configurar S1 con VLAN y enlace troncal:

Paso 1. Crear y nombrar las VLANs.

Paso 2. Crear la interfaz de administración

Paso 3. Configurar puertos de acceso.

Paso 4. Configurar puertos de enlace troncal.

Configuración de Enlace Troncal

Configuración de Enlace Troncal

Haz clic en cada botón para obtener detalles del paso de configuración.


En primer lugar, las VLAN se crean y nombran. Las VLAN sólo se crean después de salir del modo de subconfiguración de VLAN.

S1(config)# vlan 10
S1(config-vlan)# name LAN10
S1(config-vlan)# exit
S1(config)# vlan 20
S1(config-vlan)# name LAN20
S1(config-vlan)# exit
S1(config)# vlan 99
S1(config-vlan)# name Management
S1(config-vlan)# exit
S1(config)#

A continuación, se crea la interfaz de administración en VLAN 99 junto con la puerta de enlace predeterminada de R1.

S1(config)# interface vlan 99
S1(config-if)# ip add 192.168.99.2 255.255.255.0
S1(config-if)# no shut
S1(config-if)# exit
S1(config)# ip default-gateway 192.168.99.1
S1(config)#

A continuación, el puerto Fa0/6 que conecta con el PC1 está configurado como un puerto de acceso en la VLAN 10. Supongamos que el PC1 ha sido configurado con la dirección IP correcta y la puerta de enlace por defecto.

S1(config)# interface fa0/6
S1(config-if)# switchport mode access
S1(config-if)# switchport access vlan 10
S1(config-if)# no shut
S1(config-if)# exit
S1(config)#

Por último, los puertos Fa0/1 que se conecta a S2 y Fa05 que se conecta a R1 se configuran como puertos de enlace troncal.

S1(config)# interface fa0/1
S1(config-if)# switchport mode trunk
S1(config-if)# no shut
S1(config-if)# exit
S1(config)# interface fa0/5
S1(config-if)# switchport mode trunk
S1(config-if)# no shut
S1(config-if)# end
*Mar 1 00:23:43.093: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up
*Mar 1 00:23:44.511: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/5, changed state to up

3. VLAN S2 y Configuración de Enlace Troncal

La configuración para S2 es similar a S1.

Configuración de Enlace Troncal

Configuración de Enlace Troncal

S2(config)# vlan 10
S2(config-vlan)# name LAN10
S2(config-vlan)# exit
S2(config)# vlan 20
S2(config-vlan)# name LAN20
S2(config-vlan)# exit
S2(config)# vlan 99
S2(config-vlan)# name Management
S2(config-vlan)# exit
S2(config)#
S2(config)# interface vlan 99
S2(config-if)# ip add 192.168.99.3 255.255.255.0
S2(config-if)# no shut
S2(config-if)# exit
S2(config)# ip default-gateway 192.168.99.1
S2(config)# interface fa0/18
S2(config-if)# switchport mode access
S2(config-if)# switchport access vlan 20
S2(config-if)# no shut
S2(config-if)# exit
S2(config)# interface fa0/1
S2(config-if)# switchport mode trunk
S2(config-if)# no shut
S2(config-if)# exit
S2(config-if)# end
*Mar 1 00:23:52.137: %LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/1, changed state to up

4. Configuración de Subinterfaces de R1

Para el método de router-on-a-stick, se requieren subinterfaces configuradas para cada VLAN que se pueda enrutar.

Se crea una subinterfaz mediante el comando en modo de configuración global interface interface_id subinterface_id. La sintaxis de la subinterfaz es la interfaz física seguida de un punto y un número de subinterfaz. Aunque no es obligatorio, es costumbre hacer coincidir el número de subinterfaz con el número de VLAN.

A continuación, cada subinterfaz se configura con los dos comandos siguientes:

  • encapsulation dot1q vlan_id [native] – Este comando configura la subinterfaz para responder al tráfico encapsulado 802.1Q del vlan-id especificado. La palabra clave native sólo se añade para configurar la VLAN nativa a algo distinto de la VLAN 1.
  • ip address ip-address subnet-mask – Este comando configura la dirección IPv4 de la subinterfaz. Esta dirección normalmente sirve como puerta de enlace predeterminada y para la VLAN identificada.

Repite el proceso para cada VLAN que se vaya a enrutar. Es necesario asignar una dirección IP a cada subinterfaz del router en una subred única para que se produzca el routing.

Cuando se hayan creado todas las subinterfaces, habilita la interfaz física mediante el comando de configuración de interfaz no shutdown. Si la interfaz física está deshabilitada, todas las subinterfaces están deshabilitadas.

En la siguiente configuración, las subinterfaces R1 G0/0/1 se configuran para las VLAN 10, 20 y 99.

Configuración de Enlace Troncal

Configuración de Enlace Troncal

R1(config)# interface G0/0/1.10
R1(config-subif)# description Default Gateway for VLAN 10
R1(config-subif)# encapsulation dot1Q 10
R1(config-subif)# ip add 192.168.10.1 255.255.255.0
R1(config-subif)# exit
R1(config)#
R1(config)# interface G0/0/1.20
R1(config-subif)# description Default Gateway for VLAN 20
R1(config-subif)# encapsulation dot1Q 20
R1(config-subif)# ip add 192.168.20.1 255.255.255.0
R1(config-subif)# exit
R1(config)#
R1(config)# interface G0/0/1.99
R1(config-subif)# description Default Gateway for VLAN 99
R1(config-subif)# encapsulation dot1Q 99
R1(config-subif)# ip add 192.168.99.1 255.255.255.0
R1(config-subif)# exit
R1(config)#
R1(config)# interface G0/0/1
R1(config-if)# description Trunk link to S1
R1(config-if)# no shut
R1(config-if)# end
R1#
*Sep 15 19:08:47.015: %LINK-3-UPDOWN: Interface GigabitEthernet0/0/1, changed state to down
*Sep 15 19:08:50.071: %LINK-3-UPDOWN: Interface GigabitEthernet0/0/1, changed state to up
*Sep 15 19:08:51.071: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0/1, changed state to up
R1#

5. Verificar la conectividad entre PC1 y PC2

La configuración del router-on-a-stick se completa después de configurar los enlaces troncales del switch y las subinterfaces del router. La configuración se puede verificar desde los hosts, el router y el switch.

Desde un host, comprueba la conectividad con un host de otra VLAN mediante el comando ping. Es una buena idea verificar primero la configuración IP del host actual mediante el comando ipconfig en Windows.

C:\Users\PC1> ipconfig
Windows IP Configuration
Ethernet adapter Ethernet0:
  Connection-specific DNS Suffix . :
  Link-local IPv6 Address          : fe80::5c43:ee7c:2959:da68%6
  IPv4 Address                     : 192.168.10.10
  Subnet Mask                      : 255.255.255.0
  Default Gateway                  : 192.168.10.1
C:\Users\PC1>

El resultado confirma la dirección IPv4 y el default gateway de PC1. A continuación, utiliza ping para verificar la conectividad con PC2 y S1, como se muestra en la salida. El resultado de ping confirma correctamente que el enrutamiento entre VLANs está funcionando.

C:\Users\PC1> ping 192.168.20.10
Pinging 192.168.20.10 with 32 bytes of data:
Reply from 192.168.20.10: bytes=32 time<1ms TTL=127 
Reply from 192.168.20.10: bytes=32 time<1ms TTL=127
Reply from 192.168.20.10: bytes=32 time<1ms TTL=127
Reply from 192.168.20.10: bytes=32 time<1ms TTL=127
Ping statistics for 192.168.20.10:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss).
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms
C:\Users\PC1> 
C:\Users\PC1> ping 192.168.99.2
Pinging 192.168.99.2 with 32 bytes of data:
Request timed out.
Request timed out.
Reply from 192.168.99.2: bytes=32 time=2ms TTL=254
Reply from 192.168.99.2: bytes=32 time=1ms TTL=254	|
Ping statistics for 192.168.99.2:
    Packets: Sent = 4, Received = 2, Lost = 2 (50% loss). 
Approximate round trip times in milli-seconds:
    Minimum = 1ms, Maximum = 2ms, Average = 1ms
C:\Users\PC1>

6.  Verificación de Router-on-a-Stick

Además de utilizar ping entre dispositivos, se pueden utilizar los siguientes comandos show para verificar y solucionar problemas de la configuración del router-on-a-stick.

  • show ip route
  • show ip interface brief
  • show interfaces
  • show interfaces trunk

Haz clic en cada botón para ver los resultados de usar cada uno de los comandos

Comprueba que las subinterfaces aparecen en la tabla de enrutamiento de R1 mediante el comando show ip route. Observa que hay tres rutas conectadas (C) y sus respectivas interfaces de salida para cada VLAN enrutable. El resultado confirma que las subredes, las VLAN y las subinterfaces correctas están activas.

R1# show ip route | begin Gateway
Gateway of last resort is not set
      192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.10.0/24 is directly connected, GigabitEthernet0/0/1.10
L        192.168.10.1/32 is directly connected, GigabitEthernet0/0/1.10
      192.168.20.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.20.0/24 is directly connected, GigabitEthernet0/0/1.20
L        192.168.20.1/32 is directly connected, GigabitEthernet0/0/1.20
      192.168.99.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.99.0/24 is directly connected, GigabitEthernet0/0/1.99
L        192.168.99.1/32 is directly connected, GigabitEthernet0/0/1.99
R1#

Otro comando útil del router es show ip interface brief, como se muestra en el resultado. El resultado confirma que las subinterfaces tienen configurada la dirección IPv4 correcta y que están operativas.

R1# show ip interface brief | include up
GigabitEthernet0/0/1   unassigned      YES unset  up                    up
Gi0/0/1.10             192.168.10.1    YES manual up                    up
Gi0/0/1.20             192.168.20.1    YES manual up                    up
Gi0/0/1.99             192.168.99.1    YES manual up                    up
R1#

Las subinterfaces se pueden verificar mediante el comando show interfaces subinterface-id, como se muestra.

R1# show interfaces g0/0/1.10
GigabitEthernet0/0/1.10 is up, line protocol is up
  Hardware is ISR4221-2x1GE, address is 10b3.d605.0301 (bia 10b3.d605.0301)
  Description: Default Gateway for VLAN 10
  Internet address is 192.168.10.1/24
  MTU 1500 bytes, BW 100000 Kbit/sec, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID  10.
  ARP type: ARPA, ARP Timeout 04:00:00
  Keepalive not supported
  Last clearing of "show interface" counters never
R1#

La configuración incorrecta también podría estar en el puerto troncal del switch. Por lo tanto, también es útil verificar los enlaces troncales activos en un switch de Capa 2 mediante el comando show interfaces trunk, como se muestra en el ejemplo. El resultado confirma que el enlace a R1 es enlace troncal para las VLAN requeridas.

Note: Aunque la VLAN 1 no se configuró explícitamente, se incluyó automáticamente porque el tráfico de control en los enlaces troncal siempre se reenvía en la VLAN 1.

S1# show interfaces trunk
Port        Mode             Encapsulation  Status        Native vlan
Fa0/1       on               802.1q         trunking      1
Fa0/5       on               802.1q         trunking      1
Port        Vlans allowed on trunk
Fa0/1       1-4094
Fa0/5       1-4094
Port        Vlans allowed and active in management domain
Fa0/1       1,10,20,99
Fa0/5       1,10,20,99
Port        Vlans in spanning tree forwarding state and not pruned
Fa0/1       1,10,20,99
Fa0/5       1,10,20,99
S1#

7. Packet Tracer – Configurar Router-on-a-Stick en Routing Inter-VLAN

En esta actividad, verificarás la conectividad antes de implementar routing inter-VLAN. Luego, configurarás las VLAN y el routing inter-VLAN. Por último, habilitarás el enlace troncal y verificarás la conectividad entre las VLAN.

8. Lab – Configurar Router-on-a-Stick en Routing Inter-VLAN

En este laboratorio, cumplirás los siguientes objetivos:

  • Parte 1: Armar la red y configurar los ajustes básicos de los dispositivos
  • Parte 2: Configurar los switches con las VLAN y los enlaces troncales
  • Parte 3: Configurar Routing Inter-VLAN basado en enlaces troncales

Glosario: Si tienes dudas con algún término especial, puedes consultar este diccionario de redes informáticas.

¡Listo! Sigue visitando nuestro blog de curso de redes, dale Me Gusta a nuestra fanpage; y encontrarás más herramientas y conceptos que te convertirán en todo un profesional de redes.

Sin respuestas a “Enrutamiento entre VLAN con Router-on-a-Stick”

Deja un Comentario

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.

¿Quieres aprobar la certificación Cisco CCNA?Sí, quiero!
+ +