Implementaciones de VLAN

En esta sección describe cómo configurar y administrar VLAN y enlaces troncales de VLAN, así como resolver problemas relacionados.

¡Bienvenido a CCNA desde Cero!: Este tema forma parte del Capítulo 6 del curso de Cisco CCNA 2, para un mejor seguimiento del curso puede ir a la sección CCNA 2 para guiarse del índice.

1. Rangos de VLAN en los switches Catalyst

Los distintos switches Cisco Catalyst admiten diversas cantidades de VLAN. La cantidad de VLAN que admiten es suficiente para satisfacer las necesidades de la mayoría de las organizaciones. Por ejemplo, los switches de las series Catalyst 2960 y 3560 admiten más de 4000 VLAN. Las VLAN de rango normal en estos switches se numeran del 1 al 1005, y las VLAN de rango extendido se numeran del 1006 al 4094. En la siguiente ilustración, se muestran las VLAN disponibles en un switch Catalyst 2960 que ejecuta IOS de Cisco, versión 15.x.

Switch# show vlan brief

VLAN Name                        Status    Ports
---- --------------------------- --------- ----------------------
1    default                     active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                           Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                           Fa0/9, Fa0/10, Fa0/11, Fa0/12
                                           Fa0/13, Fa0/14, Fa0/15, Fa0/16
                                           Fa0/17, Fa0/18, Fa0/19, Fa0/20
                                           Fa0/21, Fa0/22, Fa0/23, Fa0/24
                                           Gi0/1, Gi0/2
1002 fddi-default               act/unsup 
1003 token-ring-default         act/unsup 
1004 fddinet-default            act/unsup 
1005 trnet-default              act/unsup

1.1. VLAN de rango normal

  • Se utiliza en redes de pequeños y medianos negocios y empresas.
  • Se identifica mediante una ID de VLAN entre 1 y 1005.
  • Las ID de 1002 a 1005 se reservan para las VLAN de Token Ring e interfaz de datos distribuidos por fibra óptica (FDDI).
  • Las ID 1 y 1002 a 1005 se crean automáticamente y no se pueden eliminar.
  • Las configuraciones se almacenan en un archivo de base de datos de VLAN, denominado vlan.dat. El archivo vlan.dat se encuentra en la memoria flash del switch.
  • El protocolo de enlace troncal de VLAN (VTP), que permite administrar la configuración de VLAN entre los switches, solo puede descubrir y almacenar redes VLAN de rango normal.

1.2. VLAN de rango extendido

  • Posibilita a los proveedores de servicios que amplíen sus infraestructuras a una cantidad de clientes mayor. Algunas empresas globales podrían ser lo suficientemente grandes como para necesitar las ID de las VLAN de rango extendido.
  • Se identifican mediante una ID de VLAN entre 1006 y 4094.
  • Las configuraciones no se escriben en el archivo vlan.dat.
  • Admiten menos características de VLAN que las VLAN de rango normal.
  • Se guardan, de manera predeterminada, en el archivo de configuración en ejecución.
  • VTP no aprende las VLAN de rango extendido.

Nota: la cantidad máxima de VLAN disponibles en los switches Catalyst es 4096, ya que el campo ID de VLAN tiene 12 bits en el encabezado IEEE 802.1Q.

2. Creación de una VLAN

Al configurar redes VLAN de rango normal, los detalles de configuración se almacenan en la memoria flash del switch en un archivo denominado vlan.dat. La memoria flash es persistente y no requiere el comando copy running-config startup-config. Sin embargo, debido a que en los switches Cisco se suelen configurar otros detalles al mismo tiempo que se crean las VLAN, es aconsejable guardar los cambios a la configuración en ejecución en la configuración de inicio.


En la siguiente tabla, se muestra la sintaxis del comando de IOS de Cisco que se utiliza para agregar una VLAN a un switch y asignarle un nombre. Se recomienda asignarle un nombre a cada VLAN en la configuración de un switch.

Tabla de Comandos de Creación de una VLAN.
DescripciónComando
Ingresar al modo de configuración global.S1# configure terminal
Crear una VLAN con un número de ID válido.S1(config)#vlan id-vlan
Especificar un nombre único para identificar la VLAN.S1(config-vlan)#name nombre-vlan
Volver al modo EXEC privilegiado.S1(config-vlan)# end

2.1. Ejemplo de Configuración VLAN

En la Imagen 1, se muestra cómo se configura la VLAN para estudiantes (VLAN 20) en el switch S1. En el ejemplo de topología, la computadora del estudiante (PC2) todavía no se asoció a ninguna VLAN, pero tiene la dirección IP 172.17.20.22.

Ejemplo de configuración VLAN

Imagen 1: Ejemplo de configuración VLAN

S1# configure terminal
S1(config)# vlan 20
S1(config-vlan)# name student
S1(config-vlan)# end

A continuación, se utiliza el comando show vlan brief para mostrar el contenido del archivo vlan.dat.

S1# show vlan brief
VLAN Name                Status   Ports 
---- ------------------ --------- ----------------------------- 
1 default               active    Fa0/1, Fa0/2, Fa0/3, Fa0/4 
                                  Fa0/5, Fa0/6, Fa0/7, Fa0/8 
                                  Fa0/9, Fa0/10, Fa0/11, Fa0/12 
                                  Fa0/13, Fa0/14, Fa0/15, Fa0/16 
                                  Fa0/17, Fa0/18, Fa0/19, Fa0/20 
                                  Fa0/21, Fa0/22, Fa0/23, Fa0/24 
1 Gig0/1, Gig0/2 
20 Student active 
1002 fddi-default act/unsup 
1003 token-ring-default act/unsup 
1004 fddinet-default act/unsup 
1005 trnet-default act/unsup 
S1#

Además de introducir una única ID de VLAN, se puede introducir una serie de ID de VLAN separadas por comas o un rango de ID de VLAN separado por guiones con el comando vlan id-vlan. Por ejemplo, utilice el siguiente comando para crear las VLAN 100, 102, 105, 106 y 107:

S1(config)# vlan 100,102,105-107

3. Asignación de puertos a las redes VLAN

Después de crear una VLAN, el siguiente paso es asignar puertos a la VLAN. Un puerto de acceso puede pertenecer a sólo una VLAN por vez. Una excepción a esta regla es un puerto conectado a un teléfono IP, en cuyo caso hay dos VLAN asociadas con el puerto, una para voz y otra para datos.

En la siguiente 1, se muestra la sintaxis para definir un puerto como puerto de acceso y asignarlo a una VLAN. El comando switchport mode access es optativo, pero se aconseja como práctica recomendada de seguridad. Con este comando, la interfaz cambia al modo de acceso permanente.

Tabla de Asignación de puertos a las VLAN.
DescripciónComando
Ingresar al modo de configuración global.S1# configure terminal
Ingresar al modo de configuración de interfaz.S1(config)# interface id_interfaz
Establecer el puerto en modo de acceso.S1(config-if)# switchport mode access
Asignar el puerto a una VLAN.S1(config-if)# switchport access vlan id_vlan

Nota: utilice el comando interface range para configurar varias interfaces simultáneamente.

3.1. Ejemplo de asignación de puertos VLAN

En el ejemplo de la Imagen 2, la VLAN 20 se asigna al puerto F0/18 del switch S1; por lo tanto, la computadora de estudiantes (PC2) está en la VLAN 20. Las VLAN se configuran en el puerto de switch, no en el dispositivo. La PC2 se configura con una dirección IPv4 y una máscara de subred asociadas a la VLAN, que se configura en el puerto de switch, VLAN 20 en este ejemplo. Cuando se configura la VLAN 20 en otros switches, el administrador de red sabe que debe configurar las otras computadoras de estudiantes para que estén en la misma subred que la PC2 (172.17.20.0/24).

Ejemplo de asignación de puertos VLAN

Imagen 2: Ejemplo de asignación de puertos VLAN

Pasamos a asignar una VLAN y utilizar el comando show vlan brief para mostrar el contenido del archivo vlan.dat.

S1# configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
S1(config)# interface f0/18
S1(config-if)# switchport mode access
S1(config-if)# switchport access vlan 20
S1(config-if)# end
S1# show vlan brief

VLAN Name                 Status  Ports 
---- -------------------- ------- ---------------------------- 
1    default              active  Fa0/1, Fa0/2, Fa0/3, Fa0/4 
                                  Fa0/5, Fa0/6, Fa0/7, Fa0/8 
                                  Fa0/9, Fa0/10, Fa0/11, Fa0/12 
                                  Fa0/13, Fa0/14, Fa0/15, Fa0/16 
                                  Fa0/17, Fa0/19, Fa0/20, Fa0/21 
                                  Fa0/22, Fa0/23, Fa0/24, Gig0/1 
                                  Gig0/2 
20   Student              active  Fa0/18 
1002 fddi-default         active 
1003 token-ring-default   active 
1004 fddinet-default      active 
1005 trnet-default        active

El comando switchport access vlan fuerza la creación de una VLAN si es que aún no existe en el switch. Por ejemplo, la VLAN 30 no está presente en el resultado del comando show vlan brief del switch. Si se introduce el comando switchport access vlan 30 en cualquier interfaz sin configuración previa, el switch muestra lo siguiente:

% Access VLAN does not exist. Creating vlan 30

4. Cambio de pertenencia de puertos de una VLAN

Existen varias maneras de cambiar la pertenencia de puertos de una VLAN. En la siguiente tabla, se muestra la sintaxis para cambiar la pertenencia de un puerto de switch de la VLAN 1 con el comando no switchport access vlandel modo de configuración de interfaz.

Tabla de Eliminación de la asignación de VLAN.
DescripciónComando
Ingresar al modo de configuración global.S1# configure terminal
Eliminar la asignación de la VLAN del puerto.S1(config-if)# no switchport access vlan
Volver al modo EXEC privilegiado.S1(config-if)# end

4.1. Ejemplo de Configuración

S1(config)# int F0/18
S1(config-if)# no switchport access vlan
S1(config-if)# end
S1# show vlan brief

VLAN Name              Status  Ports
---- ----------------- ------- -----------------------------
1 default              active  Fa0/1, Fa0/2, Fa0/3, Fa0/4
                               Fa0/5, Fa0/6, Fa0/7, Fa0/8
                               Fa0/9, Fa0/10, Fa0/11, Fa0/12
                               Fa0/13, Fa0/14, Fa0/15, Fa0/16
                               Fa0/17, Fa0/18, Fa0/19, Fa0/20
                               Fa0/21, Fa0/22, Fa0/23, Fa0/24
                               Gi0/1, Gi0/2
20 student             active
1002 fddi-default      act/unsup
1003 token-ring-default act/unsup
1004 fddinet-default   act/unsup
1005 trnet-default     act/unsup

La interfaz F0/18 se asignó anteriormente a la VLAN 20. Se introduce el comando no switchport access vlan para la interfaz F0/18. Examine el resultado del comando show vlan brief que le sigue inmediatamente, como se muestra en el resultado anterior. El comando show vlan brief muestra el tipo de asignación y pertenencia de VLAN para todos los puertos de switch. El comando show vlan brief muestra una línea para cada VLAN. El resultado para cada VLAN incluye el nombre, el estado y los puertos de switch de la VLAN.

4.2. Ejemplo de Verificación

La VLAN 20 sigue activa, aunque no tenga puertos asignados. En el siguiente esquema, se muestra que el resultado del comando show interfaces f0/18 switchport verifica que la VLAN de acceso para la interfaz F0/18 se haya restablecido a la VLAN 1.

S1# sh interfaces F0/18 switchport
Name: F0/18
Switchport: Enabled
Administrative Mode: static access
Operational Mode: down
Administrative Trunking Encapsulation: dot1q
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
<Se omitió el resultado>

4.3. Asignación de un puerto a una VLAN

La pertenencia de VLAN de un puerto se puede cambiar fácilmente. No es necesario eliminar primero un puerto de una VLAN para cambiar su pertenencia de VLAN. Cuando se vuelve a asignar la pertenencia de VLAN de un puerto de acceso a otra VLAN existente, la nueva pertenencia de VLAN simplemente reemplaza la pertenencia de VLAN anterior. A continuación, el puerto F0/11 se asignó a la VLAN 20.

S1# config t 
S1(config)# interface F0/11
S1(config-if)# switchport mode access 
S1(config-if)# switchport access vlan 20 
S1(config-if)# end
S1# show vlan brief

VLAN Name                Status    Ports
---- ------------------- --------- ----------------------------------
1 default                active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                   Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                   Fa0/9, Fa0/10, Fa0/12, Fa0/13
                                   Fa0/14, Fa0/15, Fa0/16, Fa0/17
                                   Fa0/18, Fa0/19, Fa0/20, Fa0/21
                                   Fa0/22, Fa0/23, Fa0/24, Gi0/1
                                   Gi0/2
20 student               active    F0/11
1002 fddi-default        act/unsup 
1003 token-ring-default  act/unsup 
1004 fddinet-default     act/unsup 
1005 trnet-default       act/unsup

5. Eliminación de VLAN

En la ilustración, el comando del modo de configuración global no vlan id-vlan se utiliza para eliminar la VLAN 20 del switch. El switch S1 tenía una configuración mínima con todos los puertos en la VLAN 1 y una VLAN 20 sin usar en la base de datos de VLAN. El comando show vlan brief verifica que la VLAN 20 ya no esté presente en el archivo vlan.dat después de utilizar el comando no vlan 20.

S1# conf t
S1(config)# no vlan 20
S1(config)# end
S1# sh vlan brief

VLAN Name             Status    Ports
---- ---------------- --------- -------------------------------
1    default          active    Fa0/1, Fa0/2, Fa0/3, Fa0/4
                                Fa0/5, Fa0/6, Fa0/7, Fa0/8
                                Fa0/9, Fa0/10, Fa0/12, Fa0/13
                                Fa0/14, Fa0/15, Fa0/16, Fa0/17
                                Fa0/18, Fa0/19, Fa0/20, Fa0/21
                                Fa0/22, Fa0/23, Fa0/24, Gi0/1
                                Gi0/2
1002 fddi-default     act/unsup 
1003 token-ring-default act/unsup 
1004 fddinet-default  act/unsup 
1005 trnet-default    act/unsup

Precaución: Antes de borrar una VLAN, reasigne todos los puertos miembros a una VLAN distinta. Los puertos que no se trasladen a una VLAN activa no se podrán comunicar con otros hosts una vez que se elimine la VLAN y hasta que se asignen a una VLAN activa.

Alternativamente, se puede eliminar el archivo vlan.dat completo con el comando delete flash:vlan.dat del modo EXEC privilegiado. Se puede utilizar la versión abreviada del comando (delete vlan.dat) si no se trasladó el archivo vlan.dat de su ubicación predeterminada. Después de emitir este comando y de volver a cargar el switch, las VLAN configuradas anteriormente ya no están presentes. Esto vuelve al switch a la condición predeterminada de fábrica con respecto a la configuración de VLAN.

Nota: para los switches Catalyst, el comando erase startup-config debe acompañar al comando delete vlan.dat antes de la recarga para restaurar el switch a la condición predeterminada de fábrica.

6. Verificación de información de VLAN

Una vez que se configura una VLAN, se puede validar la configuración con los comandos show de IOS de Cisco.

Sintaxis del comando de CLI IOS de Cisco

show vlan [brief | id id-vlan | name nombre-vlan | summary]

En la siguiente tabla, se muestran las opciones de los comandos show vlan y show interfaces.

Tabla de comando show vlan
DescripciónComando
Mostrar una línea para cada VLAN con el nombre, estado y los puertos de la misma.brief
Mostrar información sobre una sola VLAN identificada por su número de ID.
Para la vlan-id, el intervalo es de 1 a 4094.
id id-vlan
Mostrar información sobre una sola VLAN identificada por su nombre. El nombre de la VLAN es una cadena ASCII de 1 a 32 caracteres.name nombre-vlan
Mostrar el resumen de información de la VLAN.summary

6.1. Uso del comando show vlan

En el ejemplo siguiente, el comando show vlan name student produce un resultado que no se interpreta fácilmente. El comando show vlan summary muestra el conteo de todas las VLAN configuradas. El resultado muestra siete VLAN.

S1# show vlan name student

VLAN Name Status Ports
---- -------------------------------- --------- -------------
20 student active Fa0/11, Fa0/18

VLAN Type SAID MTU Parent RingNo BridgeNo Stp BrdgMode Trans1 Trans2
---- ------------------- ------ ------ -------- ---- -------- ------ 
20   enet 100020 1500    -      -      -        -     0        0

Remote SPAN VLAN
----------------
Disabled

Primary Secondary Type Ports
------- --------- ----------------- -----------------------

S1# show vlan summary 
Number of existing VLANs : 7
Number of existing VTP VLANs : 7
Number of existing extended VLANS : 0

6.2. Uso del comando show interfaces vlan

El comando show interfaces vlan id-vlan muestra detalles que superan el alcance de este curso. La información importante aparece en la segunda línea del siguiente esquema, que indica que la VLAN 20 está activa.

S1# show interfaces vlan 20
Vlan20 is up, line protocol is down 
 Hardware is EtherSVI, address is 001c.57ec.0641 (bia 
 001c.57ec.0641)
 MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec, 
 reliability 255/255, txload 1/255, rxload 1/255
 Encapsulation ARPA, loopback not set
 ARP type: ARPA, ARP Timeout 04:00:00
 Last input never, output never, output hang never
 Last clearing of "show interface" counters never
 Input queue: 0/75/0/0 (size/max/drops/flushes); Total output 
 drops: 0
 Queueing strategy: fifo
 Output queue: 0/40 (size/max)
 5 minute input rate 0 bits/sec, 0 packets/sec
 5 minute output rate 0 bits/sec, 0 packets/sec
 0 packets input, 0 bytes, 0 no buffer
 Received 0 broadcasts (0 IP multicast)
 0 runts, 0 giants, 0 throttles
 0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
 0 packets output, 0 bytes, 0 underruns
 0 output errors, 0 interface resets
 0 output buffer failures, 0 output buffers swapped out

7. Configuración de Enlaces Troncales de VLAN

Un enlace troncal de VLAN es un enlace de capa 2 del modelo OSI entre dos switches que transporta el tráfico para todas las VLAN (a menos que se restrinja la lista de VLAN permitidas de manera manual o dinámica). Para habilitar los enlaces troncales, configure los puertos en cualquier extremo del enlace físico con conjuntos de comandos paralelos.

Para configurar un puerto de switch en un extremo de un enlace troncal, utilice el comando switchport mode trunk. Con este comando, la interfaz cambia al modo de enlace troncal permanente. El puerto establece una negociación de protocolo de enlace troncal dinámico (DTP) para convertir el enlace en un enlace troncal, incluso si la interfaz conectada a este no acepta el cambio. En este curso, el comando switchport mode trunk es el único método que se implementa para la configuración de enlaces troncales.

En la siguiente tabla, se muestra la sintaxis del comando de IOS de Cisco para especificar una VLAN nativa (distinta de la VLAN 1). En el ejemplo, se configura la VLAN 99 como VLAN nativa con el comando switchport trunk native vlan 99.

Tabla de Configuración de enlaces troncales
DescripciónComando
Ingresar al modo de configuración global.S1# configure terminal
Ingresar el modo de configuración de interfaz.S1(config)# interface id_interfaz
Hacer que el enlace sea un enlace troncal.S1(config-if)# switchport mode trunk
Especificar una VLAN nativa para las tramas sin etiquetas.S1(config-if)# switchport trunk native vlan id_vlan
Especificar la lista de VLAN que se permitirán en el enlace troncal.S1(config-if)# switchport trunk allowed vlan lista-vlan
Volver al modo EXEC privilegiado.S1(config-if)# end

Utilice el comando switchport trunk allowed vlan lista-vlan de Cisco IOS para especificar la lista de VLAN que se permitirán en el enlace troncal.

7.1. Topología de Ejemplo

En la Imagen 3, las VLAN 10, 20 y 30 admiten las computadoras de Cuerpo docente, Estudiante e Invitado (PC1, PC2 y PC3). El puerto F0/1 del switch S1 se configuró como puerto de enlace troncal y reenvía el tráfico para las VLAN 10, 20 y 30. La VLAN 99 se configuró como VLAN nativa.

Topología de Ejemplo Enlaces Troncales

Imagen 3: Topología de Ejemplo Enlaces Troncales

VLAN 10 - Faculty/Staff - 172.17.10.0/24 
VLAN 20 - Students - 172.17.20.0/24 
VLAN 30 - Guest - 172.17.30.0/24 
VLAN 99 - Native - 172.17.99.0/24

A continuación, se muestra la configuración del puerto F0/1 del switch S1 como puerto de enlace troncal. La VLAN nativa se cambia a VLAN 99 y la lista de VLAN permitidas se restringe a 10, 20, 30 y 99.

S1(config)# interface FastEthernet0/1
S1(config-if)# switchport mode trunk
S1(config-if)# switchport trunk native vlan 99
S1(config-if)# switchport trunk allowed vlan 10,20,30,99
S1(config-if)# end

Nota: esta configuración supone el uso de los switches Cisco Catalyst 2960 que utilizan de manera automática la encapsulación 802.1Q en los enlaces troncales. Es posible que otros switches requieran la configuración manual de la encapsulación. Siempre configure ambos extremos de un enlace troncal con la misma VLAN nativa. Si la configuración de enlace troncal 802.1Q no es la misma en ambos extremos, el software IOS de Cisco registra errores.

7.2. Restablecer el enlace troncal al estado predeterminado

En la siguiente tabla, se muestran los comandos para eliminar las VLAN permitidas y restablecer la VLAN nativa del enlace troncal. Cuando se restablece al estado predeterminado, el enlace troncal permite todas las VLAN y utiliza la VLAN 1 como VLAN nativa.

Tabla de Restablecimiento de valores configurados en enlaces troncales
DescripciónComando
Ingresar al modo de configuración global.S1# configure terminal
Ingresar el modo de configuración de interfaz.S1(config)# interface id_interfaz
Establecer el enlace troncal para permitir todas las VLAN.S1(config-if)# no switchport trunk allowed vlan
Restablecer la VLAN nativa al valor predeterminado.S1(config-if)# no switchport trunk native vlan
Volver al modo EXEC privilegiado.S1(config-if)# end

Ahora se muestran los comandos utilizados para restablecer todas las características de enlace troncal de una interfaz troncal a la configuración predeterminada. El comando show interfaces f0/1 switchport revela que el enlace troncal se volvió a configurar en un estado predeterminado.

S1(config)# interface f0/1 
S1(config-if)# no switchport trunk allowed vlan 
S1(config-if)# no switchport trunk native vlan 
S1(config-if)# end 
S1# show interfaces f0/1 switchport 
Name: Fa0/1 
Switchport: Enabled 
Administrative Mode: trunk 
Operational Mode: trunk 
Administrative Trunking Encapsulation: dot1q 
Operational Trunking Encapsulation: dot1q 
Negotiation of Trunking: On 
Access Mode VLAN: 1 (default) 
Trunking Native Mode VLAN: 1 (default) 
Administrative Native VLAN tagging: enabled 
<Se omitió el resultado> 
Administrative private-vlan trunk mappings: none 
Operational private-vlan: none 
Trunking VLANs Enabled: ALL 
Pruning VLANs Enabled: 2-1001

Por último, el resultado de ejemplo muestra los comandos utilizados para eliminar la característica de enlace troncal del puerto F0/1 del switch S1. El comando show interfaces f0/1 switchport revela que la interfaz F0/1 ahora está en modo de acceso estático.

S1(config)# interface f0/1 
S1(config-if)# switchport mode access 
S1(config-if)# end 
S1# show interfaces f0/1 switchport 
Name: Fa0/1 Switchport: Enabled 
Administrative Mode: static access 
Operational Mode: static access 
Administrative Trunking Encapsulation: dot1q 
Operational Trunking Encapsulation: native 
Negotiation of Trunking: Off 
Access Mode VLAN: 1 (default) 
Trunking Native Mode VLAN: 1 (default) 
Administrative Native VLAN tagging: enabled

7.3. Verificación de la configuración de enlace troncal

El resultado siguiente muestra la configuración del puerto F0/1 del switch S1. La configuración se verifica con el comando show interfaces id-interfaz switchport.

S1(config)# interface f0/1
S1(config-if)# switchport mode trunk
S1(config-if)# switchport trunk native vlan 99
S1(config-if)# end
S1# show interfaces f0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: On
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 99 (VLAN0099)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none 
Administrative private-vlan mapping: none 
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk associations: none
Administrative private-vlan trunk mappings: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001

En el área superior resaltada, se muestra que el modo administrativo del puerto F0/1 se estableció en trunk. El puerto está en modo de enlace troncal. En la siguiente área resaltada, se verifica que la VLAN nativa es la VLAN 99. Más abajo en el resultado, en el área inferior resaltada, se muestra que todas las VLAN están habilitadas en el enlace troncal.

8. Resolución de Problemas de VLAN

8.1. Problemas de direccionamiento IP de VLAN

Cada VLAN debe corresponder a una subred IP única. Si dos dispositivos en la misma VLAN tienen direcciones de subred diferentes, no se pueden comunicar. Este es un problema frecuente y se resuelve fácilmente mediante la identificación de la configuración incorrecta y el cambio de la dirección de la subred por una dirección correcta.

En la Imagen 4, la PC1 no se puede conectar al servidor Web/TFTP que se muestra.

Problema de IP dentro de la VLAN

Imagen 4: Problema de IP dentro de la VLAN

La verificación de las opciones de configuración IPv4 de la PC1, que se muestra en el siguiente resultado, revela el error más frecuente en la configuración de redes VLAN: una dirección IPv4 mal configurada. La PC1 se configuró con la dirección IPv4 172.172.10.21, pero debería haberse configurado con la dirección 172.17.10.21.

PC1> ipconfig

IP Address...................: 172.172.10.21
Subnet Mask..................: 255.255.0.0
Default Gateway..............: 0.0.0.0

En la Imagen 5, el cuadro de diálogo de la configuración de Fast Ethernet de la PC1 muestra la dirección IPv4 actualizada, 172.17.10.21. El resultado que se muestra en la parte inferior indica que la PC1 recuperó la conectividad al servidor Web/TFTP que se encuentra en la dirección IPv4 172.17.10.30.

Solución cambiar la dirección IP de la computadora

Imagen 5: Solución –
cambiar la dirección IP de la computadora

PC1> ping 172.17.10.30
Pinging 172.17.10.30 with 32 bytes of data:
Reply from 172.17.10.30: Bytes=32 Time=147ms TTL=128

8.2. VLAN faltantes

Si todavía no hay conexión entre los dispositivos en una VLAN pero se descartaron los problemas de direccionamiento IP, consulte el diagrama de flujo de la Imagen 9 para llevar a cabo la resolución de problemas:

Solución VLAN faltantes

Imagen 6: Solución VLAN faltantes

  • Paso 1: Utilice el comando show vlan para verificar si el puerto pertenece a la VLAN esperada. Si el puerto se asignó a una VLAN incorrecta, utilice el comando switchport access vlan para corregir la pertenencia de VLAN. Utilice el comando show mac address-table para revisar qué direcciones se obtuvieron en un puerto determinado del switch y a qué VLAN se asignó ese puerto, como se muestra a continuación:
S1# show mac address-table interface FastEthernet 0/1
 Mac Address Table
-------------------------------------------

Vlan Mac Address Type Ports
---- ----------- -------- ----- 
10 000c.296a.a21c DYNAMIC Fa0/1
10 000f.34f9.9181 DYNAMIC Fa0/1
Total Mac Addresses for this criterion: 2
  • Paso 2: Si se elimina la VLAN a la que se asignó el puerto, el puerto pasa a estar inactivo. Los puertos de una VLAN eliminada no se indicarán en el resultado del comando show vlan. Utilice el comando show interfaces switchport para verificar que la VLAN inactiva está asignada al puerto, como se muestra:
S1# show interfaces FastEthernet 0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative Mode: static access
Operational Mode: static access
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: native
Negotiation of Trunking: Off
Access Mode VLAN: 10 (Inactive)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none

En el resultado anterior, se muestran las direcciones MAC que se obtuvieron en la interfaz F0/1. Se puede observar que en la interfaz F0/1 de la VLAN 10 se obtuvo la dirección MAC 000c.296a.a21c. Si este no es el número de VLAN previsto, cambie la pertenencia de puerto de VLAN con el comando switchport access vlan.

Cada puerto de un switch pertenece a una VLAN. Si se elimina la VLAN a la que pertenece el puerto, este pasa a estar inactivo. Ninguno de los puertos que pertenecen a la VLAN que se eliminó puede comunicarse con el resto de la red. Utilice el comando show interface f0/1 switchport para verificar si el puerto está inactivo. Si el puerto está inactivo, no funciona hasta que se cree la VLAN con el comando de configuración global vlan id-vlan o que se elimine la VLAN del puerto con el comando no switchport access vlan id-vlan.

9. Resolución de problemas de enlaces troncales

Una de las tareas frecuentes de los administradores de red es resolver problemas de formación de enlaces troncales o de puertos que se comportan incorrectamente como puertos de enlace troncal. En ocasiones, un puerto de switch se puede comportar como puerto de enlace troncal, incluso si no se configuró como tal. Por ejemplo, un puerto de acceso puede aceptar tramas de redes VLAN distintas de la VLAN a la cual se asignó. Esto se conoce como “filtración de VLAN”.

En la Imagen 7, se muestra un diagrama de flujo de las pautas generales de resolución de problemas de enlaces troncales.

Resolución de problemas de enlaces troncales

Imagen 7: Resolución de problemas de enlaces troncales

9.1. Comandos de resolución de problemas

Para resolver problemas de enlaces troncales que no se forman o de filtración de VLAN, proceda de la siguiente manera:

  • Paso 1: utilice el comando show interfaces trunk para verificar si hay coincidencia entre la VLAN nativa local y los pares. Si la VLAN nativa no coincide en ambos extremos, hay una filtración de VLAN.
  • Paso 2: utilice el comando show interfaces trunk para verificar si se estableció un enlace troncal entre los switches. Configure estáticamente los enlaces troncales siempre que sea posible. Los puertos de los switches Cisco Catalyst utilizan DTP de manera predeterminada e intentan negociar un enlace troncal.

Para mostrar el estado del enlace troncal y de la VLAN nativa utilizada en él, y verificar el establecimiento de dicho enlace, utilice el comando show interfaces trunk. A continuación, se muestra que la VLAN nativa en un extremo del enlace troncal se cambió a la VLAN 2. Si un extremo del enlace troncal se configura como VLAN 99 nativa y el otro extremo como VLAN 2 nativa, las tramas que se envían desde la VLAN 99 en un extremo se reciben en la VLAN 2 en el otro extremo. La VLAN 99 se filtra en el segmento VLAN 2.

SW1# show interfaces f0/1 trunk
 
Port  Mode Encapsulation Status   Native vlan
Fa0/1 auto 802.1q        trunking  2

CDP muestra un aviso de incompatibilidad de VLAN nativa en un enlace troncal con este mensaje:

*Mar 1 06:45:26.232: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on 
FastEthernet0/1 (2), with S2 FastEthernet0/1 (99).

Si existe una incompatibilidad de VLAN nativa, se producen problemas de conectividad en la red. El tráfico de datos para las VLAN distintas de las dos VLAN nativas configuradas se propaga correctamente a través del enlace troncal, pero los datos relacionados con cualquiera de las VLAN nativas no se propagan correctamente a través del enlace troncal.

Como se mostró anteriormente, los problemas de incompatibilidad de la VLAN nativa no impiden que se forme el enlace troncal. Para resolver una incompatibilidad de VLAN nativa, configure la VLAN nativa para que sea la misma VLAN en ambos lados del enlace.

9.2. Problemas comunes con enlaces troncales

En general, los problemas de enlaces troncales se deben a una configuración incorrecta. Al configurar las VLAN y los enlaces troncales en una infraestructura conmutada, los errores de configuración más frecuentes son los siguientes:

  • Incompatibilidad de VLAN nativa: los puertos de enlace troncal se configuraron con VLAN nativas diferentes. Este error de configuración genera notificaciones de consola y puede causar problemas de routing entre VLAN, entre otros inconvenientes. Esto representa un riesgo de seguridad.

Por ejemplo, un puerto se define como VLAN 99 y el otro como VLAN 100.

  • Incompatibilidades de modo de enlace troncal: un puerto de enlace troncal está configurado en un modo que no es compatible para enlaces troncales en el puerto par correspondiente. Estos errores de configuración hacen que el vínculo de enlace troncal deje de funcionar. Asegúrese de que se configuren ambos lados del enlace troncal con el comando switchport mode trunk. Los demás comandos de configuración de enlace troncal superan el alcance de este curso.

Por ejemplo, se configura un lado del enlace troncal como puerto de acceso.

  • VLAN permitidas en enlaces troncales: no se actualizó la lista de VLAN permitidas en un enlace troncal con los requisitos de enlace troncal de VLAN actuales. En este caso, se envía tráfico inesperado o ningún tráfico al enlace troncal.

La lista de las VLAN permitidas no admite los requisitos de enlace troncal de VLAN actuales.

Si se detecta un problema con un enlace troncal y se desconoce la causa, comience la resolución de problemas con un examen de los enlaces troncales para determinar si hay una incompatibilidad de VLAN nativa. Si esa no es la causa, verifique si hay una incompatibilidad de modo de enlace troncal y, por último, revise la lista de VLAN permitidas en el enlace troncal. En las dos páginas siguientes, se analiza cómo solucionar problemas frecuentes de los enlaces troncales.

9.3. Modo de puerto incorrecto

Por lo general, los enlaces troncales se configuran estáticamente con el comando switchport mode trunk. Los puertos de enlace troncal de los switches Cisco Catalyst utilizan DTP para negociar el estado del enlace. Cuando un puerto en un enlace troncal se configura con un modo de enlace troncal que no es compatible con el puerto de enlace troncal vecino, no se puede formar un enlace troncal entre los dos switches.

En la situación que se describe en la Imagen 8, la PC4 no puede conectarse al servidor web interno. La topología indica una configuración válida. ¿Por qué hay un problema?

Modo puerto incorrecto Topología de la situación

Imagen 8: Topología de la situación

Verifique el estado de los puertos de enlace troncal del switch S1 con el comando show interfaces trunk.

S1# show interfaces trunk
Port Mode Encapsulation Status Native vlan
Fa0/1 on 802.1q trunking 99
Port Vlans allowed on trunk
Fa0/1 10,99
Port Vlans allowed and active in management domain
Fa0/1 10,99
Port Vlans in spanning tree forwarding state and not pruned
Fa0/1 10,99
S1# show interface f0/3 switchport
Name: Fa0/3
Switchport: Enabled
Administrative Mode: trunk
S3# show interfaces trunk

S3#
S3# show interface f0/3 switchport
Name: Fa0/3
Switchport: Enabled
Administrative Mode: static access</span>
…

El resultado indica que la interfaz Fa0/3 del switch S1 actualmente no es un enlace troncal. Si se examina la interfaz F0/3, se descubre que el puerto del switch está configurado estáticamente en modo enlace troncal. Si se examinan los enlaces troncales del switch S3, se descubre que no hay puertos de enlace troncal activos. Si se sigue examinando, se descubre que la interfaz Fa0/3 está en modo de acceso estático. Esto sucede porque el puerto se configuró con el comando switchport mode access. Esto explica la inactividad del enlace troncal.

S1# config terminal
S1(config)# interface f0/3
S1(config-if)# switchport mode trunk
S1(config-if)# end
S1# <b>show interfaces f0/3 switchport
Name: Fa0/3
Switchport: Enabled
Administrative Mode: trunk
…
S1#

Modos de enlace troncal corregidos

Para resolver el problema, vuelva a configurar el modo de enlace troncal de los puertos F0/3 del switch S3:

S3# config terminal
S3(config)# interface f0/3
S3(config-if)# switchport mode trunk
S3(config-if)# end
S3# show interfaces f0/3 switchport
Name: Fa0/3
Switchport: Enabled
Administrative Mode: trunk
…
S3# show interfaces trunk
Port Mode Encapsulation Status Native vlan
Fa0/3 on 802.1q trunking 99
Port Vlans allowed on trunk
Fa0/3 10,99
Port Vlans allowed and active in management domain
Fa0/3 10,99
Port Vlans in spanning tree forwarding state and not pruned
Fa0/3 10,99

Después del cambio de configuración, el resultado del comando show interfaces indica que el puerto del switch S3 ahora está en modo de enlace troncal. El resultado de la PC4 indica que esta recuperó la conectividad al servidor Web/TFTP que se encuentra en la dirección IPv4 172.17.10.30.

PC4> ping 172.17.10.30
Pinging 172.17.10.30 with 32 bytes of data:
Reply from 172.17.10.30: bytes=32 time=147ms TTL=128
…

9.4. Lista de VLAN incorrecta

Para que el tráfico de una VLAN se transmita a través de un enlace troncal, debe estar permitido en dicho enlace. Para hacerlo, utilice el comando switchport trunk allowed vlan id-vlan .

En la Imagen 9, se agregaron la VLAN 20 (Estudiantes) y la PC5 a la red. La documentación se ha actualizado para mostrar que las VLAN permitidas en el enlace troncal son las 10, 20 y 99. En esta situación, la PC5 no puede conectarse al servidor de correo electrónico para estudiantes.

Lista de VLAN incorrecta

Imagen 9: Topología de ejemplo

Verificamos los puertos de enlace troncal del switch S1 con el comando show interfaces trunk

S3# show interfaces trunk
Port Mode Encapsulation Status Native vlan
Fa0/3 on 802.1q trunking 99
Port Vlans allowed on trunk
Fa0/3 10,20,99
Port Vlans allowed and active in management domain
Fa0/3 10,20,99
Port Vlans in spanning tree forwarding state and not 
pruned
Fa0/3 10,20,99
S1# show interfaces trunk
Port Mode Encapsulation Status Native vlan
Fa0/1 on 802.1q trunking 99
Fa0/3 on 802.1q trunking 99
Port Vlans allowed on trunk
Fa0/1 10,99
Fa0/3 10,99
…

El comando show interfaces trunk es una excelente herramienta para revelar problemas frecuentes de enlace troncal. El comando revela que la interfaz F0/3 del switch S3 se configuró correctamente para permitir las VLAN 10, 20 y 99. Si se examina la interfaz F0/3 del switch S1, se descubre que las interfaces F0/1 y F0/3 permiten solo las VLAN 10 y 99. Alguien actualizó el registro pero olvidó volver a configurar los puertos del switch S1.

Lista de VLAN corregida

Vuelva a configurar los puertos F0/1 y F0/3 del switch S1 con el comando switchport trunk allowed vlan 10,20,99, como se muestra en la figura 3. El resultado muestra que ya se agregaron las VLAN 10, 20 y 99 a los puertos F0/1 y F0/3 del switch S1.

S1# config terminal 
S1(config)# interface f0/1 
S1(config-if)# switchport trunk allowed vlan 10,20,99 
S1(config-if)# interface f0/3 
S1(config-if)# switchport trunk allowed vlan 10,20,99 
S1# show interfaces trunk
Port Mode Encapsulation Status Native vlan
Fa0/1 on 802.1q trunking 99
Fa0/3 on 802.1q trunking 99
Port Vlans allowed on trunk
Fa0/1 10,20,99
Fa0/3 10,20,99
…

Finalmente, la PC5 recuperó la conectividad al servidor de correo electrónico para estudiantes que se encuentra en la dirección IPv4 172.17.20.10.

PC5> ping 172.17.20.10
Pinging 172.17.20.10 with 32 bytes of data:
Reply from 172.17.20.10: bytes=32 time=147ms TTL=128
…

Deja un Comentario

CLOSE
CLOSE