Enrutamiento entre VLAN con Switches Capa 3

Enrutamiento entre VLAN con Switches Capa 3
5

Resumen

Aprenderás a configurar el enrutamiento inter-VLAN usando switching de la Capa 3. ¡¡Empieza a aprender CCNA 200-301 gratis ahora mismo!!

¡Bienvenido!: Este tema forma parte del Módulo 4 del curso de Cisco CCNA 2, para un mejor seguimiento del curso puede ir a la sección CCNA 2 para guiarte del índice.

1. Routing Inter-VLAN en Switch de Capa 3

Las redes empresariales modernas rara vez usan router-on-a-stick porque no se escalan fácilmente para cumplir los requisitos. En estas redes muy grandes, los administradores de red utilizan switches de capa 3 para configurar el enrutamiento inter-VLAN.

El routing inter-VLAN mediante el método router-on-a-stick es fácil de implementar para una organización pequeña y mediana. Sin embargo, una gran empresa requiere un método más rápido y mucho más escalable para proporcionar routing inter-VLAN.

Las LAN de campus empresariales utilizan switches de capa 3 para proporcionar routing inter-VLAN. Los switches de capa 3 utilizan switching basado en hardware para lograr velocidades de procesamiento de paquetes más altas que los routers. Los switches de capa 3 también se implementan comúnmente en gabinetes de cableado de la capa de distribución de las empresas.

Las capacidades de un switch de capa 3 incluyen lo siguiente:

  • Ruta de una VLAN a otra mediante múltiples interfaces virtuales de switch (SVIs).
  • Convierte un puerto de switch de capa 2 en una interfaz de capa 3 (es decir, un puerto enrutado). Un puerto enrutado es similar a una interfaz física en un router Cisco IOS.

Para proporcionar enrutamiento entre VLAN, los switches de capa 3 utilizan SVIs. Los SVIs se configuran utilizando el mismo comando interface vlan vlan-id utilizado para crear el SVI de administración en un switch de capa 2. Se debe crear un SVI de Capa 3 para cada una de las VLAN enrutables.

2. Escenario Switch de Capa 3

En la figura, el switch de capa 3, D1, está conectado a dos hosts en diferentes VLAN. PC1 está en VLAN 10 y PC2 está en VLAN 20, como se muestra. El switch de capa 3 proporcionará servicios routing inter-VLAN a los dos hosts.

Escenario Switch de Capa 3

Escenario Switch de Capa 3

La tabla muestra las direcciones IP de cada VLAN.

Direcciones IP VLAN de D1

VLAN InterfaceIP Address
10192.168.10.1/24
20192.168.20.1/24

3. Configuración de Switch de Capa 3

Completa los siguientes pasos para configurar S1 con VLAN y enlace troncal:


  • Paso 1. Crear las VLAN.
  • Paso 2. Crear las interfaces VLAN SVI.
  • Paso 3. Configurar puertos de acceso.
  • Paso 4. Habilitar IP routing.

Haz clic en cada botón para obtener detalles del paso de configuración.

Primero, crea las dos VLAN como se muestra en el ejemplo

D1(config)# vlan 10
D1(config-vlan)# name LAN10
D1(config-vlan)# vlan 20
D1(config-vlan)# name LAN20
D1(config-vlan)# exit
D1(config)#

Configurar el SVI para VLANs 10 y 2. Las direcciones IP configuradas servirán como default gateways para los hosts de las VLAN respectivas. Observa que los mensajes informativos que muestran el protocolo de línea (line protocol) en ambos SVIs cambiaron a funcionales (up).

D1(config)# interface vlan 10
D1(config-if)# description Default Gateway SVI for 192.168.10.0/24
D1(config-if)# ip add 192.168.10.1 255.255.255.0
D1(config-if)# no shut
D1(config-if)# exit
D1(config)#
D1(config)# int vlan 20
D1(config-if)# description Default Gateway SVI for 192.168.20.0/24
D1(config-if)# ip add 192.168.20.1 255.255.255.0
D1(config-if)# no shut
D1(config-if)# exit
D1(config)#
*Sep 17 13:52:16.053: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan10, changed state to up
*Sep 17 13:52:16.160: %LINEPROTO-5-UPDOWN: Line protocol on Interface Vlan20, changed state to up

A continuación, configura los puertos de acceso que se conectan a los hosts y asígnalos a sus respectivas VLAN.

D1(config)# interface GigabitEthernet1/0/6
D1(config-if)# description Access port to PC1
D1(config-if)# switchport mode access
D1(config-if)# switchport access vlan 10
D1(config-if)# exit
D1(config)#
D1(config)# interface GigabitEthernet1/0/18
D1(config-if)# description Access port to PC2
D1(config-if)# switchport mode access
D1(config-if)# switchport access vlan 20
D1(config-if)# exit

Por último, habilite el enrutamiento IPv4 con el comando de configuración global ip routing para permitir el intercambio de tráfico entre las VLAN 10 y 20. Este comando debe configurarse para habilitar el inter-VAN routing en un switch de capa 3 para IPv4.

D1(config)# ip routing
D1(config)#

4. Verificación Routing Inter-VLAN de Switch de Capa 3

El Routing Inter-VLAN mediante un switch de capa 3 es más sencillo de configurar que el método router-on-a-stick. Una vez completada la configuración, la configuración se puede verificar probando la conectividad entre los hosts.

Desde un host, comprueba la conectividad con un host de otra VLAN mediante el comando ping. Es una buena idea verificar primero la configuración IP del host actual mediante el comando ipconfig en un host Windows. El resultado confirma la dirección IPv4 y la puerta de enlace predeterminada de PC1.

C:\Users\PC1> ipconfig
Windows IP Configuration
Ethernet adapter Ethernet0:
  Connection-specific DNS Suffix . :
  Link-local IPv6 Address          : fe80::5c43:ee7c:2959:da68%6
  IPv4 Address                     : 192.168.10.10
  Subnet Mask                      : 255.255.255.0
  Default Gateway                  : 192.168.10.1
C:\Users\PC1>

A continuación, verifica la conectividad con PC2 mediante el comando ping en Windows, como se muestra en el ejemplo. El resultado de ping confirma correctamente que el enrutamiento entre VLANs está funcionando.

C:\Users\PC1> ping 192.168.20.10
Pinging 192.168.20.10 with 32 bytes of data:
Reply from 192.168.20.10: bytes=32 time<1ms TTL=127
Reply from 192.168.20.10: bytes=32 time<1ms TTL=127
Reply from 192.168.20.10: bytes=32 time<1ms TTL=127
Reply from 192.168.20.10: bytes=32 time<1ms TTL=127
Ping statistics for 192.168.20.10:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 0ms, Maximum = 0ms, Average = 0ms
C:\Users\PC1>

5. Enrutamiento en un Switch de Capa 3

Si se quiere que otros dispositivos de Capa 3 puedan acceder a las VLAN, deben anunciarse mediante enrutamiento estático o dinámico. Para habilitar el enrutamiento en un switch de capa 3, se debe configurar un puerto enrutado.

Un puerto enrutado se crea en un switch de Capa 3 deshabilitando la función switchport de un switch de Capa 2 que está conectado a otro dispositivo de Capa 3. Específicamente, al configurar el comando de configuración interfaz no switchport en un puerto de Capa 2, se convierte en una interfaz de Capa 3. A continuación, la interfaz se puede configurar con una configuración IPv4 para conectarse a un router u otro switch de capa 3.

6. Escenario Enrutamiento en Switch de Capa 3

En la figura, el switch de capa 3 D1 previamente configurado ahora está conectado a R1. R1 y D1 están ambos en un dominio de protocolo de enrutamiento Open Shortest Path First (OSPF). Supongamos que Inter-VLAN se ha implementado correctamente en D1. La interfaz G0/0/1 de R1 también ha sido configurada y habilitada. Además, R1 está utilizando OSPF para anunciar sus dos redes, 10.10.10.0/24 y 10.20.20.0/24.

Nota: OSPF se cubre en otro curso. En este módulo, se te darán comandos de configuración OSPF en todas las actividades y evaluaciones. No es necesario que comprendas la configuración para habilitar el enrutamiento OSPF en el switch de capa 3.

Enrutamiento en Switch de Capa 3

Enrutamiento en Switch de Capa 3

7. Configuración de Enrutamiento en Switch de Capa 3

Completa los siguientes pasos para configurar D1 para enrutar con R1:

  • Paso 1. Configurar el puerto enrutado.
  • Paso 2. Activar el routing.
  • Paso 3. Configurar el enrutamiento
  • Paso 4. Verificar enrutamiento.
  • Paso 5. Verificar la conectividad

Haz clic en cada botón para obtener detalles del paso de configuración.

Configura G1/0/1 para que sea un puerto enrutado, asígnale una dirección IPv4 y habilítalo.

D1(config)# interface GigabitEthernet1/0/1
D1(config-if)# description routed Port Link to R1
D1(config-if)# no switchport
D1(config-if)# ip address 10.10.10.2 255.255.255.0
D1(config-if)# no shut
D1(config-if)# exit
D1(config)#

Asegúrate de que el enrutamiento IPv4 esté habilitado con el comando de configuración global ip routing.

D1(config)# ip routing
D1(config)#

Configure el protocolo de enrutamiento OSPF para anunciar las redes VLAN 10 y VLAN 20, junto con la red que está conectada a R1. Observa el mensaje informándote de que se ha establecido una adyacencia con R1.

D1(config)# router ospf 10
D1(config-router)# network 192.168.10.0 0.0.0.255 area 0
D1(config-router)# network 192.168.20.0 0.0.0.255 area 0
D1(config-router)# network 10.10.10.0 0.0.0.3 area 0
D1(config-router)# ^Z
D1#
*Sep 17 13:52:51.163: %OSPF-5-ADJCHG: Process 10, Nbr 10.20.20.1 on GigabitEthernet1/0/1 from LOADING to FULL, Loading Done
D1#

Verifica la tabla de enrutamiento en D1. Observa que D1 ahora tiene una ruta a la red 10.20.20.0/24.

D1# show ip route | begin Gateway
Gateway of last resort is not set
      10.0.0.0/8 is variably subnetted, 3 subnets, 3 masks
C        10.10.10.0/30 is directly connected, GigabitEthernet1/0/1
L        10.10.10.2/32 is directly connected, GigabitEthernet1/0/1
O        10.20.20.0/24 [110/2] via 10.10.10.1, 00:00:06, GigabitEthernet1/0/1
      192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.10.0/24 is directly connected, Vlan10
L        192.168.10.1/32 is directly connected, Vlan10
      192.168.20.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.20.0/24 is directly connected, Vlan20
L        192.168.20.1/32 is directly connected, Vlan20
D1#

En este momento, PC1 y PC2 pueden hacer ping al servidor conectado a R1.

C:\Users\PC1> ping 10.20.20.254
Pinging 10.20.20.254 with 32 bytes of data: 
Request timed out.
Reply from 10.20.20.254: bytes=32 time<1ms TTL=127
Reply from 10.20.20.254: bytes=32 time<1ms TTL=127
Reply from 10.20.20.254: bytes=32 time<1ms TTL=127
Ping statistics for 10.20.20.254:
    Packets: Sent = 4, Received = 3, Lost = 1 (25% loss).
Approximate round trip times in milli-seconds: 
    Minimum = 1ms, Maximum = 2ms, Average = 1ms 
C:\Users\PC1>
!==================================================
C:\Users\PC2> ping 10.20.20.254
Pinging 10.20.20.254 with 32 bytes of data: 
Reply from 10.20.20.254: bytes=32 time<1ms TTL=127
Reply from 10.20.20.254: bytes=32 time<1ms TTL=127
Reply from 10.20.20.254: bytes=32 time<1ms TTL=127
Reply from 10.20.20.254: bytes=32 time<1ms TTL=127
Ping statistics for 10.20.20.254:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss).
Approximate round trip times in milli-seconds: 
    Minimum = 1ms, Maximum = 2ms, Average = 1ms
C:\Users\PC2>

8. Packet Tracer – Configurar Switch de Capa 3 con Routing Inter-VLAN

En esta actividad, configurarás switching de Capa 3 y Routing Inter-VLAN en un switch Cisco 3560.

Glosario: Si tienes dudas con algún término especial, puedes consultar este diccionario de redes informáticas.

¡Listo! Sigue visitando nuestro blog de curso de redes, dale Me Gusta a nuestra fanpage; y encontrarás más herramientas y conceptos que te convertirán en todo un profesional de redes.

Deja un Comentario

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.

¿Quieres aprobar la certificación Cisco CCNA?Sí, quiero!
+ +